View Issue Details

IDProjectCategoryView StatusLast Update
0002104CCdciel[All Projects] Generalpublic19-04-14 12:27
ReporterArieAssigned ToPatrick Chevalley 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version10 64bit
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0002104: Direct Mount guider and dither
DescriptionUsers of a 10Micron and ASA mount do not guide.
They however do wish to apply a dither between frames.
CCDCiel does not offer this option.
TagsNo tags attached.

Activities

Patrick Chevalley

19-03-27 09:09

administrator   ~0005495

Yes it is possible to add a dithering option.
Maybe in the Auto-guider tab when the software is set to None.

Patrick Chevalley

19-03-30 09:53

administrator   ~0005518

I start to implement this feature as a "Dither only" option in the Auto-guiding preference tab.

At the moment the configuration option are:
- the dither range in arcsecond, the actual dither is randomized in this range.
- a checkbox for RA only dither.

At the moment the function force the mount speed to 1x the sidereal rate.
Do this look good for you? or do you prefer to have a setting for the guide rate? or keep the configured speed without modification?

Arie

19-03-31 20:19

reporter   ~0005534

Last edited: 19-03-31 20:20

View 2 revisions

I posted the question on the 10Micron users forum, but did not get a reply yet.
Do as you feel appropriate. Siderial sounds ok to me.
Give it an option to settle some seconds after the dither.

Patrick Chevalley

19-04-01 22:28

administrator   ~0005540

Here is a version you can use to test this functionality:
https://vega.ap-i.net/tmp/ccdciel-0.9.54-1512-windows-x32.exe

After you install this version open the Preferences/Auto-guiding.
Select "Dither only".
Set the maximum dithering range in arcseconds.
Check "RA only" if the mount as too much backlash in declination, this is probably not necessary for your mount.

No need to use the Connect auto-guider button, also Guide and Calibrate do nothing. I still have to hide this buttons in this case.
But if you press the Dither button it must move the mount in a random fashion.
You can also try the dither option in a sequence.

Arie

19-04-01 23:02

reporter   ~0005541

Thank you. It is downloaded.
I am anxious to see how it will perform.
Right now I am experience problems with dithering from SGP via the direct mount guider option.
The mount counteracts the dither that was done inbetween exposures, during the next exposure.
This cause barred and double stars. When I set the dither time (they use seconds now) at the minimum 0,1 sec it is hardly noticable.
But at 5 or 10 sec I get long bars or even a smeared image.

Patrick Chevalley

19-04-02 20:40

administrator   ~0005543

It look like there is not enough wait for stabilization after the dither. I probably need to add a setting for that.
Another possibility is your mount driver do not report IsPulseGuiding=true when the dither move is in progress.
Let see how it work with CCDciel.

Arie

19-04-02 22:58

reporter   ~0005545

That is what I am finding out now too.
I never had this problem before.
When I set a settle time after the dither of >15 sec it is ok.
I can see on the hand controller that the dec is moving for 12-15 sec
If I set it at a shorter interval, SGP starts imaging while the mount is still moving......
Indeed a adjustable settle time after the dither is important for me.

Arie

19-04-02 23:02

reporter   ~0005546

FYI

command-protocol-v2.15.1.pdf (347,981 bytes)

Arie

19-04-03 12:04

reporter   ~0005548

I learned from the SGP forum, that after having send the dither command, the next exposure starts immediately, unless the user has set a settle delay after the dither. SGP does not check for any feedback from the mount still moving.

Patrick Chevalley

19-04-03 12:25

administrator   ~0005549

In CCDciel the current implementation is:
- send RA move
- if not RAONLY send DEC move
- wait for a maximum of 30 second the mount report it finish to move
- wait 5 seconds more

The maximum move you configure is in arcsecond, as it move at the sidereal speed of 15 arcsecond per second, you have to divide the value by 15 to find the time the move will take.
The maximum value you can set is 99 arcsecond this must be more than enough even with short focal length.

On your Rosette picture the dither move is way too big, normally a move by 5 pixel is more than enough.

Arie

19-04-03 14:14

reporter   ~0005551

I realize that it is very much. Why SGP offers this option I don't understand.
They go to from 0.1 all the way to 30 sec.
My guide speed sits at 0.5 siderial. Maybe if set this a lot slower the dithering will be less aggressive and the mount settling will be shorter. I have to test that. I could imagine that 10M has build in a gradual acceleration and deceleration.
I usually have the dithering set at 0.1 s.
That proved to be sufficient.
I took a series of 300x30s LRGB images last night without guiding and no dithering.
Total failure because of the typical "rain" noise after stacking in every channel.
So dithering is a must.

Arie

19-04-05 22:06

reporter   ~0005576

I tried the latest version you've send me (1512) to do a dither only test.
I select in the guider window "Dither only"
When I then "connect" the equipment, everything connects correctly but the guider grey dot remains gray.
When I press "dither"here, nothing happens.

Observation
When I want to look at the camera ascom driver, I need to disconnect ALL equipment.
It is not possible to disconnect the camera only, to change e,g, the gain or offset,

ScreenDithertest.JPG (302,723 bytes)
ScreenDithertest.JPG (302,723 bytes)

Arie

19-04-05 22:08

reporter   ~0005577

As mentioned before I think, a settle time after dither will be useful for many users.

Patrick Chevalley

19-04-05 23:03

administrator   ~0005579

It is expected the indicator stay gray because there is no connection required except the mount.
I just make the change in the interface to hide all the button except Dither.

In the guider options, do you set the value for "Dithering Arcseconds" because the default value is only 1 and this do only a 0.06 second pulse.
For the test you can set the maximum value of 99.

Then it depend on the telescope driver if the pulse guide command update the coordinates or not. So this can be difficult to see without a star in the camera.

Yes, I can add a button to disconnect the camera and open the setup.
This is something I forget because on Linux with INDI I not have this problem.
You can change the gain from the Preview or Capture tool, but not the offset because there is no ASCOM command for that.

OK to add a settle time in the config.

Arie

19-04-07 01:12

reporter   ~0005582

I ran a 15 image sequence with dither set at 99, as you advised.
When doing blink in ASTAP I see a minute movement in random directions of the stars between exposures.
The MountMonitor graph nor the hand controller display show a clear change.

I think the amount could be more than the current maximum.

Patrick Chevalley

19-04-08 14:32

administrator   ~0005584

This is strange because the big movement in your image of the Rosette is about 90 arcsecond so you must get something of the same order.

I make a few change to try to see what is doing.
- the dither value is no more limited, you can set any value.
- the dither value is now the mean value instead of the maximum.
- you can add a settle time after the move
- the light now reflect the state of the mount, yellow when the mount is connected, green when the mount is tracking, ready for a pulse guide.
- there is now error message if something go wrong with the pulse guide.
- if you select the "Verbose ASCOM log" option it show all the values for the guide rate and the pulse command it send to the mount.

You can download this new version from:
https://vega.ap-i.net/tmp/ccdciel-0.9.54-1534-windows-x32.exe

Be sure "Verbose ASCOM log" is checked in Preferences/Files.
This make a log like this:
4-08T14:02:44.621 3: telescope/0: GuideRateRightAscension = 0.004178
2019-04-08T14:02:44.621 3: telescope/0: PulseGuide, Direction=3, Duration=3259
2019-04-08T14:02:44.825 3: telescope/0: Set GuideRateDeclination = 0.004178
2019-04-08T14:02:47.140 3: telescope/0: GuideRateDeclination = 0.004178
2019-04-08T14:02:47.140 3: telescope/0: PulseGuide, Direction=1, Duration=2129
2019-04-08T14:02:48.061 3: telescope/0: IsPulseGuiding = True
2019-04-08T14:02:48.982 3: telescope/0: IsPulseGuiding = True
2019-04-08T14:02:49.697 3: telescope/0: IsPulseGuiding = True
2019-04-08T14:02:52.359 3: telescope/0: IsPulseGuiding = False

You can see the guide rate, the requested pulse duration for each axis in millisecond and the time it take for IsPulseGuiding to return to False.

You can do this test with the dome closed if necessary, just press the Dither button a few time and send me the log. The only requirement is the mount must be tracking.

Arie

19-04-08 22:02

reporter   ~0005587

3x5 exposures
dither set at 1000 99 and 50
I still cannot see any jumping stars between images.
On the HC I see during the dither a brief up down left or right arrow.
One only. They are random though.
In the log for all three dither settings the number seem to be identical.
The duration is 50 in all cases despite the substantial difference in dither setting.

Log_20190408_214341.log (43,141 bytes)

Patrick Chevalley

19-04-09 09:05

administrator   ~0005588

Thank you for the test and the log.

Your ASCOM driver is not conform to the ASCOM telescope specification.
ASCOM require the guide rate value to be in degree/second, but your driver respond 7.5 which is manifestly 0.5xsidereal in arcsecond/second. This make CCDciel to compute a pulse duration that is 3600x smaller than required. Then it use 50ms because this the minimal value I set in the program.

The ASCOM telescope interface specification is here: https://ascom-standards.org/Help/Developer/html/P_ASCOM_DeviceInterface_ITelescopeV3_GuideRateRightAscension.htm

You must be sure you use the last version of the ASCOM driver and if this is the case you must report the problem to get a fix for the driver.
Otherwise you will not get issue only with CCDciel, other software like PHD2 cannot work with this driver because they will also send pulse guide 3600x too small.

Patrick Chevalley

19-04-09 11:03

administrator   ~0005591

I re-read your previous notes, you say that SGP require you enter a guide duration directly for dithering. Can you confirm that?
Maybe this is to bypass this bug? maybe your mount driver is not alone with this error?

Do you think I can replace my "dithering range in arcsecond" to "dither pulse duration" in the CCDciel preference?
This way I not need to read or set the guide rate, I apply this duration as is.

Arie

19-04-09 13:46

reporter   ~0005592

I have 3 different ascom drivers for this mount.
So far I have been using the official 10M ascom driver.
But there are 2 other ones written by users themselves.
These have slightly different characteristics.
Let me test those too. See what happens.
If they perform well I'll forward your comment to the 10Micron software developer.


Typical, I first had dither issues with SGP which proves to be a bug in their software.
10Micron cannot explain however why DEC and RA react differently on a similar command from their ascom driver to the mount.
They are investigating their ascom driver for a possible bug too.

Bugs everywhere !! :-))

Attached the screen where you select the dither.
It ranges from 0,1s to 30s.

Dither10s.JPG (55,641 bytes)
Dither10s.JPG (55,641 bytes)
Dither30s.JPG (56,316 bytes)
Dither30s.JPG (56,316 bytes)
Dither01s.JPG (54,856 bytes)
Dither01s.JPG (54,856 bytes)

Patrick Chevalley

19-04-09 14:13

administrator   ~0005593

Ok, I will make the change to set the duration directly in the preferences and send you a version for testing.

It is expected the star do not move by the same amount in RA and DEC if you send the same pulse duration at the same guide rate.
This is because the RA movement in the image is multiplied by the cosine of the declination, i.e multiplied by 0.5 if you image at a declination of 60°
I will try to also correct for that, but with some limit to prevent very long duration if you image near the pole. For example at a declination of 89° to get the same movement than a 10 sec. DEC pulse you need a 10 minutes RA pulse.

Arie

19-04-09 14:35

reporter   ~0005594

Please keep it simple.
What about dithering in 1 direction only, but alternating DEC an RA?
No combined signals, but one at the time, randomly changing direction.

FYI
I just posted your comment on the 10M ascom driver on their forum.

Patrick Chevalley

19-04-09 15:14

administrator   ~0005595

Yes, it is more simple now I not have to get the guide rate from the mount.

Please test the new version:
https://vega.ap-i.net/tmp/ccdciel-0.9.54-1538-windows-x32.exe

Before to test the dithering be sure you review the options to set a duration between 5 and 10 seconds. This is a mean duration, so the actual random pulse can be from 0.05 to the double of this value.
A random dithering is very important to prevent noise pattern.
Normally your mount can move both axis at the same time so there is no problem to move both.

This version also implement the change for the focuser and filter wheel.

Arie

19-04-10 23:55

reporter   ~0005598

Hi,
CCDCiel's developer is right. The ASCOM driver returns the guide rates in arcsec/s instead of degrees/s. Nobody noticed this bug before.
An updated ASCOM driver is almost ready.
Sorry for the inconvenience.
Please, try with the new ASCOM driver
Filippo Riccio
sviluppatore software 10micron
10micron software developer

Patrick Chevalley

19-04-11 08:50

administrator   ~0005599

Please send all my thanks to Filippo Riccio for the prompt correction.
I find trace of this issue in past PHD2 discussion but it look like no one care to report because you can override the step size value in the configuration.

Now I am hesitant to what to put in the dither config.
For me the size in arcsecond was more simple because you just have to multiply the pixel scale by the number of pixel to dither.
But on the other side you are accustomed to give directly a duration.

Maybe I can have a checkbox to get the value from the driver, as I do for the camera pixel size or the telescope focal length, and if unchecked let you enter the duration value.

Patrick Chevalley

19-04-14 12:27

administrator   ~0005600

For simplicity it is probably better to keep the current setting of dither pulse duration in seconds.
I just make an additional change to use better text to describe the functionality in the Preferences.

I close the issue now but please re-open if you have any difficulties with this function.

Issue History

Date Modified Username Field Change
19-03-27 02:29 Arie New Issue
19-03-27 09:09 Patrick Chevalley Assigned To => Patrick Chevalley
19-03-27 09:09 Patrick Chevalley Status new => assigned
19-03-27 09:09 Patrick Chevalley Target Version => 1.0
19-03-27 09:09 Patrick Chevalley Note Added: 0005495
19-03-30 09:53 Patrick Chevalley Status assigned => feedback
19-03-30 09:53 Patrick Chevalley Note Added: 0005518
19-03-31 20:19 Arie Note Added: 0005534
19-03-31 20:19 Arie Status feedback => assigned
19-03-31 20:20 Arie Note Edited: 0005534 View Revisions
19-04-01 22:28 Patrick Chevalley Status assigned => feedback
19-04-01 22:28 Patrick Chevalley Note Added: 0005540
19-04-01 23:02 Arie File Added: rosette nebula_30sec_1x1_L_frame5-9small.jpg
19-04-01 23:02 Arie Note Added: 0005541
19-04-01 23:02 Arie Status feedback => assigned
19-04-02 20:40 Patrick Chevalley Note Added: 0005543
19-04-02 22:58 Arie Note Added: 0005545
19-04-02 23:02 Arie File Added: command-protocol-v2.15.1.pdf
19-04-02 23:02 Arie Note Added: 0005546
19-04-03 12:04 Arie Note Added: 0005548
19-04-03 12:25 Patrick Chevalley Note Added: 0005549
19-04-03 14:14 Arie Note Added: 0005551
19-04-05 22:06 Arie File Added: ScreenDithertest.JPG
19-04-05 22:06 Arie Note Added: 0005576
19-04-05 22:08 Arie Note Added: 0005577
19-04-05 23:03 Patrick Chevalley Note Added: 0005579
19-04-07 01:12 Arie Note Added: 0005582
19-04-08 14:32 Patrick Chevalley Status assigned => feedback
19-04-08 14:32 Patrick Chevalley Note Added: 0005584
19-04-08 22:02 Arie File Added: Log_20190408_214341.log
19-04-08 22:02 Arie Note Added: 0005587
19-04-08 22:02 Arie Status feedback => assigned
19-04-09 09:05 Patrick Chevalley Note Added: 0005588
19-04-09 11:03 Patrick Chevalley Note Added: 0005591
19-04-09 13:46 Arie File Added: Dither10s.JPG
19-04-09 13:46 Arie File Added: Dither30s.JPG
19-04-09 13:46 Arie File Added: Dither01s.JPG
19-04-09 13:46 Arie Note Added: 0005592
19-04-09 14:13 Patrick Chevalley Note Added: 0005593
19-04-09 14:35 Arie Note Added: 0005594
19-04-09 15:14 Patrick Chevalley Note Added: 0005595
19-04-10 23:55 Arie Note Added: 0005598
19-04-11 08:50 Patrick Chevalley Note Added: 0005599
19-04-14 12:27 Patrick Chevalley Status assigned => resolved
19-04-14 12:27 Patrick Chevalley Resolution open => fixed
19-04-14 12:27 Patrick Chevalley Note Added: 0005600