View Issue Details

IDProjectCategoryView StatusLast Update
0002108CCdciel[All Projects] Generalpublic19-04-10 17:54
ReporterhanAssigned ToPatrick Chevalley 
PrioritynormalSeveritytweakReproducibilityrandom
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version 
Summary0002108: EQASCOM sometimes tracking is off.
DescriptionMaybe once in the three clear nights the EQASCOM tracking is suddenly off. This is a little annoying. It happens after slewing and slewing is only allowed with tracking=on. It becomes visible if CCDCIEL tries to focus. EQACOM is at the latest version. Connection is to mount is blue tooth.

Maybe a check on tracking could help but it should not be required.

Any idea what could be the cause? If not then just close issue


TagsNo tags attached.

Activities

Patrick Chevalley

19-03-30 22:33

administrator   ~0005525

Can you see in the log if ccdciel ask to stop tracking? it must do that when waiting to start the next target in the sequence. But it must restart immediately if there is no wait time.
Also the slew() procedure start tracking if it is not active.
Otherwise the eqmod ascom log can help to find the issue.

han

19-03-31 00:25

reporter   ~0005527

Last edited: 19-03-31 00:28

View 2 revisions

I looked through the log and found at one location stop tracking due to sequence finished.

2019-03-05T22:56:41.675 1: Sequence 794-1622 finished.
2019-03-05T22:56:41.706 1: Executing the termination actions.
2019-03-05T22:56:41.721 1: Stop telescope tracking

This stop tracking is default checked in the sequence menu. Probably the safest option.

Normally i just modify sequence and the save them under a new name. No termination actions. So now I'm suspicious that this termination action in a few sequences is the cause of my problem. Strange enough if I start manually an autofocus action, there is no warning about tracking=off.

So is it not better to switch tracking on automatically when I start manually an autofocus? Same for capture and preview tools. These can be all executed with tracking=off. No warning or action to start tracking. Tracking is only visible in the EQASCOM menu?

Patrick Chevalley

19-03-31 11:54

administrator   ~0005528

At the moment tracking is restarted automatically when a new sequence is started, or a telescope slew is requested.
I agree this must be done automatically when starting a preview, capture, manual focus or autofocus. But at the moment you can start tracking manually from the Telescope tool.
You can also see the tracking status in the telescope tool. The Track button text is green wen tracking is active, red otherwise. You can click this button to start tracking.
See: https://www.ap-i.net/ccdciel/en/documentation/telescope_mount
Personally I have this tool always visible in the left of the screen to see this status and also for the time to meridian.

Patrick Chevalley

19-04-10 17:54

administrator   ~0005597

I make the change to restart mount tracking when preview, autofocus or manual focus is started.
It not change tracking when starting a capture because some capture like the sky flat require the mount to be stopped. This is not a problem because the sequence already start the mount tracking.

https://github.com/pchev/ccdciel/commit/703a3e2684842053f610cee7deb17ee78f4a5a7b

Issue History

Date Modified Username Field Change
19-03-30 21:12 han New Issue
19-03-30 22:33 Patrick Chevalley Assigned To => Patrick Chevalley
19-03-30 22:33 Patrick Chevalley Status new => assigned
19-03-30 22:33 Patrick Chevalley Note Added: 0005525
19-03-31 00:25 han Note Added: 0005527
19-03-31 00:28 han Note Edited: 0005527 View Revisions
19-03-31 11:54 Patrick Chevalley Note Added: 0005528
19-04-10 17:54 Patrick Chevalley Status assigned => resolved
19-04-10 17:54 Patrick Chevalley Resolution open => fixed
19-04-10 17:54 Patrick Chevalley Target Version => 1.0
19-04-10 17:54 Patrick Chevalley Note Added: 0005597