View Issue Details

IDProjectCategoryView StatusLast Update
0002109CCdciel[All Projects] Generalpublic19-04-01 20:58
ReporterThomas JaegerAssigned ToPatrick Chevalley 
PrioritylowSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSLinuxOS Version64bit
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0002109: A frame length of 0s results in a false log
DescriptionI wanted to do a lot of bias and darks without my telescope. A sequence with an unconnected focuser won't start with the error: "Some devices are not connected". So I made a new equipment profile only with the camera and filterwheel. Is this the right way?

Than I changed an existing plan to do only bias and darks. It is shown in the attachment. Setting the bias time to zero results in a fancy log statement:

2019-03-31T20:29:42.279 1: Starting Bias exposure 1/161 for 300 seconds

but the saved image had the right exposure time.
Changing the exposure time greater than zero, than the log was right.

The 300 came from the previous plan.

This is only for informational purposes, no need to fix.

Thomas

TagsNo tags attached.

Activities

Thomas Jaeger

19-03-31 20:52

reporter  

Log_20190331_195916.log (6,008 bytes)

Patrick Chevalley

19-04-01 20:58

administrator   ~0005538

Thank you to report this problem.
I was setting the exposure time only if it is strictly greater than zero because all the camera I use and the simulator do not accept a time of zero, they show an error message the minimum value is 0.001.

This is fixed and will be available in the next version.
https://github.com/pchev/ccdciel/commit/22270f202665462d6ab0a9b37e96cd2632e654c6

Issue History

Date Modified Username Field Change
19-03-31 20:52 Thomas Jaeger New Issue
19-03-31 20:52 Thomas Jaeger File Added: Bildschirmfoto vom 2019-03-31 20-31-09.png
19-03-31 20:52 Thomas Jaeger File Added: Log_20190331_195916.log
19-04-01 20:58 Patrick Chevalley Assigned To => Patrick Chevalley
19-04-01 20:58 Patrick Chevalley Status new => resolved
19-04-01 20:58 Patrick Chevalley Resolution open => fixed
19-04-01 20:58 Patrick Chevalley Target Version => 1.0
19-04-01 20:58 Patrick Chevalley Note Added: 0005538