View Issue Details

IDProjectCategoryView StatusLast Update
0002111CCdciel[All Projects] Generalpublic19-06-27 09:06
ReporterhanAssigned ToPatrick Chevalley 
PrioritynormalSeveritytweakReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version 
Summary0002111: Hints of buttons are not working
DescriptionThe hints of buttons in sequence editor are not working. The hint text is available but showhint=false, so it doesn't work in Windows.
TagsNo tags attached.

Activities

Patrick Chevalley

19-04-03 16:28

administrator   ~0005554

I set ShowHints to false when I started to translate the program to not put too much load for the translation. But I keep the hints themselves in the .lfm in the case I want to set them back.

The program already as 940 text to translate and this is a big work.
https://translations.launchpad.net/ccdciel

To return them to the program a first condition is to fix all the English text because a single letter change and you have to translate again.
Then maybe I can use another .po file that can be translated separately so it is more easy to start by translating the main program text first.

han

19-04-03 17:18

reporter   ~0005556

Yes translations is a lot of work. This webpage for translations is a powerful tool. You should be able to go quickly through the list and there are suggestion already. Maybe when I have nothing to do, but hopefully more volunteers will assist.

Patrick Chevalley

19-06-18 07:59

administrator   ~0005700

Hints are now reactivated and I am working to make them translatable.
There is a new option in the Preference to show or not the hints.

Thomas Jaeger

19-06-20 11:10

reporter   ~0005706

As a nativ german speaker :-) It is no problem for me to translate CCDCiel to german. Surprise, my old UbuntuOne Account works on launchpad. I was able to translate single items, but had no success doing it page for page, that results in a lauchnpad error. Another way that worked was to download a *.po file upload it again.
Should I do this oder wait?

Patrick Chevalley

19-06-20 13:30

administrator   ~0005707

Hi Thomas,
This is nice if you can do the German translation!

Sometime Launchpad give timeout error but this is not related to a specific action. Probably some issue with the server themselves.

Be sure to edit only "ccdciel" for now, not "ccdciel-hints" because it is still incomplete.

I always use the web interface to edit the translation page by page and it work. If you get an error after saving a page it usually work to reload the page and accept to send the form data again.

You can also download, translate locally and upload the .po file. But I am not sure what it do if I update the template in the mean time. If you prefer to work this way be sure to upload your work regularly and download again before a new editing.
It can help to use a tool like poedit or lokalize to edit the .po file.

Patrick Chevalley

19-06-27 09:06

administrator   ~0005722

Hints are now working and it is possible to translate them.

Issue History

Date Modified Username Field Change
19-04-03 13:53 han New Issue
19-04-03 16:28 Patrick Chevalley Assigned To => Patrick Chevalley
19-04-03 16:28 Patrick Chevalley Status new => assigned
19-04-03 16:28 Patrick Chevalley Target Version => 1.2
19-04-03 16:28 Patrick Chevalley Note Added: 0005554
19-04-03 17:18 han Note Added: 0005556
19-06-18 07:59 Patrick Chevalley Target Version 1.2 => 1.0
19-06-18 07:59 Patrick Chevalley Note Added: 0005700
19-06-20 11:10 Thomas Jaeger Note Added: 0005706
19-06-20 13:30 Patrick Chevalley Note Added: 0005707
19-06-27 09:06 Patrick Chevalley Status assigned => resolved
19-06-27 09:06 Patrick Chevalley Resolution open => fixed
19-06-27 09:06 Patrick Chevalley Note Added: 0005722