View Issue Details

IDProjectCategoryView StatusLast Update
0002128CCdciel[All Projects] Generalpublic19-05-02 14:55
ReporterThomas JaegerAssigned ToPatrick Chevalley 
PrioritylowSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
PlatformPCOSLinuxOS Version64bit
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0002128: Display an saturated image as white, not as black
DescriptionThis has very low priority.
An complete saturated image is shown as white on my screen. I expected that it would be black.
This behavour can be confusing to new users.
Thomas
TagsNo tags attached.

Activities

Thomas Jaeger

19-05-01 20:59

reporter  

Patrick Chevalley

19-05-02 12:27

administrator   ~0005624

Yes, it draw a black image if the minimal and maximal intensity are equal. This is also what other FITS viewer like DS9 do.

I agree a saturated image must be draw as white but this is a more difficult problem than it look like.
For example the saturation for a 12bit camera is 4096, so when you open a FITS file with a uniform level at 4096 how to detect if it is a saturated image from a 12bit camera, or a black image from a 16bit camera?
The only case this can be solved is when taken a new image from the camera and the camera MAXADU value is available. Then it can be draw a black if the level is less than MAXADU/2 and white greater.

Maybe a simpler approach it to consider it is impossible to get a all zero image because of reading noise, so if the value are uniform it is probably a saturated image, and always drawing the image as white make sens.

Patrick Chevalley

19-05-02 14:55

administrator   ~0005631

I find a simple fix that must be satisfactory.
Now an image filled with 0 is show as black, an image filled with any other value is show as white.
And this also fix the overflow/underflow indicator for this kind of images.

https://github.com/pchev/ccdciel/commit/cd2a38fad4e986d79cff4162a18a3962c52df267

Issue History

Date Modified Username Field Change
19-05-01 20:59 Thomas Jaeger New Issue
19-05-01 20:59 Thomas Jaeger File Added: Bildschirmfoto vom 2019-05-01 20-54-23.png
19-05-02 12:27 Patrick Chevalley Assigned To => Patrick Chevalley
19-05-02 12:27 Patrick Chevalley Status new => assigned
19-05-02 12:27 Patrick Chevalley Target Version => 1.0
19-05-02 12:27 Patrick Chevalley Note Added: 0005624
19-05-02 14:55 Patrick Chevalley Status assigned => resolved
19-05-02 14:55 Patrick Chevalley Resolution open => fixed
19-05-02 14:55 Patrick Chevalley Note Added: 0005631