View Issue Details

IDProjectCategoryView StatusLast Update
0002142CCdciel[All Projects] Generalpublic19-06-16 19:30
ReporterThomas StiborAssigned ToPatrick Chevalley 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformPCOSLinuxOS Version64bit
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0002142: Show SNR value in Star Profile window
DescriptionIn Star profile window, the values:
HFD, FWHM and Intensity are calculated and displayed.
It would great and a valuable feature showing there also the SNR value.
TagsNo tags attached.

Activities

Thomas Stibor

19-06-15 21:57

reporter  

starprofile.png (44,717 bytes)
starprofile.png (44,717 bytes)

Patrick Chevalley

19-06-16 08:18

administrator   ~0005697

Good idea.

This is added by:
https://github.com/pchev/ccdciel/commit/305b004ca2bb5d08d7c8de8b4c19a4a1177ef673

Thomas Stibor

19-06-16 09:41

reporter   ~0005698

Thanks Patricks, works perfectly.
Just one minor issue, shouldn't the 'Hint' be:

Hint = 'The SNR value', rather than

+ object LabelSNR: TLabel
+ Left = 125
+ Height = 22
+ Hint = 'The maximum intensity value'
+ Top = 86
+ Width = 6
+ Caption = ' '
+ Font.Height = 18
+ Font.Style = [fsBold]
+ ParentColor = False
+ ParentFont = False
+ end

Patrick Chevalley

19-06-16 19:30

administrator   ~0005699

Yes, a copy/past error.
This is fixed by : https://github.com/pchev/ccdciel/commit/1ceb6ce2d366224bc8d1fc264008ba042c0bbab6

But this not change anything for now because hints are not active until I implement a solution to not increase the translation load too much. See https://www.ap-i.net/mantis/view.php?id=2111

Issue History

Date Modified Username Field Change
19-06-15 21:57 Thomas Stibor New Issue
19-06-15 21:57 Thomas Stibor File Added: starprofile.png
19-06-16 08:18 Patrick Chevalley Assigned To => Patrick Chevalley
19-06-16 08:18 Patrick Chevalley Status new => resolved
19-06-16 08:18 Patrick Chevalley Resolution open => fixed
19-06-16 08:18 Patrick Chevalley Target Version => 1.0
19-06-16 08:18 Patrick Chevalley Note Added: 0005697
19-06-16 09:41 Thomas Stibor Status resolved => new
19-06-16 09:41 Thomas Stibor Resolution fixed => reopened
19-06-16 09:41 Thomas Stibor Note Added: 0005698
19-06-16 19:30 Patrick Chevalley Status new => resolved
19-06-16 19:30 Patrick Chevalley Resolution reopened => fixed
19-06-16 19:30 Patrick Chevalley Note Added: 0005699