View Issue Details

IDProjectCategoryView StatusLast Update
0002146CCdciel[All Projects] Generalpublic19-06-26 23:13
ReporterPeter BartelloAssigned ToPatrick Chevalley 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSLinuxOS Version64bit
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0002146: Crashes on equipment connection (Avalon mount, Pegasus focuser, ZWO cam).
DescriptionCrashes on equipment connection (Avalon mount, Pegasus focuser, ZWO cam) using Linux Mint 18.3 KDE on 2 different computers; one localhost and the other remotely. CCDciel begins responsively until connect is pushed, then freezes.

Connecting only Avalon mount & ZWO cam works fine.
 
Steps To ReproduceExact same behaviour every time. Same problem using 0.9.57-1587 and 0.9.57-1611.
Additional InformationWas asked in the user group to register an issue here. Patrick wrote "I need to send you a special version with more tracing".
TagsNo tags attached.

Activities

Patrick Chevalley

19-06-25 21:11

administrator   ~0005714

Thank you to open the issue here.

Just a link to the previous discussion for reference:
https://groups.io/g/ccdciel/topic/new_focuser_no_happiness/32189428

I make a test version that log every INDI data processing from CCCciel.
https://vega.ap-i.net/tmp/ccdciel_0.9.57-1611test1_amd64.deb

When you run this special version it produce 6 files indi_*.log in /tmp with detail of the protocol for the camera and the focuser.
Please run the same test as previously, be sure to click Disconnect and exit CCDciel to flush the log files, then tar them and upload the file here.

Be careful to not take picture with this version because it will log all the image data and may exhaust the disk space in /tmp

Peter Bartello

19-06-25 23:30

reporter   ~0005715

There is a problem here, Patrick. CCDciel is totally unresponsive after I click connect. As I wrote earlier "When I click 'connect', cam, mount & focuser all turn yellow, then mount and focuser turn green. The camera never changes from yellow and the programme goes totally unresponsive. Flatline." So I can't "be sure to click Disconnect and exit CCDciel to flush the log files". In fact, ctrl-c is all I can do to kill ccdciel. Even the usual OS window message that it is unresponsive with option to kill, fails to kill it.

Also, after I hit connect in ccdciel and it freezes, indistarter and the indi gui both go unresponsive too.

As a result, log files are incomplete. In fact indi_(camera/focuser)_error.log are of length zero. The other files were continuing to get bigger when I hit ctrl-c. I tarred them up anyway, in case you can find a clue inside.

As always, thanks for your help, Peter

detailed-logs.tar.gz (22,984 bytes)

Peter Bartello

19-06-25 23:32

reporter   ~0005716

PS: don't worry about my taking any pictures. It's raining here in Montréal !

Patrick Chevalley

19-06-26 10:34

administrator   ~0005717

Thank you.

I remark something abnormal with the request to load the default configuration that occur too early.
This is fixed in this new test version:
https://vega.ap-i.net/tmp/ccdciel_0.9.57-1611test2_amd64.deb

Can you install it and test as before and upload the logs.

I am also interested by the same log when you not connect the focuser and the camera finish it's initialization .

And finally another test with the 3 devices but for each go the the device setup and uncheck "Load configuration on startup", also upload the log for this test.
Make a tar file after each test because the log files are reset at every connection.

Patrick Chevalley

19-06-26 11:45

administrator   ~0005718

Another question, when it work without the focuser, is the focuser connected to the computer? and the driver active in indistarter or not?

Can you try both case without the focuser on the computer, and started in indi but unchecked in CCdciel device setup. Do it make a difference?

Peter Bartello

19-06-26 16:01

reporter   ~0005720

Great news, Patrick:

> ... test with the 3 devices but for each go the the device setup and
> uncheck "Load configuration on startup" ...

This solves my problem. I have tested with all my equipment, localhost, remotely, connecting to cartes du ciel, phd2, my Touptek guidecam, etc. Everything works! Thank you sir.

I seem to recall that "Load configuration on startup" was checked by default? What does it mean? Load what, when what is starting up? You still have to click on connect. Not understanding these things I didn't touch it. This worked fine for me for about a year (before I bought a focus motor). It looks like the meaning of this could be clarified in the documentation. Let me know if I can help. It would be my pleasure.

I found success in my test 4, described below. For the record I will post my complete response to your previous request for some testing.

All tests below were performed with ccdciel_0.9.57-1611test2. After each test I cleared out the /tmp/indi_*.log files and rebooted.

Test 1: mount, camera and focuser connected to both indistarter and in the ccdciel device profile. Like my previous test of 25 June, except using ccdciel_0.9.57-1611test2 instead of ccdciel_0.9.57-1611test1. Result: it freezes as before.

Test 2: my pre-focuser set-up that worked well for about a year. Mount and camera connected on indistarter and requested in ccdciel device set-up. Focuser not plugged in. Result: works perfectly. I took a picture, gracefully disconnected and quit the programme.

Test 3: as in test 2, except that the focuser is now plugged in and connected on indistarter, but is not part of the ccdciel device profile. Result: works perfectly! I took a picture, gracefully disconnected and quit the programme.

Test 4: test with the 3 devices, but for each I went to the ccdciel device setup and unchecked "Load configuration on startup". Result: works perfectly. I took a picture, gracefully disconnected and quit the programme.
 
Let me know if you need more tests or clarifications on what I did already. Sorry for the trouble.

Peter

test1.tar.gz (17,807 bytes)
test3.tar.gz (1,154,821 bytes)
test4.tar.gz (1,157,724 bytes)
test2.tar.gz (1,155,386 bytes)

Patrick Chevalley

19-06-26 23:13

administrator   ~0005721

Very good!

Yes this option must be off by default because it require you first save the configuration from the INDI panel.
In your case it probably load a conflicting option that cause this issue.
I have updated the documentation:
https://www.ap-i.net/ccdciel/en/documentation/devices_setup#indi_devices

And the option is now off by default:
https://github.com/pchev/ccdciel/commit/4a2c4a78a7ac7e52ae19ba877656392b6a2790f0

Anyway it is good if you save good option for the INDI devices.
When everything is connected and working open the INDI panel, for each device open the Options tab, on the Configuration row click the button Save.

I will make a new version tomorrow with this changes.

Thank you for your help!

Issue History

Date Modified Username Field Change
19-06-25 20:14 Peter Bartello New Issue
19-06-25 21:11 Patrick Chevalley Assigned To => Patrick Chevalley
19-06-25 21:11 Patrick Chevalley Status new => feedback
19-06-25 21:11 Patrick Chevalley Target Version => 1.0
19-06-25 21:11 Patrick Chevalley Note Added: 0005714
19-06-25 23:30 Peter Bartello File Added: detailed-logs.tar.gz
19-06-25 23:30 Peter Bartello Note Added: 0005715
19-06-25 23:30 Peter Bartello Status feedback => assigned
19-06-25 23:32 Peter Bartello Note Added: 0005716
19-06-26 10:34 Patrick Chevalley Status assigned => feedback
19-06-26 10:34 Patrick Chevalley Note Added: 0005717
19-06-26 11:45 Patrick Chevalley Note Added: 0005718
19-06-26 16:01 Peter Bartello File Added: test1.tar.gz
19-06-26 16:01 Peter Bartello File Added: test2.tar.gz
19-06-26 16:01 Peter Bartello File Added: test3.tar.gz
19-06-26 16:01 Peter Bartello File Added: test4.tar.gz
19-06-26 16:01 Peter Bartello Note Added: 0005720
19-06-26 16:01 Peter Bartello Status feedback => assigned
19-06-26 23:13 Patrick Chevalley Status assigned => resolved
19-06-26 23:13 Patrick Chevalley Resolution open => fixed
19-06-26 23:13 Patrick Chevalley Note Added: 0005721