View Issue Details

IDProjectCategoryView StatusLast Update
0002150CCdciel[All Projects] Generalpublic19-08-04 10:03
ReporterThomas JaegerAssigned ToPatrick Chevalley 
PrioritylowSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0002150: German Translation finished
DescriptionHello Patrick,
I have just finished the german translation of CCDCiel.

Only two small things in the hints:

#: u_hints:rsusevcurvewit
It is ok that V-Curve ist the default methode for absolut focusers, but I think "dynamic" should also advertised for this type of focusers, not only for relative position focusers.

#: u_hints:rslistofprofil
msgid "List of profile for every different equipement configuration"

> equipment

Thomas
TagsNo tags attached.

Activities

Patrick Chevalley

19-07-07 17:12

administrator   ~0005744

Hi Thomas,

Thank you very much for this big work with the translation!

Yes, some hint may need an update.
The problem when updating the English text is it invalidate all the translation. So it is best to do it as quickly as possible before there is too much translation.

I have fixed this two text, tell me if it is OK.
https://github.com/pchev/ccdciel/commit/e79dcf36dd6b0620e9916722741fe5b53e69ca1c

Thomas Jaeger

19-07-07 17:42

reporter   ~0005746

Sure, it is all right. Finished.
Thomas

Patrick Chevalley

19-07-07 18:42

administrator   ~0005748

Thank you.

I have updated all the translation in source:
https://github.com/pchev/ccdciel/commit/f4b35f416a1ea059b193e608ef9d8b2e9a1a6fa7

I have also fixed all the string that where marked with #, fuzzy,badformat in all the language.
This was because of incomplete %s for string replacement. The translation is not used if the number of replacement position do not match the original.
Now this is good in all the languages.

Thomas Jaeger

19-07-17 17:30

reporter   ~0005776

Hello Patrick,
I have installed CCDCiel Version 0.9.59-1621 and can see my german translation. Some menus and buttons are still in english. In launchpad I have got 100% coverage. Is this a issue to search for, or should I still wait?
Thomas

Patrick Chevalley

19-07-17 21:15

administrator   ~0005777

Hello Thomas,

It is possible I forget to add the translation for some text, specifically if the text is the same in English and French.
But it is expected the German translation in 0.9.59 is not complete, from the message above I update the source in July 7, but 0.9.59 was released on June 29.

Can you try with this version I just build with the last code to check if the text are still missing?
https://vega.ap-i.net/tmp/ccdciel_0.9.59-1650_amd64.deb

Thomas Jaeger

19-07-18 19:31

reporter   ~0005779

Hello Patrick,
I tried the last code you mentioned. It is much better. I found four remaining things, which are not on launchpad:
> Import CdC observing list
> Show hints
> Verbose ASCOM log (Button)
> Dome (in Preference Menu)

Sometimes german translation is a little bit longer. Maybe you can increase the textframe

Options/Autofocus/V Curve/Stay on place..
Options/Auto-guiding/Star lost recovery...
Options/Astrometry/Use custom script...

Thomas Jaeger

19-07-18 19:33

reporter   ~0005780

I have improved the german translation again. This was possible, because I saw may translation in real.
Thanks

Patrick Chevalley

19-08-02 16:53

administrator   ~0005813

Thomas,

I have corrected the points you mention for the missing text and the too small field. I also add a few more text you may want to translate.

You can use this version for testing:
https://vega.ap-i.net/tmp/ccdciel_0.9.59-1690_amd64.deb

Thomas Jaeger

19-08-02 19:53

reporter   ~0005814

Hello Patrick,
translation finished.
Please increase: Options/Astrometry/Use custom script
again about 3 letter space.

Patrick Chevalley

19-08-03 15:43

administrator   ~0005815

Thank you Thomas!

I have updated the translation file and increase the space for this text, now the full line is available and the input field appear on the next line only when the option is checked.

You can test with:
https://vega.ap-i.net/tmp/ccdciel_0.9.59-1693_amd64.deb

Thomas Jaeger

19-08-03 17:13

reporter   ~0005816

This is good. Test version works. You can close this thread.
Thomas

Issue History

Date Modified Username Field Change
19-07-06 14:14 Thomas Jaeger New Issue
19-07-07 17:12 Patrick Chevalley Assigned To => Patrick Chevalley
19-07-07 17:12 Patrick Chevalley Status new => assigned
19-07-07 17:12 Patrick Chevalley Target Version => 1.0
19-07-07 17:12 Patrick Chevalley Note Added: 0005744
19-07-07 17:42 Thomas Jaeger Note Added: 0005746
19-07-07 18:42 Patrick Chevalley Status assigned => resolved
19-07-07 18:42 Patrick Chevalley Resolution open => fixed
19-07-07 18:42 Patrick Chevalley Note Added: 0005748
19-07-17 17:30 Thomas Jaeger Status resolved => new
19-07-17 17:30 Thomas Jaeger Resolution fixed => reopened
19-07-17 17:30 Thomas Jaeger Note Added: 0005776
19-07-17 21:15 Patrick Chevalley Status new => feedback
19-07-17 21:15 Patrick Chevalley Note Added: 0005777
19-07-18 19:31 Thomas Jaeger Note Added: 0005779
19-07-18 19:31 Thomas Jaeger Status feedback => assigned
19-07-18 19:33 Thomas Jaeger Note Added: 0005780
19-08-02 16:53 Patrick Chevalley Note Added: 0005813
19-08-02 19:53 Thomas Jaeger File Added: Bildschirmfoto vom 2019-08-02 19-53-09.png
19-08-02 19:53 Thomas Jaeger Note Added: 0005814
19-08-03 15:43 Patrick Chevalley Note Added: 0005815
19-08-03 17:13 Thomas Jaeger Note Added: 0005816
19-08-04 10:03 Patrick Chevalley Status assigned => resolved
19-08-04 10:03 Patrick Chevalley Resolution reopened => fixed