View Issue Details

IDProjectCategoryView StatusLast Update
0002151CCdciel[All Projects] Generalpublic19-07-10 10:52
Reportertango13Assigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSLinuxOS Version64bit
Product Version 
Target Version1.0Fixed in Version 
Summary0002151: Preview moves mount
DescriptionHi Patrick,
yesterday I tested the 0.9.59 version under the stars and I had an annoying problem: every time I pushed the "Preview" button the mount seemed to receive a slew command.
Even though the move was small, I had to recenter the target so I was forced to not use the Preview function.
This is something I never experienced in previous versions.
Thank you.
TagsNo tags attached.

Activities

tango13

19-07-07 16:45

reporter   ~0005743

I forgot to say that it seemed a slew command because I could hear the "beep" from the mount like when slewing.

tango13

19-07-07 17:16

reporter   ~0005745

Please see attached files. Thanks

Devices_Log_20190706_215516.log (17,095 bytes)
Log_20190706_215516.log (12,354 bytes)

Patrick Chevalley

19-07-07 17:48

administrator   ~0005747

What was your previous version?
Because the change I suspect to produce this effect with your mount date back in April and is active since version 0.9.55.

This is because I add a command to start the mount tracking when starting the preview. This is because in some case, for example the end of a sequence, the tracking is stopped.

Normally the tracking for a INDI mount is managed by the TELESCOPE_TRACK_STATE property, this not make any move of the mount. But some driver do not implement this property and to start the tracking I have to send a slew command at the current coordinates. This can make a small offset because of the mount pointing precision and backlash.

Maybe the Ioptron driver implement this function with another name. Can you start the indi server with only the ioptron driver, use a INDI gui to connect the mount, then run the command indi_getprop and upload the result.



Patrick Chevalley

19-07-07 21:10

administrator   ~0005749

Hi,
No need to send this file.
I remark the driver as a simulation mode so I can test without the mount.

The problem is really this driver miss the setting for Tracking, I upload 2 screenshot that show the missing row in the zeq25 driver.

When I write this function I not think any current Indi driver will miss this property so I not tested this case.
Now I make a change to avoid to set tracking before the preview if this property is missing.
So you have to be sure tracking is on by using the Track button in the telescope tool before to start the preview.

You can test this change by installing this test version:
https://vega.ap-i.net/tmp/ccdciel_0.9.59-1636_amd64.deb

Please tell how it work with the real mount.

zeq25.png (27,235 bytes)
zeq25.png (27,235 bytes)
set_tracking.png (26,238 bytes)
set_tracking.png (26,238 bytes)

tango13

19-07-09 22:11

reporter   ~0005753

Thank you Patrick, it seems to work well as it used to, no slew and track commands issued anymore.
The strange thing is that the SmartEQ INDI driver shows the Tracking option in the INDI panel, whereas the ZEQ (which, incidentally, uses the same hand controller) does not.
Anyway, things are back to normal now.
Thank you very much!

Patrick Chevalley

19-07-10 10:51

administrator   ~0005754

Thank you for testing.

I don't know why this driver do not include this function and if other drivers also miss it.
Anyway it is good the program work correctly in this case.

Issue History

Date Modified Username Field Change
19-07-07 16:44 tango13 New Issue
19-07-07 16:45 tango13 Note Added: 0005743
19-07-07 17:16 tango13 File Added: Devices_Log_20190706_215516.log
19-07-07 17:16 tango13 File Added: Log_20190706_215516.log
19-07-07 17:16 tango13 Note Added: 0005745
19-07-07 17:48 Patrick Chevalley Assigned To => Patrick Chevalley
19-07-07 17:48 Patrick Chevalley Status new => feedback
19-07-07 17:48 Patrick Chevalley Target Version => 1.0
19-07-07 17:48 Patrick Chevalley Note Added: 0005747
19-07-07 21:10 Patrick Chevalley File Added: set_tracking.png
19-07-07 21:10 Patrick Chevalley File Added: zeq25.png
19-07-07 21:10 Patrick Chevalley Note Added: 0005749
19-07-09 22:11 tango13 Note Added: 0005753
19-07-09 22:11 tango13 Status feedback => assigned
19-07-10 10:51 Patrick Chevalley Note Added: 0005754
19-07-10 10:52 Patrick Chevalley Status assigned => resolved
19-07-10 10:52 Patrick Chevalley Resolution open => fixed