View Issue Details

IDProjectCategoryView StatusLast Update
0002159CCdciel[All Projects] Generalpublic19-08-01 17:13
ReporterhanAssigned ToPatrick Chevalley 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version 
Summary0002159: Autofocus chart
DescriptionGreat this new feature is wonderful to study focussing more in detail! No more cumbersome tricks to export data to a spreadsheet. :) :) Also the x-scale is now equal to focuser position.

Two wishes:

1) Is it possible to indicate star saturation (for single star) by changing the color of the graph marks or any other way. Saturation creates very noise graph but focusing is still reasonable okay. See second image.
2) Can the autofocus graph window stay "always in front"? While resizing it sometimes disappear behind CCDCiel
TagsNo tags attached.

Activities

han

19-07-26 23:33

reporter  

CCDciel curve.png (16,888 bytes)
CCDciel curve.png (16,888 bytes)

Patrick Chevalley

19-07-27 09:11

administrator   ~0005795

Nice graph!
I cannot do real testing because of cloud, probably not before tomorrow.

I have a few question about the saturation detection.
- Is the value show in the log for "peak" OK to detect the saturation: Autofocus running, hfd=6.3 peak:41018.9 snr:133.1
- There is two value in the setting related to saturation, the maxadu value returned by the camera and a "highlight adu" clipping indicator in the preview setting. I remember adding this second setting for cmos camera. Do I need to compare peak to "highlight adu" or maxadu here for your camera? with my ccd it not care because the two value are the same.

Patrick Chevalley

19-07-27 11:14

administrator   ~0005796

I do the change for saturation by comparing with clipping overflow, this is very easy to change if required. Doing that I remark the max value was not normalized when measuring multiple stars, this is fixed.
The graph form is now set to stay on top.
Another change I do is to stick the mouse position to the nearest point when inside the point circle, this allow to see the exact point value.
The "keep graph open" button is automatically checked when you double click the graph because it is likely you not want to close after a few seconds if you open it, save one click :)

https://github.com/pchev/ccdciel/commit/1549e4a0052784a1c28c8a98b79f014c97956bf3

Patrick Chevalley

19-07-27 11:43

administrator   ~0005797

For consistency I make another change: when you click the "keep graph open" button this is surely because you want to study the graph, so now it also open the graph window.

han

19-07-28 00:15

reporter   ~0005800

Patrick,

Thanks for the updates. Saturation, my camera saturated pixel values don't reach the value 65535. It stops around 65226. Partly because it has a 12 bit ADU. So to make the colour change to work you have to reduce ClippingOverflow with a small factor. E.g. as:

pu_main.pas, line 3052:
ClippingOverflow:=0.99*min(ClippingOverflow,MaxADU);

I also made a small change in pu_hyperbola.pas. The curve fit was using for the summation of all point errors. I changed it to error per point. This should make it more consistent if you use either 7 or 30 point for finding the focus. See attached updated pu_hyperbola.pas

pu_hyperbola.zip (2,620 bytes)

Patrick Chevalley

19-07-28 21:41

administrator   ~0005801

Han, I apply your change for the fit error display.

I think you see this difference in saturation intensity because the value I use for focus is the star intensity above background. When you see max value of 65226, this is probably because the background value is 309.
I make a change to add the background to the displayed value and the value I use to compare with ClippingOverflow, this must solve the problem.

han

19-07-30 22:50

reporter   ~0005803

Today there where some brief clear moments here. I have add some extra messaging in the code. After centering on a bright star, i get the results as below. The maximum value FValMax+bg is 65504. The ClippingOverflow is 65535. The bg value is pretty large since it still twilight, so not dark.

2019-07-30T22:38:36.353 3: ASCOM.USB_Focus.Focuser: Focuser move to 37047
2019-07-30T22:38:44.044 3: FValMax=62369.8215963989, bg=3134.17840360113, FValMax+bg=65504
2019-07-30T22:38:44.044 3: Autofocus running, hfd=8.7 peak:65504.0 snr:238.1
2019-07-30T22:38:44.059 3: ASCOM.USB_Focus.Focuser: Focuser move to 37247
2019-07-30T22:38:50.830 3: FValMax=62479.9879349966, bg=3024.01206500343, FValMax+bg=65504
2019-07-30T22:38:50.830 3: Autofocus running, hfd=8.1 peak:65504.0 snr:238.7
2019-07-30T22:38:50.830 3: ASCOM.USB_Focus.Focuser: Focuser move to 37447
2019-07-30T22:38:57.288 3: FValMax=62151.509594873, bg=3352.49040512703, FValMax+bg=65504
2019-07-30T22:38:57.288 3: Autofocus running, hfd=5.9 peak:65504.0 snr:236.9
2019-07-30T22:38:57.304 3: ASCOM.USB_Focus.Focuser: Focuser move to 37647
2019-07-30T22:39:04.105 3: FValMax=62400.406521706, bg=3103.59347829404, FValMax+bg=65504
2019-07-30T22:39:04.121 3: Autofocus running, hfd=7.0 peak:65504.0 snr:238.2
2019-07-30T22:39:04.121 3: ASCOM.USB_Focus.Focuser: Focuser move to 37847
2019-07-30T22:39:10.876 3: FValMax=62342.9961458763, bg=3161.00385412375, FValMax+bg=65504
2019-07-30T22:39:10.876 3: Autofocus running, hfd=6.6 peak:65504.0 snr:237.9
2019-07-30T22:39:10.876 3: ASCOM.USB_Focus.Focuser: Focuser move to 38047
2019-07-30T22:39:17.241 3: FValMax=62498.8571139086, bg=3005.1428860914, FValMax+bg=65504
2019-07-30T22:39:17.241 3: Autofocus running, hfd=8.4 peak:65504.0 snr:238.8
2019-07-30T22:39:17.241 3: ASCOM.USB_Focus.Focuser: Focuser move to 38247
2019-07-30T22:39:24.120 3: FValMax=62611.9918260472, bg=2892.00817395285, FValMax+bg=65504
2019-07-30T22:39:24.120 3: Autofocus running, hfd=9.6 peak:65504.0 snr:239.4
2019-07-30T22:39:24.136 3: ASCOM.USB_Focus.Focuser: Focuser move to 38447
2019-07-30T22:39:30.813 3: FValMax=62554.8535466545, bg=2949.14645334554, FValMax+bg=65504
2019-07-30T22:39:30.813 3: Autofocus running, hfd=10.3 peak:65504.0 snr:239.1
2019-07-30T22:39:30.813 3: ASCOM.USB_Focus.Focuser: Focuser move to 38647
2019-07-30T22:39:37.224 3: FValMax=37435.9442423133, bg=3580.05575768673, FValMax+bg=41016
2019-07-30T22:39:37.224 3: Autofocus running, hfd=8.2 peak:41016.0 snr:177.3
2019-07-30T22:39:37.240 3: ASCOM.USB_Focus.Focuser: Focuser move to 38847
2019-07-30T22:39:44.166 3: FValMax=7557.54134493019, bg=3610.45865506981, FValMax+bg=11168
2019-07-30T22:39:44.166 3: Autofocus running, hfd=9.5 peak:11168.0 snr:62.2
2019-07-30T22:39:44.166 3: ASCOM.USB_Focus.Focuser: Focuser move to 39047
2019-07-30T22:39:51.093 3: FValMax=59317.144698558, bg=3082.85530144198, FValMax+bg=62400
2019-07-30T22:39:51.093 3: Autofocus running, hfd=12.0 peak:62400.0 snr:231.8

han

19-07-31 09:56

reporter   ~0005804

I had a look to the collection of test images I keep for ASTAP. One other ZWO camera, the ASI294 has a maximum reading of 65532. So my camera with a 65504 max seems the worst. Introducing a factor of 0,999526 or lower will fix the colour change of the graph.

 QHY8L, CCDciel Version beta 0.9.23-773 ==> 65535

ZWO ASI294MC Pro, CCDciel Version beta 0.9.59-1621-27f63b5 ==> 65532

QHY8 (classic), CCDciel Version beta 0.9.53-873-7fbb56e ==> 65535

My ASI1600 ==>65504

Your camera Atik 314L CCD ==> 65535

Patrick Chevalley

19-07-31 16:59

administrator   ~0005806

Han,
You can change the value for ClippingOverflow in Preference/Preview, this is in "Highlight ADU", change the value to 65500 and it must work.

han

19-07-31 20:06

reporter   ~0005808

I didn't realise that option was available. But what I propose is to make it "novice" robust. If you multiply ClippingOverflow with 0.9995, the graph it will show default the saturation for any camera. All people with a ASI294MC or ASI1600 camera will never realise this indication in the graph is available and that they have to change the setting from 65535 to 65500 to make it work. That is something for the software developer to implement.

Patrick Chevalley

19-07-31 22:30

administrator   ~0005809

I agree, but I do it differently to prevent the value to decrease every time the program is started.
Can you test with this change:
https://github.com/pchev/ccdciel/commit/c83b0fba4d3895eea490387be284734273532ef9

han

19-08-01 10:16

reporter   ~0005811

Perfect.

Issue History

Date Modified Username Field Change
19-07-26 23:33 han New Issue
19-07-26 23:33 han File Added: CCDciel curve.png
19-07-26 23:33 han File Added: CCDciel curve highly saturated star.png
19-07-27 09:11 Patrick Chevalley Note Added: 0005795
19-07-27 11:14 Patrick Chevalley Note Added: 0005796
19-07-27 11:43 Patrick Chevalley Note Added: 0005797
19-07-28 00:15 han File Added: pu_hyperbola.zip
19-07-28 00:15 han Note Added: 0005800
19-07-28 21:41 Patrick Chevalley Note Added: 0005801
19-07-30 22:50 han Note Added: 0005803
19-07-31 09:56 han Note Added: 0005804
19-07-31 16:59 Patrick Chevalley Note Added: 0005806
19-07-31 20:06 han Note Added: 0005808
19-07-31 22:30 Patrick Chevalley Note Added: 0005809
19-08-01 10:16 han Note Added: 0005811
19-08-01 17:13 Patrick Chevalley Assigned To => Patrick Chevalley
19-08-01 17:13 Patrick Chevalley Status new => resolved
19-08-01 17:13 Patrick Chevalley Resolution open => fixed
19-08-01 17:13 Patrick Chevalley Target Version => 1.0