View Issue Details

IDProjectCategoryView StatusLast Update
0002187SkyChart1-Softwarepublic19-10-06 14:48
ReporterMartinAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSLinuxOS Version64bit
Product Version4.1 SVN 
Target Version4.2Fixed in Version4.1 SVN 
Summary0002187: Wrong moon illumination in twilight calendar
DescriptionThe moon illumination in the twilight calendar shows wrong values for days before full moon depending on which start date is being selected. It looks like the values for the two days before full moon are taken from the 3rd day before full moon. This leads to 0.91 if that day is included (picture 1) while it's 0.00 if that day is not included (picture 2).

It looks like for some cities (e.g. Stuttgart, Germany), setting the date of three or more days before full moon doesn't show the issue in the first picture (but the second showing 0.00 still remains)
Steps To Reproduce1. Select location, set date/time to "tonight"
2. Open Ephemerisis Calendar
3. Select date range for 2019-09-11 or 2019-09-10
4. refresh
Additional Informationversion 4.1.1 beta 2019-09-09 fb1bbbcb
TagsNo tags attached.

Activities

Martin

19-09-12 13:14

reporter  

cdc_twilight_1.jpg (153,763 bytes)
cdc_twilight_1.jpg (153,763 bytes)
cdc_twilight_2.jpg (123,967 bytes)
cdc_twilight_2.jpg (123,967 bytes)

Patrick Chevalley

19-09-14 17:36

administrator   ~0005941

Thank you to report this issue, I can confirm the value is wrong for this date.
Strangely it is right in the Solar system, Moon tab.

Patrick Chevalley

19-10-06 14:48

administrator   ~0005991

This is because I was computing the illumination at the time of Moon transit. But for some days this time can be undefined, because transit occur only on previous and next day.

To fix the issue I now compute the illumination at local midnight for the twilight table :
https://github.com/pchev/skychart/commit/b7f2f3937b1fe5ea7ff12c5a62926c4ede5b8155

The change will be in tomorrow beta version.

Issue History

Date Modified Username Field Change
19-09-12 13:14 Martin New Issue
19-09-12 13:14 Martin File Added: cdc_twilight_1.jpg
19-09-12 13:14 Martin File Added: cdc_twilight_2.jpg
19-09-14 17:36 Patrick Chevalley Assigned To => Patrick Chevalley
19-09-14 17:36 Patrick Chevalley Status new => assigned
19-09-14 17:36 Patrick Chevalley Target Version => 4.2
19-09-14 17:36 Patrick Chevalley Note Added: 0005941
19-10-06 14:48 Patrick Chevalley Status assigned => resolved
19-10-06 14:48 Patrick Chevalley Resolution open => fixed
19-10-06 14:48 Patrick Chevalley Fixed in Version => 4.1 SVN
19-10-06 14:48 Patrick Chevalley Note Added: 0005991