View Issue Details

IDProjectCategoryView StatusLast Update
0002742SkyChart1-Softwarepublic24-06-23 11:11
ReporterKevin Horsey Assigned To 
PriorityhighSeveritymajorReproducibilityalways
Status newResolutionopen 
PlatformPCOSLinuxOS Version64bit
Product Version4.2 
Summary0002742: skychart_4.2.1-4073_amd64.deb fails to install on Ubuntu 24.04
DescriptionFollowing installation instructions:
bash <(wget -qO- https://raw.githubusercontent.com/pchev/skychart/master/setup_skychart_deb.sh) <return>
1) Stable selected
sudo apt update <return>
sudo apt install --no-install-recommends skychart <return>
The following packages have unmet dependencies:
 skychart : Depends: libpango1.0-0 but it is not installable
E: Unable to correct problems, you have held broken packages.

libpango1.0-0 is installed:
sudo apt install libpango-1.0-0 <return>
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
libpango-1.0-0 is already the newest version (1.52.1+ds-1build1).
libpango-1.0-0 set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Steps To Reproducesudo apt update <return>
sudo apt install --no-install-recommends skychart <return>
The following packages have unmet dependencies:
 skychart : Depends: libpango1.0-0 but it is not installable
E: Unable to correct problems, you have held broken packages.
TagsNo tags attached.

Activities

Patrick Chevalley

24-06-22 20:16

administrator   ~0008946

This is very strange, I don't know what can be broken in the Gtk install to produce this error. This is something specific to your installation, I can install this skychart package without problem on my Ubuntu 24.04.

I suggest to not lost too much time with that as anyway the next version of skychart will no more use Gtk but Qt5.

Please run the setup script again : bash <(wget -qO- https://raw.githubusercontent.com/pchev/skychart/master/setup_skychart_deb.sh)
But select: 2) Beta
Then install skychart

Kevin Horsey

24-06-23 11:11

reporter   ~0008947

Patrick,
Thanks for the quick reply!
I've just installed the Beta version without errors
Thanks again, and also for Skychart which I've been using for some years now

Issue History

Date Modified Username Field Change
24-06-21 19:22 Kevin Horsey New Issue
24-06-22 20:16 Patrick Chevalley Note Added: 0008946
24-06-23 11:11 Kevin Horsey Note Added: 0008947