View Issue Details

IDProjectCategoryView StatusLast Update
0000906SkyChart1-Softwarepublic12-03-04 19:25
ReporterJames DietrichAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.5 SVN 
Target Version3.6Fixed in Version3.5 SVN 
Summary0000906: some stars cannot be selected
DescriptionI cannot select some NOMAD stars near the south celestial pole.
Steps To ReproduceI used CatGen to create a NOMAD catalog for CdC with the files Oleg provided following the instructions at http://www.ap-i.net/skychart/en/news/nomad

Then I navigated to the south celestial pole, set the FOV to 3' and tried to select various stars. Some I can select; a label appears, which I can click on to see all the information in the catalog about that star. Other stars, however cannot be selected.
Additional InformationI am running 32-bit Debian Linux and have installed version 3.5-svn1929. I also have 3.5-svn1914 installed on WindowsXP, and the same thing happens on that machine too.

I have attached a zip file with two things:
1.) the NOMAD catalog made with CatGen using just the first four files (000[0-3]_nomad.txt), which is sufficient to demonstrate the problem.
2.) an image with some stars I *can* select circled in green and stars I *cannot* select circled in red.
3.) my current skychart.ini

Please let me know if any additional information would be useful.

Thanks for your help!
TagsNo tags attached.

Activities

James Dietrich

11-12-04 02:39

reporter  

1.zip (1,496,879 bytes)

Patrick Chevalley

11-12-20 18:10

administrator  

nomad2.prj.zip (11,278 bytes)

Patrick Chevalley

11-12-20 18:18

administrator   ~0001820

The problem was because of an error I do on the NOMAD Catgen .prj file.
I miss to divide the proper motion by 1000 to put them in arcsec/year instead of mas/year in the text files.
This result in 1000x too big proper motion. This is specially visible near the pole but it affect the whole catalog. This fool the search function in CdC and this is why you can only click on stars with null proper motion.

You need to rebuild your catalog in Catgen using the new nomad2.prj file I upload here. I will also update the NOMAD CdC page.

Sorry for inconvenience of running this huge process again.

James Dietrich

11-12-22 21:30

reporter   ~0001828

I downloaded the new nomad2.prj file and rebuilt the catalog using just the first four files. I can select more stars than before, but I still cannot select all the stars near the south celestial pole. I will attach another zip file with three things:
1.) The catalog I made with CatGen and nomad2.prj using just the first four files (000[0-3]_nomad.txt)
2.) an image with the stars I *can* select circled in green and the stars I *cannot* select circled in red.
3.) my current skychart.ini

Again, thank you for working on this, and let me know if I can be of any further help.

James Dietrich

11-12-22 21:31

reporter  

2.zip (1,570,223 bytes)

Patrick Chevalley

11-12-23 08:01

administrator   ~0001829

Last edited: 11-12-23 08:06

View 2 revisions

I use your files with the today version svn1976 but I can click on every star without problem, including the red.

The only difference I may have is that I only have the main square chart1 and not the two other. For that I need skychart.ini1 and skychart.ini2. But as they are linked I think they are the same just at another scale.

Can you try with this new version? This last weeks I do a lot of change to the apparent position calculation and this may make the difference.

BTW if you are searching the star nearest to the south pole be careful it is moving rapidly at this scale. Because of light aberration it change almost every day. Do an animation with a one month step to see how big it is over the year due to the cumulated effect of aberration, nutation and precession.


Edit:
I try with an old 3.2 binary I found on my computer and with this version I cannot select the same stars as you. So I really think this is fixed with the last svn.

James Dietrich

11-12-25 11:09

reporter   ~0001831

I tried this latest version and I can select all the stars now.

Patrick Chevalley

11-12-25 18:08

administrator   ~0001833

Thank you for the confirmation.

James Dietrich

11-12-26 01:35

reporter   ~0001843

I just discovered another problem with this issue of selecting stars.

Until now I have been generating a catalog with 9537 files, even when testing with the small extract as described above. But since the extract has not very many objects, I decided to try making a catalog (using the first four files only) with the 50, 184, and 732 files option. With the 184 and 732 files catalogs, I could still select all the stars in the 3' field centered at the south celestial pole. But with the 50 files catalog, I was unable to select a number of stars.

So, I have attached another file 3.zip with two things--the 50 files catalog and an image showing which stars I can and cannot select.

Thank you for looking at this again!

James Dietrich

11-12-26 01:35

reporter  

3.zip (175,670 bytes)

Patrick Chevalley

11-12-26 18:32

administrator   ~0001844

Thank you for all the testing!

For safety I truncate the search to 89.9 degree for the 50 files catalog.
Revision 1991 increase the limit to 89.99999 and now it work for all the stars.

http://svn.origo.ethz.ch/viewvc/skychart?view=rev&revision=1991

James Dietrich

12-01-11 12:39

reporter   ~0001900

There wasn't a new development version for a couple weeks, so I am just testing this again.

It seems that the problem with the 50 files catalog is solved. Thank you.

But now there is one star I cannot select, and this time it's the same no matter whether I activate the 50, 184, 732, or 9537 files catalogs. With all four catalogs I cannot select the same star.

I have installed the latest version--3.5-2051. I also removed my .skychart/ directory and recreated the four catalogs with the new version.

Attached is another file 4.zip with my skychart.ini and an image showing the star I cannot select. Also included is the 50 files catalog. Just let me know if it would be helpful to have the 184, 732, or 9537 files catalogs, and I can upload them too.

James Dietrich

12-01-11 12:40

reporter  

4.zip (143,909 bytes)

Patrick Chevalley

12-01-14 09:21

administrator   ~0001901

Nice case! it is different than the last problem.

This is because at this date the star was almost exactly at 0h RA.
If you do the same with today date it work!

I try to find a solution.

Patrick Chevalley

12-01-14 10:17

administrator   ~0001902

This is fixed by revision 2054.
A new beta is normally available Monday.

http://svn.origo.ethz.ch/viewvc/skychart?view=rev&revision=2054

James Dietrich

12-01-17 02:25

reporter   ~0001903

Since you mentioned that this had to do with that star being very nearly at 0h RA, I decided to advance the time manually, clicking on the star at each time, and watch the star move across the 0h RA line. I discovered that there is still a period of time during which I cannot select that one star.

2012 Jan 11, 16:52:18 UT I can select it, but from 16:52:19 UT until about 20h UT I cannot. Then, from 20h UT forward, it is very difficult to select that star. It seems that I have to click on *exactly* the right spot to select it, instead of being able to click anywhere within a few pixels of the star, like I can with all the other stars. So I might have to click ten or twenty times on or near the star to find the right spot and finally get it selected.

Patrick Chevalley

12-01-22 15:51

administrator   ~0001911

This case and a few other bug near 0h RA are now fixed by revision 2072:

http://svn.origo.ethz.ch/viewvc/skychart?view=rev&revision=2072

Issue History

Date Modified Username Field Change
11-12-04 02:39 James Dietrich New Issue
11-12-04 02:39 James Dietrich File Added: 1.zip
11-12-04 18:49 Patrick Chevalley Assigned To => Patrick Chevalley
11-12-04 18:49 Patrick Chevalley Status new => assigned
11-12-04 18:49 Patrick Chevalley Target Version 0.3.0 => 3.6
11-12-20 18:10 Patrick Chevalley File Added: nomad2.prj.zip
11-12-20 18:18 Patrick Chevalley Note Added: 0001820
11-12-20 18:18 Patrick Chevalley Status assigned => resolved
11-12-20 18:18 Patrick Chevalley Resolution open => fixed
11-12-22 21:30 James Dietrich Note Added: 0001828
11-12-22 21:30 James Dietrich Status resolved => feedback
11-12-22 21:30 James Dietrich Resolution fixed => reopened
11-12-22 21:31 James Dietrich File Added: 2.zip
11-12-23 07:44 Patrick Chevalley Status feedback => assigned
11-12-23 08:01 Patrick Chevalley Note Added: 0001829
11-12-23 08:01 Patrick Chevalley Status assigned => feedback
11-12-23 08:06 Patrick Chevalley Note Edited: 0001829 View Revisions
11-12-25 11:09 James Dietrich Note Added: 0001831
11-12-25 11:09 James Dietrich Status feedback => assigned
11-12-25 18:08 Patrick Chevalley Note Added: 0001833
11-12-25 18:08 Patrick Chevalley Status assigned => resolved
11-12-25 18:08 Patrick Chevalley Resolution reopened => fixed
11-12-25 18:08 Patrick Chevalley Fixed in Version 0.3.0 => 3.5 SVN
11-12-26 01:35 James Dietrich Note Added: 0001843
11-12-26 01:35 James Dietrich Status resolved => feedback
11-12-26 01:35 James Dietrich Resolution fixed => reopened
11-12-26 01:35 James Dietrich File Added: 3.zip
11-12-26 18:32 Patrick Chevalley Note Added: 0001844
11-12-26 18:32 Patrick Chevalley Status feedback => resolved
11-12-26 18:32 Patrick Chevalley Resolution reopened => fixed
12-01-11 12:39 James Dietrich Note Added: 0001900
12-01-11 12:39 James Dietrich Status resolved => feedback
12-01-11 12:39 James Dietrich Resolution fixed => reopened
12-01-11 12:40 James Dietrich File Added: 4.zip
12-01-14 09:21 Patrick Chevalley Note Added: 0001901
12-01-14 09:21 Patrick Chevalley Status feedback => assigned
12-01-14 09:21 Patrick Chevalley Fixed in Version 3.5 SVN => 0.3.0
12-01-14 10:17 Patrick Chevalley Note Added: 0001902
12-01-14 10:17 Patrick Chevalley Status assigned => resolved
12-01-14 10:17 Patrick Chevalley Resolution reopened => fixed
12-01-14 10:17 Patrick Chevalley Fixed in Version 0.3.0 => 3.5 SVN
12-01-17 02:25 James Dietrich Note Added: 0001903
12-01-17 02:25 James Dietrich Status resolved => feedback
12-01-17 02:25 James Dietrich Resolution fixed => reopened
12-01-22 15:51 Patrick Chevalley Note Added: 0001911
12-01-22 15:51 Patrick Chevalley Status feedback => resolved
12-01-22 15:51 Patrick Chevalley Resolution reopened => fixed
12-03-04 19:25 Patrick Chevalley Status resolved => closed