User Tools

Site Tools


Sidebar


News:


Cartes du Ciel is free software released under the terms of the
GNU banner GNU General Public License


Hosted by SourceForge.net

Support This Project


en:documentation:server_commands

Server Commands

SkyChart can work as a server. It accepts the following commands from a TCP/IP connection:

Connection

You can use any socket library or object to connect to Skychart from your software, or use the commands telnet or netcat from a script.
To send a command, write to the socket the command, any parameter separated by a blank space, and finally a CR-LF termination.
For examples with various languages, see https://github.com/pchev/skychart/tree/master/skychart/sample_client

The standard port is 3292, this can be changed by the user in the configuration menu. The program can also choose to listen to another random port if the configured port is busy.

Skychart maintains a file with information about the port and it's status.
In Linux and Mac: [User settings]/tmp/tcpport
In Windows: Registry key HKCU\Software\Astro_PC\Ciel\Status\TcpPort

The file (or key) do not exist if Skychart was never run.
It contains 0 if the program is not running, or the server is disabled in the configuration menu.
It contains the listen port if the program is ready to accept a connection.

Global Commands

Command Parameters Comment or GUI Equivalent
? No GUI equivalent, list the available commands
NEWCHART chart_name File → New Chart
CLOSECHART chart_name File → Close Chart
SELECTCHART chart_name Window → chart_name
LISTCHART Window
SAVE saved_file_name Save the current chart to the specified file
LOAD saved_file_name Load the chart from the file
LOADDEFAULT option_file_name Use this command to load an extract of the configuration file that temporarily replace some option from skychart.ini.
SETCAT path shortname active min max Add or change a Catgen catalog. The fields are the same as in the catalog setup.
LOADMPCORB file_name Load the specified file with asteroid element in MPCORB format. Detail result is available in file [user_data]/database/LoadAsteroidFile.log
PLANETINFO page_number Open the Solar system information window at the given page
GETMSGBOX Returns the status bar content
GETCOORBOX Returns the coordinates shown in the status bar
GETINFOBOX Setup → Display → Labels - Display the chart information in the menu bar
RESET Reload the default chart and options (same as signal HUP)
SHUTDOWN Close the program

Chart Commands

Command Parameters Comment or GUI Equivalent
REDRAW Follows a modification command, mandatory to update chart
ZOOM+ View → Zoom in
ZOOM- View → Zoom out
ZOOM+MOVE Right-clic → Zoom + Move
ZOOM-MOVE Right-clic → Zoom - Move
MOVEEAST Keyboard Left arrow
MOVEWEST Keyboard Right arrow
MOVENORTH Keyboard Up arrow
MOVESOUTH Keyboard Down arrow
MOVENORTHEAST Numpad 7 (Ver num off)
MOVENORTHWEST Numpad 9 (Ver num off)
MOVESOUTHEAST Numpad 1 (Ver num off)
MOVESOUTHWEST Numpad 3 (Ver num off)
SETNORTH Chart → View Horizon → North
SETSOUTH Chart → View Horizon → South
SETEAST Chart → View Horizon → East
SETWEST Chart → View Horizon → West
SETZENITH View zenith
ALLSKY Show all sky
FLIPX Chart > Tranformation > Mirror Horizontally
FLIPY Chart > Tranformation > Mirror Vertically
ROT+ Chart → Tranformation → Rotate Right
ROT- Chart → Tranformation → Rotate Left
SETFOV 00d00m00s or 00.00 Chart FOV input fields or icon (Main Bar)
SETFIELDNUMBER 1..10 Set the FOV to one of the predefined field number
GETFOV S/F
SETRA RA:00h00m00s or 00.00 Chart center RA
GETRA S/F Chart center RA, S → 17h07m12s
F → 17.11991
SETDEC DEC:+00d00m00s or 00.00 Chart center DEC
GETDEC S/F Chart center RA
SETOBS LAT:+00d00m00sLON:+000d00m00s ALT:000mOBS:name Setup → Observatory
Beware the longitude must be negative East. In many case you must change the longitude sign.
GETOBS LAT:+00d00m00sLON:+000d00m00s ALT:000mOBS:name Beware the longitude is negative East. In many case you must change the longitude sign.
SETDATE yyyy-mm-ddThh:mm:ss or “yyyy-mm-dd hh:mm:ss” Setup → Date/Time
GETDATE
SETTZ Etc/GMT Setup → Observatory (Country Timezone)
GETTZ
RESIZE width height Resize the chart
SETCURSOR pixX pixY Set the cursor position at the x,y coordinates
GETCURSOR Current cursor x,y coordinates
CENTRECURSOR center the chart atthe cursor position, Right-clic → Center
SAVEIMG PNG/JPEG/BMP filename quality File → Save Image…
PRINT PRT/PS/BMP PORTRAIT/LANDSCAPE COLOR/BW filepath Print or export to Postscript or Bitmap,
File → Print and File→ Printer setup
UNDO Edit → Undo
REDO Edit → Redo

Chart drawing

Command Parameters Comment or GUI Equivalent
CLEANUPMAP Remove any selection and redraw the map
SETFOVPROJECTION fov_number HAI/MER/CAR/ARC/TAN/SIN Set the given projection for the fov_number
SHOWONLYMERIDIAN ON/OFF Display only the meridian instead of full grid
SHOWALWAYSMERIDIAN ON/OFF Display the meridian line on every projection
SETEQGRID ON/OFF Chart → Lines, Grid → Add Equatorial Grid
GETEQGRID
SETGRID ON/OFF Chart → Lines, Grid → Show Coordinate Grid
GETGRID
SETSTARMODE 0/1/2 Setup → Display → Display → Star Display
GETSTARMODE
SETNEBMODE 0/1 Setup > Display → Display → Deep Sky Objects Display
GETNEBMODE
SETAUTOSKY ON/OFF Setup → Display → Sky Colour
GETAUTOSKY
SETPROJ ALTAZ/EQUAT/GALACTIC/ECLIPTIC Chart → Chart Coordinate System
GETPROJ
SETCHARTEQUINOX Date/J2000 Set the equinox when coordinate system is EQUAT
SETGRIDNUM ON/OFF Setup → Display → Lines - Show Grid Label
SETCONSTLINE ON/OFF Setup → Display → Lines - Show Constellation Figure
SETCONSTBOUNDARY ON/OFF Setup → Display → Lines - Show Constellation Boundary
SHOWPICTURE ON/OFF Chart → Show objects → Show pictures
SHOWBGIMAGE ON/OFF Show background image
LOADBGIMAGE fits_filename Load new background image FITS file, also force reload of updated file if the name is the same.
LOADCIRCLE file_name Load a list of finder mark, same as right click - Finder circle - Load from file
SETCIRCLE num diameter rotation offset Define a finder circle as in Setup - Display - Finder circle
SETRECTANGLE num width height rotation offset Define a finder rectangle as in Setup - Display - Finder rectangle
SHOWCIRCLE num_list Set a comma separated list of circle to be activated 1,2,…,10
SHOWRECTANGLE num_list Set a comma separated list of rectangle to be activated 1,2,…,10
MARKCENTER ON/OFF Show a mark at the chart center, same as Show mark
GETFRAMES Return the mosaic frames, same as the mosaic tool “Send via server” button
PLANISPHEREDATE ON/OFF Show or hide the planisphere date scale
PLANISPHERETIME ON/OFF Show or hide the planisphere time scale

Object selection

Command Parameters Comment or GUI Equivalent
GETCHARTEQSYS Return the current equatorial system to be used with other command. Date or J2000, B1950, …
SEARCH object_name Search tool (Main Bar). object_name must be enclosed in double quote if it contain space
FIND object_class object_name Same as search, but lets you specify the class of object you want: 0=nebula, 1=na, 2=star, 3=star, 4=variable, 5=double, 6=comet, 7=asteroid, 8=planet, 9=constellation, 10=line catalog. . object_name must be enclosed in double quote if it contain space
IDCENTER Identify object at chart center
IDCURSOR Identify object at cursor position, same as click on chart
IDSCOPE Identify object at telescope position
GETSELECTEDOBJECT Return information about the last selected object
GETRISESET Get rise/transit/set time for the last selected object

Telescope

Command Parameters Comment or GUI Equivalent
CONNECTTELESCOPE Connect to the default telescope.
DISCONNECTTELESCOPE Disconnect the default telescope.
SLEW RAhr Dec [in decimal] Slew the default telescope to specified coordinates.
ABORTSLEW Abort the current slewing command.
SYNC RAhr Dec [in decimal] Sync the default telescope at the specified coordinates.
GETSCOPERADEC S/F Return current telescope coordinates, string or float format
TRACKTELESCOPE ON/OFF Chart follow the telescope. Same as menu Telescope / Track telescope.
SETSCOPEREFRESHRATE delay [ms] Refresh the telescope position every (delay) [ms]
GETSCOPERATES Return a list of movement rate supported by the telescope
SCOPEMOVEAXIS axis(0/1) rate Start moving the telescope along (axis) using (rate)
The following command are specific for a INDI telescope, prefer the command above
CONNECTINDI Connect to configured INDI telescope.
DISCONNECTINDI Disconnect the INDI telescope.
SLEWINDI RAhr Dec [in decimal] Slew the INDI telescope to specified coordinates.
ABORTSLEWINDI Abort the current slewing command.
SYNCINDI RAhr Dec [in decimal] Sync the INDI telescope at the specified coordinates.
This command show a cursor on the chart for a telescope not managed by Skychart
MOVESCOPE RA Dec [00.00] Move the telescope cursor to coordinates. RA in decimal hours.
MOVESCOPEH HourAngle Dec [00.00] Same as MOVESCOPE but hourangle instead of RA. Hourangle in decimal hours.

Observing list

Command Parameters Comment or GUI Equivalent
OBSLISTLOAD list_file_name load the observing list
OBSLISTFIRST select first object
OBSLISTLAST select last object
OBSLISTNEXT select next object
OBSLISTPREV select previous object
OBSLISTLIMIT ON/OFF set limit on/off
OBSLISTAIRMASSLIMIT [airmass] limit by airmass
OBSLISTTRANSITLIMIT [hours] limit by meridian distance
OBSLISTTRANSITSIDE EAST/WEST/BOTH side of meridian

V2.7 compatibility DDE command

Avoid to use this command that exist to help the migration for older application.

Command Parameters Comment or GUI Equivalent
MOVE obsolete RA: 00h00m00.00s DEC:+00d00m00.0s FOV:+00d00m00s Icon
DATE obsolete, same as SETDATE
OBSL obsolete, same as SETOBS
RFSH obsolete, same as REDRAW
PDSS Same as the menu Chart-Get DSS Image
SBMP obsolete, use SAVEIMG
SGIF obsolete, use SAVEIMG
SJPG obsolete, use SAVEIMG
IDXY X:pixelx Y:pixely
GOXY X:pixelx Y:pixely
ZOM+ obsolete, same as ZOOM+
ZOM- obsolete, same as ZOOM-
STA+ icon (Main Bar)
STA- icon (Main Bar)
NEB+ icon (Main Bar)
NEB- icon (Main Bar)
GREQ obsolete, use SETEQGRID
GRAZ obsolete, use SETGRID
GRNM obsolete, use SETGRIDNUM
CONL obsolete, use SETCONSTLINE
CONB obsolete, use SETCONSTBOUNDARY
EQAZ obsolete, use SETPROJ

Information about selected object

The following information are returned when an object is selected on the chart, either by a mouse click or as a result of a search. Each field is separated by the <tab> character.

> Chart_1 : 23h21m39.85s +61°19'04.8" Nb  NGC 7635 m:11.00 Dim: 15.0 x  8.0 ' class:  Identifier:C11,LBN 548
  • > indicate the start of a message.
  • Chart_1 : the name of the chart the object was selected.
  • 23h21m39.85s RA of the object using current chart equinox.
  • +61°19'04.8“ Dec of the object using current chart equinox.
  • Nb the type of object
  • NGC 7635 the name of the object

Then follow a number of fields whose content depend on the object type and the catalog in use.

If the selection is from a mouse click you can also get this information about the distance from the last selected object:

> Chart_1 : From: "Sh 2-150" to "NGC 7635 " Separation: +06°48'05.6" PA:119° Offset:  0h49m46.4s -03°53'47"
en/documentation/server_commands.txt · Last modified: 2020/02/06 20:04 by pch