View Issue Details

IDProjectCategoryView StatusLast Update
0001356SkyChart1-Softwarepublic14-09-02 17:42
ReporterReinhold Fr. Auer Assigned ToPatrick Chevalley  
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
PlatformDELL NB E5520OSMS  
Product Version3.11 SVN 
Target Version4.0Fixed in Version3.11 SVN 
Summary0001356: missing screen update after time change
DescriptionI am using horizon file of my observatory together with total sky view to check wheather a target variable star is within my sky window (star time - end time) for planing observations. This I am doing for every month e.g. 15.9.2014 and start time nautic twilight in the evening and the morning, checking wheather target is within the horizon area or not and manipulation the time until I have the right information.
Unfortunateyl after every time change, I have to use "search for" to renew the screen to get my target shown. It would be very comfortable, if once a star has been selected and time is changed, that screen would be updated automatically.
Steps To Reproduceactivating horizon file -> az coordinates -> total sky view -> selecting a star with "search for" -> changing observing time by one or more hours
=== now the position of the stars is missing !===
if you doing "search for" with the star again, then the screen is updated and position of stars at new time is shown.
Additional Informationthe "automatic" update would make it much more comfortable finding out within what time window a certain object could be observed within certain horizon limits.
TagsNo tags attached.

Activities

Reinhold Fr. Auer

14-08-15 09:39

reporter  

screen_update.pdf (380,667 bytes)

Patrick Chevalley

14-08-16 15:06

administrator   ~0002916

If I understand correctly you want the selected object (NGC 188 in your first screen shot) to be selected automatically after you change the time?

This is already implemented but you need "lock on" the object first. Use the right click menu "Lock on NGC 188", or the anchor button.
If you have the "Detail" window open for this object the data are automatically updated to allow to follow the altitude or airmass directly without any other click.

Reinhold Fr. Auer

14-08-26 14:36

reporter   ~0002934

Hello Patrick, in the meanwhile I studied how to use CdC to simulate prediction of observation WHEN object enters within horizon limts (can be observed) and WHEN will leave this obsrving window. In present CdC chart "every thing" moves, when times are changed. For simulation s.a., it would be the best if orientation of horizon keeps unchanged, only sky moves around the pole (white circle in enclosure). Together with the new feature "toolbar" it would be in ideal instrument to plan observations in advance and definate when will be the best time to observe (in my case binary and pulsating variables).
By the way, it seems to me, that compass rose does not fit to the position of the horizon in chart, see also copy of my mount controller which uses same horizon file.

Patrick Chevalley

14-09-02 17:42

administrator   ~0002940

Thank you for your explanation.

I find a way to keep the label selected after the time change.
This can work only for non moving object (i.e. not for the asteroid or comets) but it work in your case for the stars.

The revision 3002 implement this change.
The labels for stars and nebula are redraw after the time change as long we are no more than 10 years after the selection. This 10 years limit is to avoid to draw the label at the wrong place because of coordinates change due to the precession or proper motion.

http://sourceforge.net/p/skychart/code/3002/

Issue History

Date Modified Username Field Change
14-08-15 09:39 Reinhold Fr. Auer New Issue
14-08-15 09:39 Reinhold Fr. Auer File Added: screen_update.pdf
14-08-16 15:06 Patrick Chevalley Note Added: 0002916
14-08-16 15:06 Patrick Chevalley Assigned To => Patrick Chevalley
14-08-16 15:06 Patrick Chevalley Status new => feedback
14-08-26 14:36 Reinhold Fr. Auer Note Added: 0002934
14-08-26 14:36 Reinhold Fr. Auer Status feedback => assigned
14-09-02 17:42 Patrick Chevalley Note Added: 0002940
14-09-02 17:42 Patrick Chevalley Status assigned => resolved
14-09-02 17:42 Patrick Chevalley Resolution open => fixed
14-09-02 17:42 Patrick Chevalley Fixed in Version 0.3.0 => 3.11 SVN
14-09-02 17:42 Patrick Chevalley Target Version 0.3.0 => 4.0