View Issue Details

IDProjectCategoryView StatusLast Update
0001506SkyChart1-Softwarepublic16-12-03 17:16
ReporterSasa Assigned ToPatrick Chevalley  
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.11 SVN 
Target Version4.0Fixed in Version3.11 SVN 
Summary0001506: Solar System Information - some improvement suggestion
DescriptionSolar System Information information is indeed beautiful feature for observers and kids introducing in astronomy.

I would suggest some improvements:

1. To sync with time from chart page and/or better to have independent time navigation. That would be indeed very interesting to see real rotation and shadows.

2, For independent planets, also its satellite positions is interesting to be seen optionally (of course, that with stable and predictable trajectory).

3. To have also entire Solar System with zoom in/out ability and real images and proper labeling. Of course all with independent time navigation...
TagsNo tags attached.

Relationships

related to 0000037 resolvedPatrick Chevalley Observer position in space 

Activities

Sasa

16-02-14 23:31

reporter   ~0003288

I'm actually interesting to help in implementation of these new features, when free time allows...

Patrick Chevalley

16-02-15 09:13

administrator   ~0003290

This is very interesting improvements and I will be happy if you implement them.

I like the idea to add a time bar to this window.
It is also possible to sync the time from the chart (at the moment you need to click the button again).
But doing the two can be difficult, for example a chart autorefresh can ruin with what you set in the time bar.

Sasa

16-02-15 09:23

reporter   ~0003291

I'm currently very short with free time, but soon it should be more of them, so yes, I'm quite interesting to implement them.

Checkbox "Sync with active chart and settings" is enough to solve that problem...

teslaStinker

16-03-12 18:05

reporter   ~0003336

Well, i sympathise with this idea, but why do that to the software and make it drag even more. I do mean, are we going to have to buy new computers to get new faster processors every time someone is not satisified. Not to mention, just how much do you think a no real pie processor is going to handle? I would suggest you use a second software instead, such as this one.
For I like Cartes du ciel the way it is. To fancy it over with more stuff is just asking for trouble with itself in its calculations....
I think it takes long enough to search the databases now, let alone, what happens when you compile more into it? Or put it is animation...
There are some things Winstars does not do, that du ciel does. I would prefer two softwares to one, because the processor is always quicker...

http://www.winstars.net/english/screenshots.html

Sasa

16-03-13 01:41

reporter   ~0003337

There is no single reason for any worries.

All I have manage to make so far is quite simple and optimized - no negative impact on current CDC speed nor rest of the CDC code. "Solar System Information" is optional feature and as such fully controlled by user. As is based on planets/satellites ephemeris only, all is fast and almost trivial to make.

The xplanet based rendering is in general the most problematic part in CDC. However, I have manage to optimize it for usage here and these methods can be used as a base for rest of CDC rendering gives speed up for most of rendering. At least until implementing internal rendering engine.

Sasa

16-11-04 20:14

reporter   ~0003389

Almost all plan is implemented and this issue can be closed.

Sasa

16-11-27 20:14

reporter   ~0003448

I have just finished and sent third and last update regarding the issue and this can be closed permanently. :)

Patrick Chevalley

16-12-03 17:16

administrator   ~0003464

Feature implemented by a lot of changes from revision 3295 to 3345.

Issue History

Date Modified Username Field Change
16-02-14 23:27 Sasa New Issue
16-02-14 23:31 Sasa Note Added: 0003288
16-02-15 09:13 Patrick Chevalley Note Added: 0003290
16-02-15 09:13 Patrick Chevalley Status new => acknowledged
16-02-15 09:13 Patrick Chevalley Target Version => 4.2
16-02-15 09:23 Sasa Note Added: 0003291
16-03-02 10:44 Patrick Chevalley Relationship added related to 0000037
16-03-02 11:02 Patrick Chevalley Target Version 4.2 => 4.0
16-03-12 18:05 teslaStinker Note Added: 0003336
16-03-13 01:41 Sasa Note Added: 0003337
16-11-04 20:14 Sasa Note Added: 0003389
16-11-27 20:14 Sasa Note Added: 0003448
16-12-03 17:16 Patrick Chevalley Note Added: 0003464
16-12-03 17:16 Patrick Chevalley Assigned To => Patrick Chevalley
16-12-03 17:16 Patrick Chevalley Status acknowledged => resolved
16-12-03 17:16 Patrick Chevalley Resolution open => fixed
16-12-03 17:16 Patrick Chevalley Fixed in Version => 3.11 SVN