View Issue Details

IDProjectCategoryView StatusLast Update
0001519SkyChart1-Softwarepublic16-02-29 18:48
ReporterSasa Assigned ToPatrick Chevalley  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionwon't fix 
PlatformLinux 64-bitOSKubuntu 
Product Version3.11 SVN 
Summary0001519: Setting longitude from observatiry seems to be wrong
DescriptionIf set observer longitude from observatory and it is East, the value become negative double, meaning it is West.

Looking at the combobox, first value is West, second is East, however, in code it changes the sign opposite:

procedure Tf_config_observatory.longdegChange(Sender: TObject);
begin
if LockChange then exit;
if obslock then exit;
if frac(longdeg.Value)>0 then
   csc.ObsLongitude:=longdeg.value
else
   csc.ObsLongitude:=longdeg.value+longmin.value/60+longsec.value/3600;
if long.Itemindex>0 then csc.ObsLongitude:=-csc.ObsLongitude;
ShowObsCoord;
SetObsPos;
CenterObs;
end;

Solution is to change order in combobox and set default index value to 0, or to change in code long.Itemindex=0. However, order in combobox for latitude is correct (North - South), then lat.Itemindex>0 is correct...

However, it seems that somewhere else in code, long is negated, thus all calculations are correct. See as well longutude values in skychart.ini - it is negative.

Steps To Reproduce1. Set date of solar eclipse in 1999-08-11 13:04 (CEST)
2. Set coordinate for greatest eclipse at lat 45 01' N and long 24 03' E
3. Look at the chart - Sun seems to be perfectly covered by Moon
4. Look at skychart.ini it show negative value for longitude.

TagsNo tags attached.

Activities

Sasa

16-02-29 01:53

reporter   ~0003325

Last edited: 16-02-29 02:06

View 6 revisions

Correct location from NASA paper is: lat 45 04' N and long 24 17' E

Anyway, regarding the issue, that is irrelevant.

The problem is spotted when I intended to use csc.ObsLatitude and csc.ObsLongitude values for xplanet call.

Patrick Chevalley

16-02-29 18:48

administrator   ~0003327

Longitude sign is just a convention and traditionally the astronomer where using the positive west convention, maybe because the convention used for the other planets is to have the central meridian value increasing with time.

Positive west convention is used in Meeus book and so was the earlier version of CdC.

Now the ObsLongitude value is used more than 100 time in the program and I am not willing to change the sign as this internal value is never visible by the user.

Issue History

Date Modified Username Field Change
16-02-29 01:37 Sasa New Issue
16-02-29 01:53 Sasa Note Added: 0003325
16-02-29 02:00 Sasa Note Edited: 0003325 View Revisions
16-02-29 02:01 Sasa Note Edited: 0003325 View Revisions
16-02-29 02:02 Sasa Note Edited: 0003325 View Revisions
16-02-29 02:05 Sasa Note Edited: 0003325 View Revisions
16-02-29 02:06 Sasa Note Edited: 0003325 View Revisions
16-02-29 18:48 Patrick Chevalley Note Added: 0003327
16-02-29 18:48 Patrick Chevalley Assigned To => Patrick Chevalley
16-02-29 18:48 Patrick Chevalley Status new => resolved
16-02-29 18:48 Patrick Chevalley Resolution open => won't fix