View Issue Details

IDProjectCategoryView StatusLast Update
0001533SkyChart1-Softwarepublic16-04-23 09:48
ReporterHans Lambermont Assigned ToPatrick Chevalley  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntu 
Product Version3.11 SVN 
Target Version4.0Fixed in Version3.11 SVN 
Summary0001533: INDI server host field only accepts IP address or FQDN
DescriptionTrying to connect to a remote indi server, I typed in just the hostname. My resolv.conf has a nice search domain set, so for all unix programs this works fine. But not for this INDI server host field.
Steps To ReproduceINDI server host field with IP address works.
with FQDN also works. With just the hostname it does not connect.
Additional InformationIf entry is not an IP adress and has no . then the local domain should be added for the name resolve.
TagsNo tags attached.

Activities

Patrick Chevalley

16-04-21 17:54

administrator   ~0003356

Name resolution is done by the Synapse tcp/ip library https://sourceforge.net/projects/synalist/
It look difficult to patch here.

Maybe the best solution is to do the resolution using fcl-net because it use libc.

Patrick Chevalley

16-04-23 09:48

administrator   ~0003357

I find a solution without change to the tcp/ip library.

Fixed by revision 3263:
https://sourceforge.net/p/skychart/code/3263/

Issue History

Date Modified Username Field Change
16-04-14 00:01 Hans Lambermont New Issue
16-04-21 17:54 Patrick Chevalley Note Added: 0003356
16-04-21 17:54 Patrick Chevalley Assigned To => Patrick Chevalley
16-04-21 17:54 Patrick Chevalley Status new => confirmed
16-04-21 17:54 Patrick Chevalley Target Version => 4.2
16-04-23 09:48 Patrick Chevalley Note Added: 0003357
16-04-23 09:48 Patrick Chevalley Status confirmed => resolved
16-04-23 09:48 Patrick Chevalley Resolution open => fixed
16-04-23 09:48 Patrick Chevalley Fixed in Version => 3.11 SVN
16-04-23 09:48 Patrick Chevalley Target Version 4.2 => 4.0