View Issue Details

IDProjectCategoryView StatusLast Update
0001590SkyChart1-Softwarepublic17-06-04 16:37
ReporterArmando Beneduce Assigned ToPatrick Chevalley  
PrioritynoneSeverityminorReproducibilityalways
Status resolvedResolutionnot fixable 
OSWindows 
Product Version3.11 SVN 
Summary0001590: wrong DSS image placement
DescriptionHi Patrick,

I just found DSS image not properly aligned/placed on the map.
The issue seems related to FOV in use and also to the coordinates of the center. You can reproduce the issue by centering on IC410 with FOV at 5° (at lower FOVs I see no issues).

Thank You and Clear Skies!
Armando
TagsNo tags attached.

Activities

Armando Beneduce

16-12-12 22:32

reporter   ~0003501

It seems occuring when the map is centered near one of the margins of the DSS image.

Patrick Chevalley

16-12-12 23:20

administrator   ~0003502

I cannot reproduce the problem.
I set the fov to 5deg, center on ic410, set the DSS source to "Skyview DSS", click the DSS button and the image is perfectly aligned.

What is the source for your dss image?
Can you zip and upload the file $temp.fits here if it is not too big.

Armando Beneduce

16-12-12 23:46

reporter   ~0003503

I'm using the 102CD mode, stored locally.

Armando Beneduce

16-12-12 23:53

reporter  

1.png (439,868 bytes)   
1.png (439,868 bytes)   

Armando Beneduce

16-12-12 23:55

reporter  

1.fit (1,382,400 bytes)

Armando Beneduce

16-12-12 23:58

reporter   ~0003504

Last edited: 16-12-13 00:02

View 2 revisions

I see online DSS plates are not usable @ FOV=5°.
Anyway I also found a change in FOV, as you can see in the attached png - I was at 5° but after the DSS click SkyChart switched to a larger FOV (greater than 6°).

Patrick Chevalley

16-12-13 00:19

administrator   ~0003505

Yes, if you select "Skyview DSS" the online DSS can show wide FOV by making mosaic of the DSS images. This is probably the best option.

And I can reproduce the problem with the 102CD. The WCS is wrong in the FITS file, I will take a look at libgetdss if I can fix it.

Sasa

17-06-01 17:04

reporter   ~0003833

Last edited: 17-06-01 20:08

View 2 revisions

I have noticed similar with 4.1 SVN and pictures installed from https://www.ap-i.net/skychart/en/download (skychart-data-pictures_4.0-3421_all.deb).

Search and lock on NGC 1101 and zoom in to about 10". The picture is shifted left of the center of the screen. If compare parametric shape and actual picture, picture is shifted left in about half of the actual size...

Upper happens with SAC catalog. If perform the same with Open NGC, all seems to be aligned properly.

As well, when switch between catalogs, be sure to perform Search and lock - otherwise catalogs seems to not being switched, as on changing time position of picture is not changed accordingly.

Patrick Chevalley

17-06-04 16:37

administrator   ~0003845

The issue is in the DSS 102 CD extraction software when the FOV is out of a plate boundary.
I cannot find the issue for now and a real solution will be to merge data from adjacent plate, something this software is not intended for.

The solution for large DSS FOV is really to use Skyview online as it merge many plate nicely.


Sasa, your problem with NGC 1101 is different.
The offset you see is because the SAC coordinates are sometime imprecise, so the picture is at the right place but the symbol and search position from SAC are wrong.

OpenNGC contain much better coordinates and since last week version it also include the IC. It is now a much better choice than SAC and I will probably switch the default catalog after a few more testing.


Issue History

Date Modified Username Field Change
16-12-12 22:16 Armando Beneduce New Issue
16-12-12 22:32 Armando Beneduce Note Added: 0003501
16-12-12 23:20 Patrick Chevalley Note Added: 0003502
16-12-12 23:20 Patrick Chevalley Assigned To => Patrick Chevalley
16-12-12 23:20 Patrick Chevalley Status new => feedback
16-12-12 23:46 Armando Beneduce Note Added: 0003503
16-12-12 23:46 Armando Beneduce Status feedback => assigned
16-12-12 23:53 Armando Beneduce File Added: 1.png
16-12-12 23:55 Armando Beneduce File Added: 1.fit
16-12-12 23:58 Armando Beneduce Note Added: 0003504
16-12-13 00:02 Armando Beneduce Note Edited: 0003504 View Revisions
16-12-13 00:19 Patrick Chevalley Note Added: 0003505
17-01-15 17:54 Patrick Chevalley Target Version => 4.2
17-06-01 17:04 Sasa Note Added: 0003833
17-06-01 20:08 Sasa Note Edited: 0003833 View Revisions
17-06-04 16:37 Patrick Chevalley Status assigned => resolved
17-06-04 16:37 Patrick Chevalley Resolution open => not fixable
17-06-04 16:37 Patrick Chevalley Target Version 4.2 =>
17-06-04 16:37 Patrick Chevalley Note Added: 0003845