View Issue Details

IDProjectCategoryView StatusLast Update
0001635SkyChart1-Softwarepublic17-02-16 15:18
ReporterSasaAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinux 32-bitOSKubuntuOS Version16.04
Product Version3.11 SVN 
Target Version4.0Fixed in Version3.11 SVN 
Summary0001635: Zoom in/out - datetime change
DescriptionIn one of recent change, when zoom in/out the chart will keep old chart datetime. However, even position of pointed object will not change, datetime on info view (left upper corner of the chart) will change the datetime according current time.

SVN 3483
Steps To Reproduce1. Set FOV to 45 and enable "Use system time"
2. Search Jupiter and do not lock on it
3. Zoom in close enough. Position of Jupiter will not change, however on every zoom step, datetime on info will change
4. When close enough, click on 30" FOV icon once or more times. Position of Jupiter will change.

These two actions (Zoom in/out and FOV icons click) should produce the same effect.
TagsNo tags attached.

Activities

Patrick Chevalley

17-02-06 22:56

administrator   ~0003586

The "Use system time" option is disabled for all this button only if the FOV is smaller than 10 arcmin. For wider FOV it is honored and the time change every refresh.

The difference here is not because the time change or not, but because you are in Alt/Az coordinates and the +/- button let you centered in equatorial coordinates, but the FOV buttons in Alt/Az coordinates.

If I remember it was a request to keep the same object centered when zooming with the +/- button or the mouse wheel. (and not simulate the object dragging off of view as with a Dobson)
I think it is important to keep this behavior for the observers.

And the FOV button make Jupiter (and stars) to move because it is explicitly set to keep the Alt/Az position as you request in 0001485

I am tempted to let it as is.

Sasa

17-02-07 00:43

reporter   ~0003588

Last edited: 17-02-07 08:39

View 4 revisions

I do not see any difference between zoom by mouse/keyboard and click on icons - they do exactly the same, change the FOV. As currently is, they do differently which is a bit confusing. For instance, as I cannot zoom in instantly on Jupiter (I have suggested in the past 2 more icons of 1' and 2'), I would have to zoom in constantly by mouse/keyboard (which is extremely slow), use 30' and mouse/keyboard or set FOV from main menu. For that purpose it is important that all do the same.

The chart (as requested some time ago) during zoom in/out must keep the same datetime, that is essential to keep moving object still. However, object stay still, but datetime changes. That is obviously bug, as it is used one JD for calculation and another to display on chart (left upper corner for info).

The #1485 is about different issue (grid shift). I believe you refer on issue I suggested to not change datetime when zoom in/out, which is essential on small FOV regardless projection.

Try as well to zoom in under 4', datetime is kept still. Then zoom out - when threshold FOV is reach, datetime will be chahged, then zoom in again under 10' - Jupiter will stay on center, even if not locked.

Patrick Chevalley

17-02-07 10:02

administrator   ~0003589

All this problem are because you keep Alt/Az chart when zooming to a narrow FOV, Earth rotate quickly and this move the object in the chart.
You must not mix this movement with the planet movement on it's orbit, with a FOV of 10' you cannot see the orbital movement of Jupiter over a few minutes.
0001485 was about this Earth rotation movement.
  
I not want to change the FOV button because they can also be used on wide FOV over large time period. And if you are looking at the East horizon you not want this position to change.

Personally I alway switch to Ecliptic chart when working on the planet detail because this is a much more natural projection (with alt/az all is randomly upside-down).

I not want to add more button on the main interface to zoom on narrow FOV for the planets, there is already too much.
The place to do that is the SolarSystem Toolbox script.
I attach to this issue a change in the script that zoom when you search a planet from the script. This is a quick change and it is possible to make it better, maybe with another button.
To install unzip the file in ~/.skychart/script and use "Setup/Manage Toolbox Script" to assign it to a F key.

Patrick Chevalley

17-02-07 10:03

administrator  

SolarSystem_cdcps.zip (1,899 bytes)

Sasa

17-02-07 12:54

reporter   ~0003590

I find all this far too complicated.

Yes, it is default Alt/Az projection in this case. However, "Use system time" should be ignored completely on some actions (as zoom in and FOV change, as suggested in some older issue), regardless projection, because every recalculation is far too demanding (last even 5-6s) and make mentioned problems...

Anyway, I will not insist on this further.

Thank you for the script. I have added it and it crashed app. (attached screen shot). I will try later to find cause, as on reopening app and adding the scrip again, it worked fine.

Script crash app.png (217,133 bytes)
Script crash app.png (217,133 bytes)

Patrick Chevalley

17-02-07 14:05

administrator   ~0003591

I not see a viable solution for this problem because it is very important for observers that check "Use system time" to alway have updated time. This is vital when a telescope is connected to CdC.

I think of adding a minimal delay before to update the time, but this would make the thing worst because the jump in position is more important you have more chance to lost your object.

Thank you to find this problem with the script execution.
This is because you click again on the button while the previous execution was not terminated, maybe make a double-click on the button?

This is fixed in revision 3485.

Patrick Chevalley

17-02-07 14:23

administrator   ~0003592

I just think about another way to make the FOV button more coherent with the zoom function.

In revision 3486 I make the first two FOV buttons (30' and 1° using standard setting) to react like the +/- zoom buttons.

This fix the consistency problem where it is the more visible and annoying.

Sasa

17-02-07 16:42

reporter   ~0003593

Last edited: 17-02-07 16:48

View 3 revisions

In case of Jupiter and Saturn, this does not make too much difference. Instead 30'+ search + zoom in, now can be performed search + 30'+ zoom in. Much faster solution for me is to use your script.

Regarding AV. Yes, it is unintentional double-click - mouse micro-switch malfunction. Similar AV happens if double click on "Date and Time" icon. In general, this should be check for all icons dynamically create and call form.

Patrick Chevalley

17-02-16 15:18

administrator   ~0003613

I update the standard SolarSystem script to add a checkbox option to zoom on the planet.

https://sourceforge.net/p/skychart/code/3522/

Issue History

Date Modified Username Field Change
17-02-06 18:28 Sasa New Issue
17-02-06 22:56 Patrick Chevalley Assigned To => Patrick Chevalley
17-02-06 22:56 Patrick Chevalley Status new => feedback
17-02-06 22:56 Patrick Chevalley Note Added: 0003586
17-02-07 00:43 Sasa Note Added: 0003588
17-02-07 00:43 Sasa Status feedback => assigned
17-02-07 00:57 Sasa Note Edited: 0003588 View Revisions
17-02-07 01:09 Sasa Note Edited: 0003588 View Revisions
17-02-07 08:39 Sasa Note Edited: 0003588 View Revisions
17-02-07 10:02 Patrick Chevalley Note Added: 0003589
17-02-07 10:03 Patrick Chevalley File Added: SolarSystem_cdcps.zip
17-02-07 12:54 Sasa File Added: Script crash app.png
17-02-07 12:54 Sasa Note Added: 0003590
17-02-07 14:05 Patrick Chevalley Note Added: 0003591
17-02-07 14:23 Patrick Chevalley Status assigned => feedback
17-02-07 14:23 Patrick Chevalley Note Added: 0003592
17-02-07 16:42 Sasa Note Added: 0003593
17-02-07 16:42 Sasa Status feedback => assigned
17-02-07 16:47 Sasa Note Edited: 0003593 View Revisions
17-02-07 16:48 Sasa Note Edited: 0003593 View Revisions
17-02-16 15:18 Patrick Chevalley Status assigned => resolved
17-02-16 15:18 Patrick Chevalley Resolution open => fixed
17-02-16 15:18 Patrick Chevalley Fixed in Version => 3.11 SVN
17-02-16 15:18 Patrick Chevalley Target Version => 4.0
17-02-16 15:18 Patrick Chevalley Note Added: 0003613