View Issue Details

IDProjectCategoryView StatusLast Update
0001663SkyChart1-Softwarepublic17-03-05 12:05
ReporterSasaAssigned ToPatrick Chevalley 
PrioritynormalSeveritytrivialReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformLinuxOSLubuntu 32-bitOS Version16.10
Product Version3.11 SVN 
Target Version4.0Fixed in Version3.11 SVN 
Summary0001663: Solar System Information: Planet ephemreis can be calculated between - 3000 and 3000
DescriptionAccording to help file, CDC can calculate with date between -20000 and 20000, however ephemeris for planets and satellites only between -3000 and 3000.

That is the reason Solar System Information failing out of the range, without any warning. I would suggest to stop simulation when limits are reach and do not allow incrementing/decrementing datetime and perhaps rise warning.
TagsNo tags attached.

Activities

Sasa

17-02-25 21:04

reporter   ~0003658

Last edited: 17-02-25 21:05

View 3 revisions

Furthermore, if enter into Solar System Information with date out of range, FOV become Inf or Nan and will not be fixed until complete reopening the CDC.

Patrick Chevalley

17-02-25 22:46

administrator   ~0003660

Rev 3548 check the ephemeris validity in Planet Info and show a message if not.
https://sourceforge.net/p/skychart/code/3548/

The doc is outdated, valid date range is ten time more -200000 / +200000, planet is limited by DE431 -13000 / +17000 if you install it.

Sasa

17-03-01 10:55

reporter   ~0003681

Last edited: 17-03-01 10:56

View 2 revisions

This works fine, except in following cases:

1. If datetime when open form is already out of range.
2. If set Jupiter revolution time, play forwared/backward and when get out of range back to 1 hour step or so and then try to play again.

In both cases it look like it is frozen (it is actually not). I would suggest standard message instead and when click on OK to set minimum/maximum limit (depending on direction), instead to keep datetime out of range.

Patrick Chevalley

17-03-05 12:05

administrator   ~0003686

Revision 3556 fix the frozen/broken aspect by reseting the NAV buttons:
https://sourceforge.net/p/skychart/code/3556/

Revision 3557 revert the last date step when the ephemeris is invalid, this avoid to stop on an empty page:
https://sourceforge.net/p/skychart/code/3557/

But for 1. it is not possible to do more than the error message because it is not possible to know the absolute validity range of ephemeris.
It is possible to install only part of ephemeris. For example one can split DE431 in one file per century and install only one century on two.

Issue History

Date Modified Username Field Change
17-02-25 20:35 Sasa New Issue
17-02-25 21:04 Sasa Note Added: 0003658
17-02-25 21:05 Sasa Note Edited: 0003658 View Revisions
17-02-25 21:05 Sasa Note Edited: 0003658 View Revisions
17-02-25 22:46 Patrick Chevalley Assigned To => Patrick Chevalley
17-02-25 22:46 Patrick Chevalley Status new => resolved
17-02-25 22:46 Patrick Chevalley Resolution open => fixed
17-02-25 22:46 Patrick Chevalley Fixed in Version => 3.11 SVN
17-02-25 22:46 Patrick Chevalley Target Version => 4.0
17-02-25 22:46 Patrick Chevalley Note Added: 0003660
17-03-01 10:55 Sasa Status resolved => new
17-03-01 10:55 Sasa Resolution fixed => reopened
17-03-01 10:55 Sasa Note Added: 0003681
17-03-01 10:56 Sasa Note Edited: 0003681 View Revisions
17-03-05 12:05 Patrick Chevalley Status new => resolved
17-03-05 12:05 Patrick Chevalley Resolution reopened => fixed
17-03-05 12:05 Patrick Chevalley Note Added: 0003686