View Issue Details

IDProjectCategoryView StatusLast Update
0001668SkyChart1-Softwarepublic17-03-07 09:40
ReporterMichael BauerAssigned ToPatrick Chevalley 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSLubuntuOS VersionYakkety
Product Version3.11 SVN 
Target Version4.0Fixed in Version3.11 SVN 
Summary0001668: Difficulties with obtaining artificial satellite data
Description1. I have problems installing and performing wine:

mb@mb-MS-6590:~$ sudo yum install wine
Es gibt keine aktivierten repos.
Führen sie "yum repolist all" aus, um zu sehen, welche repos sie haben.
Sie können repos mit yum-config-manager --enable <repo> aktivieren
mb@mb-MS-6590:~$ sudo yum repolist all
repolist: 0
mb@mb-MS-6590:~$ skychart

2. When clicking Artificial Satellite Update I get error message:
Abort Finished: Connect www.prismnet.com/443. Error 500SSL/TLS support is not compiled.

3. My question: When I installed Skychart I did '--no-install recommends' following advice on web-page. How can I install the rest of all recommended packages? How can I install artificial satellite package?

Thanks a lot.

Michael
Steps To Reproducemb@mb-MS-6590:~$ skychart
2017-02-28T16:26:49.233 Start trace
2017-02-28T16:26:49.233 Program version : 3.11-svn-3553
2017-02-28T16:26:49.233 Program compiled: 2017/02/28 10:06:09
2017-02-28T16:26:49.234 Compiler version: Lazarus 1.6.2.0 Free Pascal 3.0.0 Linux-i386-gtk2
2017-02-28T16:26:49.336 Screen scaling : True
2017-02-28T16:26:49.337 Screen scale : 114%
2017-02-28T16:26:49.346 Try language: de_DE, de
2017-02-28T16:26:49.426 Language: de
2017-02-28T16:26:51.280 Verbunden zur SQL Datenbank /home/mb/.skychart/database/cdc.db
2017-02-28T16:26:52.166 Aktiv auf Port: 3292
WARNING: obsolete call to RecreateWnd for Tf_configtime
Warning: TWinControl.DestroyHandle f_configtime:Tf_configtime Handle not Allocated

(skychart:2323): Gtk-WARNING **: Theme directory imported-Humanity/192 of theme Lubuntu has no size field

WARNING: obsolete call to RecreateWnd for Tf_about
Warning: TWinControl.DestroyHandle f_about:Tf_about Handle not Allocated

TagsNo tags attached.

Activities

Patrick Chevalley

17-02-28 18:11

administrator   ~0003679

Michael,

1. yum command is for Fedora, not Ubuntu. You must use apt-get.
I remark the doc is confusing here, I try to make it better, can you read again:
https://www.ap-i.net/skychart/en/documentation/artificial_satellites#require_software_installation

2. This look like a configuration error in the 32bit chroot of my build server. I look to fix it.

3. Wine and Dosbox are not in the recommends list because many people do not want DOS software on Linux.
The doc say '--no-install recommends' because this add about 200 MB of data download. This also install Indi telescope support.
You can install the recommends list with:
apt-get install indi-bin, indistarter, skychart-data-stars, skychart-data-dso, skychart-data-pictures

Patrick Chevalley

17-02-28 22:23

administrator   ~0003680

Update for 2. :
The problem is Synapse tcp/ip library search only for the devel openssl library.
I need to fix it to search also for versioned library.

Mattia Verga

17-03-01 19:51

reporter   ~0003682

Patrick, the link to libssl.so in sources is fine, you need to have the devel package installed while building skychart.
However I don't think it will work since synapse code is quite old. I cannot make it work on Fedora rawhide which uses the latest openssl-1.1 (I get an error on runtime).
I will try on the older Fedora 25 which uses openssl 1.0.2k.
Maybe I will open a separate bug for this.

Mattia Verga

17-03-02 19:29

reporter   ~0003683

Last edited: 17-03-02 19:30

View 2 revisions

Sorry Patrick, I was wrong. The ssl_openssl_lib.pas file needs to be patched with the versioned library.
But here it is another problem: it seems that instead of using the part:
{$IFDEF CIL}
const
  {$IFDEF LINUX}
  DLLSSLName = 'libssl.so';
  DLLUtilName = 'libcrypto.so';

it uses:
var
  {$IFNDEF MSWINDOWS}
    ...
     {$ELSE OS2}
    DLLSSLName: string = 'libssl.so';
    DLLUtilName: string = 'libcrypto.so';

So I found that if I change libraries names under "$IFDEF LINUX" it doesn't find them, instead if I change the part under "$ELSE OS2" it works...

Patrick Chevalley

17-03-05 10:53

administrator   ~0003685

Rev 3555 search for versioned soname. This must work on most system, tested with 0.9.8 and 1.0.0:
https://sourceforge.net/p/skychart/code/3555/

Mattia, this must also work for Fedora but it is better if you can patch the right DLLSSLName and DLLUtilName as you know it for the version you compile.

Everything in {$IFDEF CIL} is only for .NET, maybe if using Synapse with Mono?

This {$ELSE OS2} match for everything not Windows, not Mac, not OS2. So Linux, FreeBSD and any other Unix is defined here.

Michael Bauer

17-03-05 18:26

reporter   ~0003690

What should I do in order to avoid the error message when trying to update articial satellite data? I still get it.

Patrick Chevalley

17-03-05 18:58

administrator   ~0003692

Michael,

New beta version with the update from the last week are build every Monday morning.
So if you are configured with the "unstable" repository you will receive the corrected version tomorrow.

Issue History

Date Modified Username Field Change
17-02-28 16:46 Michael Bauer New Issue
17-02-28 18:11 Patrick Chevalley Assigned To => Patrick Chevalley
17-02-28 18:11 Patrick Chevalley Status new => assigned
17-02-28 18:11 Patrick Chevalley Target Version => 4.0
17-02-28 18:11 Patrick Chevalley Note Added: 0003679
17-02-28 22:23 Patrick Chevalley Note Added: 0003680
17-03-01 19:51 Mattia Verga Note Added: 0003682
17-03-02 19:29 Mattia Verga Note Added: 0003683
17-03-02 19:30 Mattia Verga Note Edited: 0003683 View Revisions
17-03-05 10:53 Patrick Chevalley Note Added: 0003685
17-03-05 10:54 Patrick Chevalley Status assigned => resolved
17-03-05 10:54 Patrick Chevalley Resolution open => fixed
17-03-05 10:54 Patrick Chevalley Fixed in Version => 3.11 SVN
17-03-05 18:26 Michael Bauer Status resolved => new
17-03-05 18:26 Michael Bauer Resolution fixed => reopened
17-03-05 18:26 Michael Bauer Note Added: 0003690
17-03-05 18:58 Patrick Chevalley Note Added: 0003692
17-03-07 09:40 Patrick Chevalley Status new => resolved
17-03-07 09:40 Patrick Chevalley Resolution reopened => fixed