View Issue Details

IDProjectCategoryView StatusLast Update
0001680SkyChart3-Documentationpublic17-03-18 22:14
ReporterSasa Assigned ToPatrick Chevalley  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformLinuxOSLubuntu 32-bitOS Version16.10
Product Version3.11 SVN 
Target Version4.0Fixed in Version3.11 SVN 
Summary0001680: PDF help - empty PDF file for Duch
DescriptionWhen switch language to Duch, empty PDF file is shown. This may indicate some issue in script files which generate PDF files, as for some other language have no created PDF file, English version is shown.
TagsNo tags attached.

Activities

Sasa

17-03-18 07:37

reporter   ~0003726

Furthermore, looking at http://www.ap-i.net/pub/skychart/doc/, it seems there is a problem with several more PDF files.

Patrick Chevalley

17-03-18 10:40

administrator   ~0003727

The problem is because of 3 required pages missing in the Dutch documentation, the pages about telescope interface.
I copy the English pages and now it work.

I also delete the tr and ru pdf files that where small because there is almost no doc translation for this languages.

Sasa

17-03-18 17:24

reporter   ~0003728

Last edited: 17-03-18 17:28

View 2 revisions

I have compiled latest SVN 3573 and now only "Cannot download PDF help now" message is shown if delete old PDFs first.

http://www.ap-i.net/pub/skychart/doc/ is available and can open any PDF from browser.

In fact, this seems to be 4.0 release version ready, then instead of beta it should download doc_4.0_en.pdf in case local file is missing? Anyway, last .deb beta as well failing to download file.

Sasa

17-03-18 17:52

reporter   ~0003729

After deleting ./skychart, from old beta release it become possible to dowload new PDF help file.

Thus, it is some conflict using official and beta release, you warn about in some recent note.

Sorry, my bad. I have not notice first the code is already prepared for 4.0 release.

Patrick Chevalley

17-03-18 22:14

administrator   ~0003731

You get this problem because of a number of condition probably very specific to all the change I do today. This probably not need a change to the code.

- you deleted the pdf but not the file pdflist.txt
- the file pdflist.txt is downloaded only once a day
- so your pdflist.txt contain old pdf file name I replaced to solve the Dutch problem.
- when you try to display pdf it read the old filename from pdflist and give this error because the file no more exist.
- after removing .skychart it download the new pdflist.txt with the new file name and it work ok.

Yes, the version is now 4.0 and today I tested the installer on all the platform.
Tomorrow I tag the version (will be 3574) and publish the installer.

Issue History

Date Modified Username Field Change
17-03-18 07:27 Sasa New Issue
17-03-18 07:37 Sasa Note Added: 0003726
17-03-18 10:40 Patrick Chevalley Assigned To => Patrick Chevalley
17-03-18 10:40 Patrick Chevalley Status new => resolved
17-03-18 10:40 Patrick Chevalley Resolution open => fixed
17-03-18 10:40 Patrick Chevalley Category Other => 3-Documentation
17-03-18 10:40 Patrick Chevalley Fixed in Version => 3.11 SVN
17-03-18 10:40 Patrick Chevalley Target Version => 4.0
17-03-18 10:40 Patrick Chevalley Note Added: 0003727
17-03-18 17:24 Sasa Status resolved => new
17-03-18 17:24 Sasa Resolution fixed => reopened
17-03-18 17:24 Sasa Note Added: 0003728
17-03-18 17:28 Sasa Note Edited: 0003728 View Revisions
17-03-18 17:52 Sasa Note Added: 0003729
17-03-18 22:14 Patrick Chevalley Status new => resolved
17-03-18 22:14 Patrick Chevalley Resolution reopened => fixed
17-03-18 22:14 Patrick Chevalley Note Added: 0003731