View Issue Details

IDProjectCategoryView StatusLast Update
0001918SkyChart1-Softwarepublic18-03-25 18:16
ReporteranuAssigned ToPatrick Chevalley 
PriorityhighSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version7
Product Version4.1 SVN 
Target Version4.2Fixed in Version4.1 SVN 
Summary0001918: crosshair issue in display-finder circle menu. Issue appears on screen and another anomaly well as print
Descriptionissue1 in print- offset of crosshairs position with fov circles-- In display both appears concentric but in print they are offset. Found it in print while making new nova finder chart. Placed 5 deg and 1 deg fov circles. Had centre of chart marked.

issue2 on screen- In menu, 'Mark centre of chart' and 'Add crosshair centre of chart' do not work independently. Have to check Mark centre of chart to have add crosshairs. Unchecking 'Mark centre of chart' I'm not sure if mark centre of chart alone should add selected fov circle(as it happens curretly) or should have added additional centre marking.
Steps To ReproduceAdd any finder circles with mark centre of chart and add crosshairs to centre of chart. keep header footer in print setting checked. Print to pdf. Observe anomaly in exported pdf that circles are offset w.r.to crosshairs running across chart

Observe onscreen chart behavior of setting- Setup>Display> Finder circle(eyepiece)- and toggling Mark centre of chart and Add crosshairs to centre of chart.
TagsNo tags attached.

Activities

anu

18-03-21 17:45

reporter  

CdC22.pdf (122,680 bytes)
version.jpg (54,241 bytes)
version.jpg (54,241 bytes)
CdC.pdf (39,282 bytes)

Patrick Chevalley

18-03-23 18:33

administrator   ~0004611

I confirm the crosshair for the chart center is offset when printing.
Removing the header and footer fix the problem, so this is related to how this cross is positioned relative to the canvas border.

Crosshair can only be added when the mark is active, this is why it is labeled 'Add crosshair centre of chart' but not 'Mark centre of chart with crosshair'.
I will change the setup screen to disable it when 'Mark centre of chart' is not checked.

If you want only the crosshair just uncheck every circle.

anu

18-03-25 17:32

reporter   ~0004633

Dear Patrick,
Thanks a lot for reply.

Absolutely love the skycharts over any other application especially considering the incorporation of large catalogs & databases like NOMAD, GAIA as soon as they were released. Using it since more than a decade and it always exceeded expectations and my observing capability.

The printing feature is the best i've ever seen and star dial style 'orient to pole' feature is also too good for training new students of astronomy by printing handouts of circular sky chart.

Thanks for everything.

Patrick Chevalley

18-03-25 18:16

administrator   ~0004635

Thank you!

The crosshair center is now fixed:
https://github.com/pchev/skychart/commit/8ef641de1c5fabebc454407ea6b009022a0ffd5b

This will be in tomorrow beta version.

Issue History

Date Modified Username Field Change
18-03-21 17:45 anu New Issue
18-03-21 17:45 anu File Added: CdC22.pdf
18-03-21 17:45 anu File Added: CdC.pdf
18-03-21 17:45 anu File Added: version.jpg
18-03-23 18:33 Patrick Chevalley Assigned To => Patrick Chevalley
18-03-23 18:33 Patrick Chevalley Status new => assigned
18-03-23 18:33 Patrick Chevalley Target Version => 4.2
18-03-23 18:33 Patrick Chevalley Note Added: 0004611
18-03-25 17:32 anu Note Added: 0004633
18-03-25 18:16 Patrick Chevalley Status assigned => resolved
18-03-25 18:16 Patrick Chevalley Resolution open => fixed
18-03-25 18:16 Patrick Chevalley Fixed in Version => 4.1 SVN
18-03-25 18:16 Patrick Chevalley Note Added: 0004635