View Issue Details

IDProjectCategoryView StatusLast Update
0001968SkyChart1-Softwarepublic18-09-18 17:37
ReporterGuillermo AbramsonAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version10 64bit
Product Version4.1 SVN 
Target Version4.2Fixed in Version4.1 SVN 
Summary0001968: Finding Mars
DescriptionSearching for Mars in the search box finds Kappa Herculis instead. The common name of the star is Marsic.
Searching through the dialog > Solar system > Mars finds Mars OK.
Same thing happens on two computers, both with the same SVN build.
Steps To ReproduceType mars<enter> in the search box.
Additional InformationThanks for solving the search stars problem. This may be related?
TagsNo tags attached.

Activities

Patrick Chevalley

18-09-18 09:39

administrator   ~0004843

This problem is a result of a recent update of the star name from the IAU list where they use the name Marsic for Kappa Herculis, previously it was Marfic but this probably make confusion with Lambda Ophiuchi,

This is also because CdC always search for substring when you type something in the search box, so typing mars effectively search for *mars*

You can get a more precise search function by using the menu Edit/Advanced search.
In this case selecting "Solar system" and "Mars" find the planet Mars.

A way to improve that will be to first do a search for the exact name, then if nothing is found do the substring search as now.

Patrick Chevalley

18-09-18 17:37

administrator   ~0004860

This is fixed by searching first for the exact star or nebula name and doing the partial name search only at the very end if nothing else is found.
I also stop searching for comet if only a number is given, this must consistently return an asteroid.

https://github.com/pchev/skychart/commit/0af9f266870863ecefe54852f3c19ba644aba12f

Issue History

Date Modified Username Field Change
18-07-25 15:13 Guillermo Abramson New Issue
18-09-18 09:39 Patrick Chevalley Assigned To => Patrick Chevalley
18-09-18 09:39 Patrick Chevalley Status new => assigned
18-09-18 09:39 Patrick Chevalley Target Version => 4.2
18-09-18 09:39 Patrick Chevalley Note Added: 0004843
18-09-18 17:37 Patrick Chevalley Status assigned => resolved
18-09-18 17:37 Patrick Chevalley Resolution open => fixed
18-09-18 17:37 Patrick Chevalley Fixed in Version => 4.1 SVN
18-09-18 17:37 Patrick Chevalley Note Added: 0004860