View Issue Details

IDProjectCategoryView StatusLast Update
0001972SkyChart1-Softwarepublic18-09-18 16:15
ReporterDavid FilipowskiAssigned ToPatrick Chevalley 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version10 64bit
Product Version4.0 
Target Version4.2Fixed in Version4.1 SVN 
Summary0001972: Asteroids Will Not Update
DescriptionWhen I try to update the Asteroids on my computer, this what I get, followed my leaving the 'Update:'

Cancel Finished: Request sent,waiting response/Error:404 Not Found

Help!
Steps To ReproduceI try again and again, and the same thing repeats.
Additional InformationI've been using this program to hunt asteroids nightly and it had been working great! Now this has happened. I've done nothing different.
TagsNo tags attached.

Activities

Sasa

18-08-31 23:11

reporter   ~0004830

You may try with latest development release, i.e. "unstable" release (4.1.1 beta), which should correctly update asteroids.

David Filipowski

18-09-05 15:55

reporter   ~0004832

Sasa -

Thank you very much! I found and installed the CdC 'beta' 4.1.1 - and this restored the asteroids updates. As well as fine-tuned many other functions & features that also had been 'buggy.'

I'd recommend downloading and using this 4.1.1 'beta' to anyone who loves this wonderful piece of software. This update preserved all my personalization - without even asking. A very nice feature.

I love it!

Dave in Vermont

Patrick Chevalley

18-09-18 09:54

administrator   ~0004845

Nice this is fixed!

There is another error with the MPC download when selecting the full MPCORB it finish with the message:
'This file was not recognized as a MPCORB file'.

This also affect comet download but without error message.

This problem is because the MPC make change to the way they do the http to https redirection.
It worked in the past, but now CdC redirect to the MPC main page instead of the file.

The quick solution is to change the URL in Setup/Internet/Orbital Elements.
In the asteroid list replace http: by https:
Change:
http://www.minorplanetcenter.net/iau/MPCORB/MPCORB.DAT.gz
To:
https://www.minorplanetcenter.net/iau/MPCORB/MPCORB.DAT.gz

Do the same also for the comets or other asteroid list that are downloaded from minorplanetcenter.net

Patrick Chevalley

18-09-18 16:15

administrator   ~0004859

This last point is fixed by forcing https: at first:
https://github.com/pchev/skychart/commit/5284160cce0fcb37cea1389887f580804e1460a3

Issue History

Date Modified Username Field Change
18-08-17 03:03 David Filipowski New Issue
18-08-31 23:11 Sasa Note Added: 0004830
18-09-05 15:55 David Filipowski Note Added: 0004832
18-09-18 09:54 Patrick Chevalley Assigned To => Patrick Chevalley
18-09-18 09:54 Patrick Chevalley Priority normal => urgent
18-09-18 09:54 Patrick Chevalley Status new => assigned
18-09-18 09:54 Patrick Chevalley Target Version => 4.2
18-09-18 09:54 Patrick Chevalley Note Added: 0004845
18-09-18 16:15 Patrick Chevalley Status assigned => resolved
18-09-18 16:15 Patrick Chevalley Resolution open => fixed
18-09-18 16:15 Patrick Chevalley Fixed in Version => 4.1 SVN
18-09-18 16:15 Patrick Chevalley Note Added: 0004859