View Issue Details

IDProjectCategoryView StatusLast Update
0001985SkyChart1-Softwarepublic18-10-01 20:48
ReporterMattia VergaAssigned ToPatrick Chevalley 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version4.2Fixed in Version4.1 SVN 
Summary0001985: Fix on coordinates
DescriptionWhen I move to a specified position by "View -> Position" menu I would like to have the window locked on those coordinates, just like when I fix on a object.
If it's possible, it would also be nice to have those coordinates act as an object, so I can use the measure tool to measure distances from that point.
TagsNo tags attached.

Activities

Patrick Chevalley

18-09-24 08:04

administrator   ~0004882

You can add a "User object" (setup/catalog/user defined object) instead of setting the position and you can do all of this.
But this is more operation.

Maybe this can be done by automatically adding a temporary "user object" when you set the position?

Mattia Verga

18-09-24 18:01

reporter   ~0004883

Yes, a temporary user object created whenever a user manually set a position would be great! And it would be better to lock the chart on that position, so that changing zoom or time doesn't move the chart from the specified position.

Patrick Chevalley

18-10-01 20:48

administrator   ~0004917

I implement this function without using a user object because this can make undesired effect by activating this objects when they are not.

A first change add a checkbox in the Position window to lock the chart at this position, so you can choose to lock or not.
If locked the position remain and you can slew the telescope or add this position to the observing list:
https://github.com/pchev/skychart/commit/c33ea0e478e49cdaebd7b503fa5181613d7d38c1

A second change make the distance measurement to always start with the locked object if any:
https://github.com/pchev/skychart/commit/a31f8dc0d050bc7b929d21f72233df16c63e60d7

Issue History

Date Modified Username Field Change
18-09-23 11:50 Mattia Verga New Issue
18-09-24 08:04 Patrick Chevalley Assigned To => Patrick Chevalley
18-09-24 08:04 Patrick Chevalley Status new => assigned
18-09-24 08:04 Patrick Chevalley Target Version => 4.2
18-09-24 08:04 Patrick Chevalley Note Added: 0004882
18-09-24 18:01 Mattia Verga File Added: Screenshot_20180924_180007.png
18-09-24 18:01 Mattia Verga Note Added: 0004883
18-10-01 20:48 Patrick Chevalley Status assigned => resolved
18-10-01 20:48 Patrick Chevalley Resolution open => fixed
18-10-01 20:48 Patrick Chevalley Fixed in Version => 4.1 SVN
18-10-01 20:48 Patrick Chevalley Note Added: 0004917