View Issue Details

IDProjectCategoryView StatusLast Update
0002054SkyChart1-Softwarepublic19-01-15 13:38
ReporterSam Finn Assigned ToPatrick Chevalley  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOS10 
Target Version4.2Fixed in Version4.1 SVN 
Summary0002054: Screen fonts, highlights not visible against window background color when Mac "Appearance" set to "Dark"
DescriptionWith Mac OS 10.14 the screen appearance may be set to Dark (a new setting) or Light (the previous appearance). When Appearance is set to Dark, the window borders and menu bars are darkened. To be visible, fonts and other highlights must change to a lighter color or shade. CdC does not make this change (successfully), leading to dark fonts on a dark background, which is unreadable.
Steps To ReproduceOn a Mac OS X 10.14 system, go to System Preferences>General. Set Appearance to Dark. Open CdC.
TagsNo tags attached.

Activities

Patrick Chevalley

19-01-15 13:38

administrator   ~0005244

Thank you to report this issue.

Skychart already include support for dark theme with Windows and Linux but the theme was wrongly detected on the Mac.
Also some LCL Cocoa widget need to set the background color explicitly.

This is fixed by this change:
https://github.com/pchev/skychart/commit/188faaa4d0ddd60afc2ceeb12443fef7d7c458bb

This will be available in next week beta version.
Please test and reopen this issue if there is still problem, because I am not sure if my dev virtual machine react the same as a real Mac.

Issue History

Date Modified Username Field Change
19-01-14 20:47 Sam Finn New Issue
19-01-15 13:31 Patrick Chevalley Project CCdciel => SkyChart
19-01-15 13:38 Patrick Chevalley Assigned To => Patrick Chevalley
19-01-15 13:38 Patrick Chevalley Status new => resolved
19-01-15 13:38 Patrick Chevalley Resolution open => fixed
19-01-15 13:38 Patrick Chevalley Category General => 1-Software
19-01-15 13:38 Patrick Chevalley Fixed in Version => 4.1 SVN
19-01-15 13:38 Patrick Chevalley Target Version => 4.2
19-01-15 13:38 Patrick Chevalley Note Added: 0005244