View Issue Details

IDProjectCategoryView StatusLast Update
0002096SkyChart1-Softwarepublic19-06-20 10:16
ReporterRichard HollandsAssigned ToPatrick Chevalley 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version10 64bit
Product Version4.0 
Target Version4.2Fixed in Version4.1 SVN 
Summary0002096: Horizon files are not tied to the observatory
DescriptionIf an horizon file is selected it is independent of the observatory and will be used for all subsequent observatories selected. I have tried saving the observatory data after setting the horizon file but it makes no difference. I would like the horizon file to be tied to the observatory definition and the reference to it to be saved in the chart file.
Steps To ReproduceCreate an horizon file.
Select it in 'Observatory/Horizon'
Change to another observatory.
The horizon is still your newly loaded file.
TagsNo tags attached.

Activities

Patrick Chevalley

19-03-10 18:38

administrator   ~0005463

The horizon information is saved with the observatory when you click the Save button for the favorite list.
This allow to retrieve the right horizon for every favorite location.

But when you just change to coordinates, or select another place from the Observatory Database, the current horizon is keep for convenience.
If you not want it just clear it in the Horizon tab and save the favorite location without horizon.

Do this solve the issue?

Richard Hollands

19-03-10 20:25

reporter   ~0005464

Yes, that does work for me but if I load a saved chart the observatory changes but the horizon doesn't. It remains whatever horizon was loaded previously.
Thanks.

Patrick Chevalley

19-03-10 20:53

administrator   ~0005465

OK, I understand the problem.
This is because at the moment the horizon file is a global resource that not depend on the chart.
I need to change that to allow horizon to be loaded per chart and then save the horizon with the chart.

Patrick Chevalley

19-06-20 10:16

administrator   ~0005704

Horizon file are now specific for each chart, allowing a different observatory with it's horizon file in different chart.
https://github.com/pchev/skychart/commit/01255b85471f0ab936b487cad8a7b51fd4ef64a3

This will be available in next Monday beta version.

Issue History

Date Modified Username Field Change
19-03-06 20:08 Richard Hollands New Issue
19-03-10 18:38 Patrick Chevalley Status new => feedback
19-03-10 18:38 Patrick Chevalley Note Added: 0005463
19-03-10 20:25 Richard Hollands Note Added: 0005464
19-03-10 20:25 Richard Hollands Status feedback => new
19-03-10 20:53 Patrick Chevalley Assigned To => Patrick Chevalley
19-03-10 20:53 Patrick Chevalley Status new => assigned
19-03-10 20:53 Patrick Chevalley Target Version => 4.2
19-03-10 20:53 Patrick Chevalley Note Added: 0005465
19-06-20 10:16 Patrick Chevalley Status assigned => resolved
19-06-20 10:16 Patrick Chevalley Resolution open => fixed
19-06-20 10:16 Patrick Chevalley Fixed in Version => 4.1 SVN
19-06-20 10:16 Patrick Chevalley Note Added: 0005704