View Issue Details

IDProjectCategoryView StatusLast Update
0002116SkyChart3-Documentationpublic19-08-14 13:02
ReporterFrancesco AgostiAssigned ToPatrick Chevalley 
PrioritynormalSeveritytextReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version10 64bit
Product Version4.0 
Target Version4.2Fixed in Version 
Summary0002116: Wrong Longitude sign in remote command GETOBS
DescriptionThe Longitude component of the coordinates returned by the remote command GETOBS has the opposite sign
TagsTCP

Activities

Francesco Agosti

19-04-10 13:11

reporter  

ws.png (89,363 bytes)
ws.png (89,363 bytes)

Patrick Chevalley

19-04-24 13:16

administrator   ~0005610

CdC internally use East negative longitude because this is how it is use in Meeus book.
The GETOBS and SETOBS command use this same convention.

I cannot change that now because this will break any existing application that use this command and already negate the longitude they send or receive from CdC.
But I need to clarify the documentation on this point.

Francesco Agosti

19-04-24 20:47

reporter   ~0005614

Thanks, if that is stable and not going to chenge, I will just negate the sign then

Patrick Chevalley

19-08-14 13:02

administrator   ~0005852

I change the documentation to indicate this specificity.
https://www.ap-i.net/skychart/en/documentation/server_commands#chart_commands

Issue History

Date Modified Username Field Change
19-04-10 13:11 Francesco Agosti New Issue
19-04-10 13:11 Francesco Agosti File Added: ws.png
19-04-10 13:11 Francesco Agosti Tag Attached: TCP
19-04-24 13:16 Patrick Chevalley Assigned To => Patrick Chevalley
19-04-24 13:16 Patrick Chevalley Severity minor => text
19-04-24 13:16 Patrick Chevalley Status new => assigned
19-04-24 13:16 Patrick Chevalley Note Added: 0005610
19-04-24 20:47 Francesco Agosti Note Added: 0005614
19-08-14 13:02 Patrick Chevalley Status assigned => resolved
19-08-14 13:02 Patrick Chevalley Resolution open => fixed
19-08-14 13:02 Patrick Chevalley Category 1-Software => 3-Documentation
19-08-14 13:02 Patrick Chevalley Target Version => 4.2
19-08-14 13:02 Patrick Chevalley Note Added: 0005852