View Issue Details

IDProjectCategoryView StatusLast Update
0002118SkyChart1-Softwarepublic19-04-28 18:55
ReporterBasil RoweAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version7
Product Version4.1 SVN 
Target Version4.2Fixed in Version4.1 SVN 
Summary0002118: Cannot display asteroid positions using CatGen - Catalog tutorial
DescriptionI've tried all I can think of. I'm using the tutorial files,

http://www.centaurus-a.nl/home/files/ephemerides.zip

and can't get the MPC format to display. It seems to go through the CatGen process creating a .HDR file, but when I add it to the catalogs and turn it on, nothing is displayed.

I think I understand what you are doing using CatGen to create the file, I also tried starting from scratch, downloading the positions from the MPC, marking the fields in the text file etc. Saving the file in the C:\Program Files (x86)\Ciel\cat\ephemerids directory, but nothing plots.

Could this be a magnitude filter? Or maybe a filter in my brain <g>

Anyway, I can't get the tutorial to work (this is the first time I've tried import MPC positions).

Thanks!!
Basil
Steps To ReproduceJust try to follow the steps in the tutorial....
TagsNo tags attached.

Activities

Patrick Chevalley

19-04-23 21:07

administrator   ~0005607

Hi Basil,

I make some testing with this files and sure it not work just after extract from the zip, probably because of a change in the catalog format since 2013.
But it work after you open the file MPC.prj in Catgen using the button "Load project", then click "Next",... , "Build catalog".

Then in the Catalog settings select the file mpc.hdr , click the first column so it is green and click OK.
Make a chart of 2 degree width, centered at 12h, -30 and you see one of the position.

Basil Rowe

19-04-23 22:42

reporter   ~0005608

Sorry, I still cant get it to show anything. Your instructions seem very straightforward and it seems like it should work.
After I click "Build Catalog" nothing seems to happen (but it does create the .hdr file with the current date and time), just happens so fast?

I've tried this on 2 different PC's, same result.

I'm attaching the .hdr and .info2 files if they help. If you use these files, do you get something plotted?

Thought it might me an anti-virus thing, so I disabled it. Same result.

Also, I'm using beta v-3925 if that helps.

mpc test.zip (1,044 bytes)

Patrick Chevalley

19-04-24 10:56

administrator   ~0005609

Your .hdr and .info2 work for me, they are strictly identical to the one I generate.

"Build catalog" is very fast because in this case it only write this two files that are just a declaration of the format of the file mpc.txt.
Are you sure the file mpc.txt is present in the same directory as the .hdr and .info2 files?

Basil Rowe

19-04-24 15:00

reporter   ~0005611

Good to hear the .hdr and .info2 files work!

Yes mpc.txt is in the same folder as the above files, all are in C:\Program Files (x86)\Ciel\cat\ephemerides\

Let me try a few things. Looks like I adjusted something that is preventing the points from being piloted. I will start with a fresh install on a new virtual machine and see if that works. If it does, I'll start adjusting things to see if I can make the points disappear.

I will get back in touch soon.

Thanks for all your help.

Basil Rowe

19-04-24 19:12

reporter   ~0005613

Ok, I knew I was the problem.

I was clicking on the "Show user defined objects" button (which I guess is a fair assumption) expecting the points to show. Nope. As soon as clicked on the "Show deep sky objects" button (which I usually keep off), the points showed up. It apparently was working all the time, I just was clicking on the wrong button to make them show.

I don't know if it would be helpful to add something in the documentation about this behavior or not? When someone uses Catgen and selects the catalog type (stars, nebula outline, deep sky or other), they will need to make sure the corresponding objects are displayed and not use the "Show user defined objects" button...

Anyway, it works! Thanks again for this amazing program (one of many you do)

Patrick Chevalley

19-04-28 18:55

administrator   ~0005620

Good you find why it not work.

I have updated the documentation to specify that DSO must be active.
I also replace the zip file to include the newly build .hdr and .info2 so it work immediately without running catgen.

Issue History

Date Modified Username Field Change
19-04-18 22:24 Basil Rowe New Issue
19-04-23 21:07 Patrick Chevalley Assigned To => Patrick Chevalley
19-04-23 21:07 Patrick Chevalley Status new => feedback
19-04-23 21:07 Patrick Chevalley Note Added: 0005607
19-04-23 22:42 Basil Rowe File Added: mpc test.zip
19-04-23 22:42 Basil Rowe Note Added: 0005608
19-04-23 22:42 Basil Rowe Status feedback => assigned
19-04-24 10:56 Patrick Chevalley Note Added: 0005609
19-04-24 15:00 Basil Rowe Note Added: 0005611
19-04-24 19:12 Basil Rowe Note Added: 0005613
19-04-28 18:55 Patrick Chevalley Status assigned => resolved
19-04-28 18:55 Patrick Chevalley Resolution open => fixed
19-04-28 18:55 Patrick Chevalley Fixed in Version => 4.1 SVN
19-04-28 18:55 Patrick Chevalley Target Version => 4.2
19-04-28 18:55 Patrick Chevalley Note Added: 0005620