View Issue Details

IDProjectCategoryView StatusLast Update
0002135SkyChart1-Softwarepublic19-08-14 13:48
ReporterBirgerAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionnot fixable 
PlatformPCOSWindowsOS Version10 64bit
Product Version4.1 SVN 
Target VersionFixed in Version 
Summary0002135: Impossible to get older asteroid elements
DescriptionIt seems impossible to get older asteroid data. Setting the year to e.g. 1998 and displaying asteroids, CdC asks you to download an MPC file, which is understandable as the current ephemeris is not accurate. When the file is downloaded, it asks you to prepare monthly data. However, it then says to download an MPC file, and it starts all over again. Seemingly, it is impossible to display accurate asteroids in the past.

Is it a bug or am I misunderstanding something?
Steps To Reproduce1. Start CdC.
2. Set the year to e.g. 1998.
3. Display asteroids. An error message will show.
4. Go to Setup > Solar System > Asteroids > Load MPC file
5. CdC now asks you to prepare monthly data. However, this will fail and CdC will ask you to download a new MPC.
TagsNo tags attached.

Activities

Patrick Chevalley

19-05-18 14:46

administrator   ~0005651

It is not easy to get old elements.
To my knowledge the MPC web site do not offer this possibility at all, so CdC cannot download automatically the elements for the date you set, but only the most recent elements.
Do you know a place this old elements can be downloaded?

The only way I know is to request the elements for one asteroid at a time from the JPL Horizon web interface.
This method is described here:
https://www.ap-i.net/skychart/en/documentation/add_elements

Birger

19-05-19 16:01

reporter   ~0005652

Unfortunately, no. However, it seems the Occult software found here http://www.lunar-occultations.com/iota/occult4.htm uses old MPC's. At least its asteroid ephemerides seem accurate even in the past.

Patrick Chevalley

19-08-14 13:48

administrator   ~0005853

I cannot look how Occult do it because it is not open source.
Also CdC need a way to do bulk calculation of all know asteroid, not only a specific one.

For now I don't know how to do that.
The only solution, valid for the future is to archive the MPC file once a year.
I find a few one since 2011 on my computer and I setup a crontab to save a new file once a year.
They are available here:
https://vega.ap-i.net/pub/Archives-MPCORB/

Issue History

Date Modified Username Field Change
19-05-17 15:21 Birger New Issue
19-05-18 14:46 Patrick Chevalley Assigned To => Patrick Chevalley
19-05-18 14:46 Patrick Chevalley Status new => feedback
19-05-18 14:46 Patrick Chevalley Note Added: 0005651
19-05-19 16:01 Birger Note Added: 0005652
19-05-19 16:01 Birger Status feedback => assigned
19-08-14 13:48 Patrick Chevalley Status assigned => resolved
19-08-14 13:48 Patrick Chevalley Resolution open => not fixable
19-08-14 13:48 Patrick Chevalley Note Added: 0005853