View Issue Details

IDProjectCategoryView StatusLast Update
0002145SkyChart1-Softwarepublic19-08-14 11:21
ReporterRichard HollandsAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version10 64bit
Product Version4.1 SVN 
Target Version4.2Fixed in Version4.1 SVN 
Summary0002145: Saved charts not displaying correctly when loaded.
DescriptionFollowing on from issue 0002096, the horizon file does indeed load with the chart. But, strangely, the chart does not show the view with which it was saved. What is displayed I'm not entirely sure. All the information around the chart is correct - time, place, even the coordinate grid - but the displayed skyfield isn't.

The fix is easy: open the observatory settings and just click OK. The display the adjusts to the correct view.

I've tried saving fresh versions of the same charts but the problem remains.
Steps To ReproduceLoad a saved chart. Incorrect objects are displayed on the chart until the observatory dialogue is opened and closed.
TagsNo tags attached.

Activities

Patrick Chevalley

19-06-24 23:04

administrator   ~0005710

I cannot reproduce the problem with my saved chart.

Can you please zip and upload here a saved chart that present the problem, and if possible a screen shot of what you expect when the chart is loaded.

Richard Hollands

19-06-25 14:55

reporter   ~0005711

The zip file contains four files: Before.png and After.png: screenshots after loading the chart before opening the observatory dialogue and after, the saved chart and the horizon file.

Skychart_2145.zip (670,118 bytes)

Richard Hollands

19-06-25 15:00

reporter   ~0005712

Also, the location I'm using for Tenochtitlan is 19deg 44min N 96deg 58min W.

Patrick Chevalley

19-08-14 11:21

administrator   ~0005850

Thank you for all this information.
The problem is because the time zone was not correctly loaded from the saved file, so it use UTC instead of Mexico local time.

This is fixed by:
https://github.com/pchev/skychart/commit/da5144b53e33d84fcffbe7e44dc1e7697a38cd25

This will be available in the next beta version on Monday.

Issue History

Date Modified Username Field Change
19-06-24 17:21 Richard Hollands New Issue
19-06-24 23:04 Patrick Chevalley Assigned To => Patrick Chevalley
19-06-24 23:04 Patrick Chevalley Status new => feedback
19-06-24 23:04 Patrick Chevalley Note Added: 0005710
19-06-25 14:55 Richard Hollands File Added: Skychart_2145.zip
19-06-25 14:55 Richard Hollands Note Added: 0005711
19-06-25 14:55 Richard Hollands Status feedback => assigned
19-06-25 15:00 Richard Hollands Note Added: 0005712
19-08-14 11:21 Patrick Chevalley Status assigned => resolved
19-08-14 11:21 Patrick Chevalley Resolution open => fixed
19-08-14 11:21 Patrick Chevalley Fixed in Version => 4.1 SVN
19-08-14 11:21 Patrick Chevalley Target Version => 4.2
19-08-14 11:21 Patrick Chevalley Note Added: 0005850