View Issue Details

IDProjectCategoryView StatusLast Update
0002193SkyChart1-Softwarepublic19-10-06 16:08
ReporterJoe ShusterAssigned ToPatrick Chevalley 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.1 SVN 
Target Version4.2Fixed in Version4.1 SVN 
Summary0002193: "Orient to Pole" labels are placed incorrectly.
DescriptionWith "Orient to Pole" checked, the line from the pole to the midpoint of the baseline should be perpendicular to the baseline. Instead, CDC 4.1.1, beta 3899 positions the label so a line from the pole though the left edge of the baseline is perpendicular.

CDC seems to calculate the correct point for the label and the correct text angle for the baseline. But instead of centering the text over the placement point, CDC starts the text at that placement point. You can see the error best with long labels, like Triangulum.

In the provided sample, you can see that the "Triangulum" and "Aries" labels have baselines that are perpendicular to the azimuth grid lines and the text starts at the grid line. Because of that, a line perpendicular to the _center_ of the text baseline won't pass through the pole/zenith. If the text was centered on that calculated label point and at the calculated angle, the label would be properly "oriented to the pole". IOW, the fix seems very simple: Shift the text so it's centered on the placement point.

Steps To ReproduceCheck "Orient to Pole", enable Show Coordinates Grid
Near zenith, examine labels (preferably with long text) with a left edge near an azimuth grid line.
See that a line through the center point of the text baseline will not pass through the "pole".
Additional InformationThere is an associated side issue: The language "to pole" is problematic. In the version of CDC I'm using, "Orient to Pole" causes a baseline orientation to the zenith. That's what I want, but the zenith isn't a pole.

IMO, there should be a choice to orient to the screen (standard), NCP, SCP, nadir, and zenith.

As always, thanks for the great software!
TagsNo tags attached.

Activities

Joe Shuster

19-09-18 00:54

reporter  

Patrick Chevalley

19-09-18 17:35

administrator   ~0005958

Hi Joe,

Thank you for the detailed description.

I will look what I can do to fix that. The problem is I cannot center the label for DSO or star because this hide the object itself behind the label. I will try a special processing for constellation label that must be centered on the position and in all case compute the rotation for the center of the label.

The term "pole" here refer to the current projection pole. This can be the celestial pole but also the ecliptic or the galactic pole. I agree this look strange for the alt/az projection but the zenith is the pole of this projection.
Maybe "orient to the current projection pole" is better? but a bit too long for the space in this screen.
Or "orient to pole or zenith" ?

Patrick Chevalley

19-10-06 16:08

administrator   ~0005992

This is fixed by :
https://github.com/pchev/skychart/commit/9f1e0c7a674fa752e2f9cbd1fee22409c9321241

I also replace the text "Orient to the pole" by "Orient to the pole or zenith".

This two change will be available in tomorrow beta version.

Issue History

Date Modified Username Field Change
19-09-18 00:54 Joe Shuster New Issue
19-09-18 00:54 Joe Shuster File Added: Show label not correctly oriented.jpg
19-09-18 17:35 Patrick Chevalley Assigned To => Patrick Chevalley
19-09-18 17:35 Patrick Chevalley Status new => assigned
19-09-18 17:35 Patrick Chevalley Target Version => 4.2
19-09-18 17:35 Patrick Chevalley Description Updated View Revisions
19-09-18 17:35 Patrick Chevalley Steps to Reproduce Updated View Revisions
19-09-18 17:35 Patrick Chevalley Additional Information Updated View Revisions
19-09-18 17:35 Patrick Chevalley Note Added: 0005958
19-10-06 16:08 Patrick Chevalley Status assigned => resolved
19-10-06 16:08 Patrick Chevalley Resolution open => fixed
19-10-06 16:08 Patrick Chevalley Fixed in Version => 4.1 SVN
19-10-06 16:08 Patrick Chevalley Note Added: 0005992