View Issue Details

IDProjectCategoryView StatusLast Update
0002662SkyChart1-Softwarepublic23-10-19 11:53
ReporterFrank Stefani Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformPCOSLinuxOS Version64bit
Product Version4.3 beta 
Summary0002662: Depending on zoom step Jupiters 4 Galilean moon labels are messed
DescriptionOption: In case it matters and/or depends, set the date manually to 20230908-0500h (CEST) = 0300h UTC

While zoomin in to the centered Jupiter, several moon labels appear which are not at all visible while the 4 big (Galilean) moons remain unlabeled or (much worse!) wronly labeled.

When the zoom level is big enough so that all 4 moons are visible, first label "Metis" appears at Jupiter's position. Next zoom level th label "Metis" jumps towards Callisto to the position "Europa" had at that time.

Zoom more and Callisto, Io, Ganymede are labeled right but label "Metis" has disappeared. Insteadl "Almathea" label now is placed close to Europa ... which has no(!) label.

Zoom on and suddenly Jupiter is also labelled "Adrastea" (probably obscured) while "Metis" is now exactly at Europa's dot while the label Europa seemingly points nowhere.

I guess the labels my be correct, but the related moons are invisible.

Suggestion:
If my guess is right, please add an option(!) to only display and label the 4 Galilean moons, because they are right away visible. This is important to prepare a card of the dancing moons at any given time and in particular for (rather) wide field imaging where Jupiter and the 4 Galilean moons ra visible together.
Steps To Reproduce1. Locate and Center Jupiter in a wide field, so that the 4 moons are not visible
2. Zoom in (mouse wheel) and watch out for the labels, when the 4 moons appear
3. Though not visible at higher zoom level "Metis" appears very early at irritating positions
4. "Metis" position jumps from Jupiter's location towards "Callisto" while the Ganymed, Io and Europa stay unlabeld

Additional InformationSee the attached screenshots: Several zoom steps and dancing (moonless) and/or irritating labels.
TagsCdC, Galilean moons, Jupiter, label, skychart, Solar System

Activities

Frank Stefani

23-10-06 12:32

reporter  

Auswahl_007.png (20,123 bytes)   
Auswahl_007.png (20,123 bytes)   
Auswahl_008.png (18,069 bytes)   
Auswahl_008.png (18,069 bytes)   
Auswahl_009.png (14,784 bytes)   
Auswahl_009.png (14,784 bytes)   

Patrick Chevalley

23-10-15 18:25

administrator   ~0008584

Last edited: 23-10-15 18:26

This is because of the label automatic placement to prevent overlap on the screen.

You can prevent that by unchecking "Automatically optimize the labels placement" in Setup / Display / Labels.

You can also move the labels manually using the "Edit labels" function so other overlapping labels can be show.

Frank Stefani

23-10-17 21:07

reporter   ~0008596

Thanks for your reply!

I cannot find the "Edit labels" option, despite searching all menus up and down. I don't want to bother you with this topic, because it's only an inconvenience - not an error ... after reading your message.

Anyway, as the 4 galilean moons are specific I would really love to have an option to only display these four of all the 80+ moons Jupiter has.

CS Frank

Patrick Chevalley

23-10-18 14:37

administrator   ~0008602

"Edit label" is available in menu Edit / Edit label.
Once checked you can right click on a label to move it.

To only show the major satellites, open Setup / Solar system, uncheck the option "Show the faint satellites of the outer planets".

Frank Stefani

23-10-18 16:38

reporter   ~0008603

Way cool! The latter is what I was hoping for!

Good to know how to move labels, too. Not very intuitive, though, to first have to "globally" check / activate the "Edit > Edit label" menu entry before the right click context function for the actual move comes to life.

Nevertheless, now that I know, I certainly can live by that. If appropriate, you may mark this issue as solved, because I'm probably not authorized to do so.

Thanks for this fine software and as well for your excellent support!

CS Frank

Issue History

Date Modified Username Field Change
23-10-06 12:32 Frank Stefani New Issue
23-10-06 12:32 Frank Stefani Tag Attached: CdC
23-10-06 12:32 Frank Stefani Tag Attached: Galilean moons
23-10-06 12:32 Frank Stefani Tag Attached: Jupiter
23-10-06 12:32 Frank Stefani Tag Attached: label
23-10-06 12:32 Frank Stefani Tag Attached: skychart
23-10-06 12:32 Frank Stefani Tag Attached: Solar System
23-10-06 12:32 Frank Stefani File Added: Auswahl_007.png
23-10-06 12:32 Frank Stefani File Added: Auswahl_008.png
23-10-06 12:32 Frank Stefani File Added: Auswahl_009.png
23-10-15 18:25 Patrick Chevalley Status new => feedback
23-10-15 18:25 Patrick Chevalley Note Added: 0008584
23-10-15 18:26 Patrick Chevalley Note Edited: 0008584
23-10-17 21:07 Frank Stefani Note Added: 0008596
23-10-17 21:07 Frank Stefani Status feedback => new
23-10-18 14:37 Patrick Chevalley Note Added: 0008602
23-10-18 16:38 Frank Stefani Note Added: 0008603
23-10-19 11:53 Patrick Chevalley Status new => resolved
23-10-19 11:53 Patrick Chevalley Resolution open => no change required