View Issue Details

IDProjectCategoryView StatusLast Update
0000037SkyChart1-Softwarepublic16-03-02 10:49
ReporterSasa Assigned ToPatrick Chevalley  
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionduplicate 
Platformx86OSWindows 
Product Version3.0.1.1 SVN 
Summary0000037: Observer position in space
DescriptionI'm aware that CDC is basically oriented to amateur observer's using telescope.
However, I'm also interesting in possibilitie to allow setting observer's position in space or any object in space. For example, observer's position in Earth orbit, looking to the rendered Earth during Solar eclipse and tracking Moon's shadow. Or on IO, looking on Jupiter, etc.
TagsNo tags attached.

Relationships

related to 0001506 resolvedPatrick Chevalley Solar System Information - some improvement suggestion 

Activities

Patrick Chevalley

06-04-01 10:13

administrator   ~0000073

Yes this is very interesting.
But this is not the goal of CdC and Celestia already do that very nicely.
The solution I will look for is to add a "View in Celestia" popup menu entry that launch a cel: url for the selected object at the current time.
 

Sasa

06-04-02 09:03

reporter   ~0000080

Last edited: 06-04-02 14:30

Yes, I have tried Celestia long time ago, it is very interesting product. However, it require quite large ammount of free space to be installed, extensive downloading objects from web, as well as more phisical memory and 3D accelerator to be run without problems. Since I'm concentrated on software development, hardware I work on relatively old.

It is interesting deoes math implemented in CDC allow it, since it is enough to translate local 3D coorinate system from earth to another object or positions in space (assuming that Sun is a central coordinate system). However, that depends on how basis is designed. However, generealy speaking, every system can be translated to another wit some accurate loosing. As this feature is only a optional, precisioni degradation is not an issue. I'm interesting in producing it when free time allow.

Sasa

16-02-29 20:06

reporter   ~0003330

Last edited: 16-03-01 10:24

View 2 revisions

"...rendered Earth during Solar eclipse..."

This is almost implemented in new version of Solar system info...
Then, this old suggestion can be closed.

Patrick Chevalley

16-03-02 10:49

administrator   ~0003332

Whoa! ten years ...

Nice you can work on the implementation now.

Issue History

Date Modified Username Field Change
06-03-30 21:50 Sasa New Issue
06-04-01 10:13 Patrick Chevalley Note Added: 0000073
06-04-01 10:13 Patrick Chevalley Assigned To => Patrick Chevalley
06-04-01 10:13 Patrick Chevalley Status new => confirmed
06-04-02 09:03 Sasa Note Added: 0000080
06-04-02 09:05 Sasa Note Edited: 0000080
06-04-02 09:06 Sasa Note Edited: 0000080
06-04-02 14:30 Sasa Note Edited: 0000080
08-01-05 14:22 Patrick Chevalley Target Version 0.3.0 => Post 3.2
09-01-12 10:26 Patrick Chevalley Target Version Post 3.2 => 5.0
16-02-29 20:06 Sasa Note Added: 0003330
16-03-01 10:24 Sasa Note Edited: 0003330 View Revisions
16-03-02 10:44 Patrick Chevalley Relationship added related to 0001506
16-03-02 10:49 Patrick Chevalley Note Added: 0003332
16-03-02 10:49 Patrick Chevalley Status confirmed => resolved
16-03-02 10:49 Patrick Chevalley Resolution open => duplicate
16-03-02 10:49 Patrick Chevalley Fixed in Version 0.3.0 =>
16-03-02 10:49 Patrick Chevalley Target Version 5.0 =>