View Issue Details

IDProjectCategoryView StatusLast Update
0001407SkyChart1-Softwarepublic15-09-17 09:41
ReporterteslaStinker Assigned ToPatrick Chevalley  
PriorityhighSeverityfeatureReproducibilityalways
Status resolvedResolutionno change required 
PlatformX86OSWindows 
Summary0001407: 3.4 Version OBJECT LIST, MCPORB.DAT.gz
DescriptionOk, did what you said. Problem I am getting is, the file itself is weird. When I tell the 3.4 version to download it, it shows where it is going to put the file, in this path, user/pc/appdata/local/skychart/MPC/ and when it is done, its not there. As a matter of fact, I cannot find it anywhere in the machine when I do a search. So what I did was, I downloaded it again by going to the MPC site, and when it was done, I used pzip to unzip the file, and what it looked like was all ascii code, not anything of what the normal DAT file looks like. So, when CDC 3.4 trys to download, it gives me a "error 200 ok", whatever that means, and there is not any file. Now, I am on limited amounts here, so I am not liking this when it takes place, for 40mb of data is quite a bit for me to just up and loose it. Now the other file that is DAT, is very large. When I do that one manually, without the CDC, it comes up on my browser and it looks normal, with text as it should... But, I have not downloaded it yet manually, because the cdc is supposed to do that right, but it never puts it either in the file path folder that it says it is supposed to put it in. I have tried both files from CDC 3.4, and it acts as if its downloading, but never writes the file down on the hard drive. HMM, very strange... I have a quad processor in this machine sp ... And I have checked the file name to make certain it is correct. I also am using the 3.2 version on another machine, but have not tried to do anything with that one yet.
Steps To Reproduceredownloaded file that was not .gz compressed one, and it still does not write it where it belongs, nor does it attempt to load it up at all so that one may view it on the screen, the asteroids. I think there is something wrong in the program, that it does not know where it is to put it, and may be discarding it by deleting it. However, when I do download for the low limt one that is limited 5000, from api site, everything works just fine, and it loads it up so you can see it on the screen. Even the comets work. But NOT that MCPORB.DAT, neither compressed or not compressed. AND the compressed one, makes no sense to me why, it is still in ascii code when I am done unzipping it. ? Both win zip and pea zip give the same results on the gz file itself. gibberish garbage, like obama...
TagsNo tags attached.

Activities

Patrick Chevalley

15-05-27 12:54

administrator   ~0003017

Hi,

Please try with the last available version from http://www.ap-i.net/skychart/en/download
Yes, 3.10 is greater than 3.4 ! see: http://en.wikipedia.org/wiki/Software_versioning#Separating_sequences

After installing 3.10 open the menu "Setup/Internet/Orbital elements" and click the button "MPCORB >70Mb". This ensure you use the last download URL as unfortunately the MPC is changing that at some time.

If you need to configure a proxy server to connect to the Internet you must also configure it from "Setup/Internet/Proxy".

Then try "Setup/Solar system/Asteroid/Load MPC file" click the Download button. This work for thousand of people around the world so it must work for you.

The file MCPORB.DAT.gz you download from the MPC site using your web browser is not in zip format but gzip. On Windows you can use 7-zip to extract the file because it support this format (pkzip or winzip not). It is available from http://www.7-zip.org/


Patrick Chevalley

15-05-27 13:01

administrator   ~0003018

And about Kemble you can locate it by searching "Kemble's Cascade" in "Edit/Advanced search", click "Deep sky common name".

teslaStinker

15-06-28 21:39

reporter   ~0003030

Last edited: 15-06-28 22:04

View 4 revisions

tried it again to use the file, did not work, said, non file format. maybe you cannot use a .gz file I do mean, the other is a .dat file... Pea zip and win zip will not convert the .gz correctly. Only thing I can think about is, that MPC has a bad .gz file. But it says in Win Zip, version 9, that it does do .gz formats...??? I may try the other one later the one that you had said above. For I do not like to download larger files. Also, the labels where it says under DATE TIME, simulation tab, does not work right when you try to say, One out of SLOT and I input the ammount. ??? It just gives all the labels on the screen the whole bunch of them, and that prytell is a big mess. I am using the file from ap-i to get the asteroids, but that is limited file... It is not as large as the file I am trying to get to work from the MPC... I think it has to be in the .DAT format in order for the program to recognize it right? Please answer this... I do mean, you do not have some sort of converter built into the program do you,,, that will recognize a .gz format? I hope not. Maybe that would be a good idea for a later on version... Anyway, God will send us some asteroids, so you may as well get ready, after they have told the entire United States that Sodomy queers is just fine with them in Washington, now the hippcrite Supreme Court is going to force it to the country. I would not expect any less from God, but the same exact punishment in the book of Genesis, So you may want to try this out yourself some... In case you have to run from the fire balls....!!! I shall try that trick above...thanks. Hopefully, God just targets DC. I do mean, We do not need them anyway. They are all evil in that place that never do anything except to $$ to death to the very poor of this nation. Sad to say, Daniel the one that gave them the land, DC, would be very dissapointed in them if he was here. Especially that thing they call a president.

teslaStinker

15-07-01 20:21

reporter   ~0003032

Last edited: 15-07-01 21:19

View 4 revisions

OK - - - Here is the scoupe; Have the large file in the program now, Downloaded it from MPC, when i did that, it opened explorer and put the data in that program. So Im standing there watching it download into the browser window, and it takes some time to get it. when it was done, I had to save the file and when I did, it wrote it down as a .txt file. Now, this is normal, and i just renamed the file to .dat format. And that was fine. I then used open office spreadsheet to check both the files, for identicle before load up, and the one that came from AP-I, and the one that I had just downloaded from the MPC. They were. Now, this file I am using is not the .gz file, its the uncompressed one instead. Easier for start out.... Now what is going on, is when I set the general settings, for asteroid tab, after old list is deleted, and new list loaded up, I set magnitude at #10, And its fine, but when I go past #11, the entire set of asteroids go away, poof (dissapear) and do not show themeselves. Now it does not matter if I use Proportional to mag or not, they just dissapear??? Now the other thing is, when I pull up an object list, when they are on the screen, The object list truncates at 2000. Chops it off. is there a way to stop it from doing this please?, (both) so that it brings up the entire list? and no dissapear? I do mean, you can set magnitude to a lower number, but that does not help as you cannot view as many in the entire object list then. The object of viewing all of them in the entire list, is to be able to check distance on all at the same time, without to make the list to small. the amount they have at MPC anyway. Now, there is one other thing, in comparing the lists themselves, They are indenticle except for one thing, the one from API and the one from MPC, - I get a set of data in the position of around #5000, that all have ALL captial letters descripting of them. I dont think these three are asteroids at all, especially one named MPC??? but some kind of divider so that when someone wants the list for just the 5000 drawn up, they just run down it and grab that specific to seperate it with. So one problem here is, the object list is only going to 2000, and truncates. On the asteroid list itself, another problem, the program seems to want to truncate it at 10000, on scrn in certain position shows itself this on bottom bar. Another problem. There is almost 700,000 asteroids in this list from MPC. So, to try to view all of them is kind of hard to do yes, I know, Magnitude seperates it though, when the program seems to have all these limits set on it yuk. Now, could this be affecting the magnitude problem of it displaying itself past magnitude 11? Whatever limits there are set inside the program? Please try to change these remove them, in the next version so that there is no limits set. For I believe the program will handle it all just fine, if you just remove the truncating limits from it. Or can I do that somehow myself maybe? Of course, the 1 step for one day will have to be set of, in order for to use the program without it crashing up yes, (In the Simulation tab,) to get these lists, but so what, i do mean, you can always move that in refrence to the magnitude number that one sets up of. Have no idea why it dissapears on me when I try to go past #11 on magnitude. ??? - The other list lets you , the 5000 one. This one does not, it dissapears past #11 mag. I have had the other list in version 3.10 which I am using yes now, (Thanks,) and it works just fine, In lesser magnitudes of such as even 18, and they are all still on the display, just fine. But the big list, just drops off at magnitude 12... All of them just Dissapears. And this is not so well, when your trying to get the object list to show them all in its own spread sheet.

teslaStinker

15-07-06 01:51

reporter   ~0003033

Last edited: 15-07-06 01:59

View 2 revisions

I suppose you should go ahead and kill this ticket Patrick. Since the new problem is not so much of the old one that is resolved. but is almost kind of. File just does have to do with the same object list sort of, but its a understanding that there must be some kind of limit somewhere yes. I just dont like it when it dissapears from the screen poof. But of course, that does not matter so much if all the data is all being searched. Does the program search the entire MPCORB file if I poke in a asteroid name, or does it only search the magnitude setting that i set, and ignore the others that are not on the screen and truncated off? If it does search it all, then you really dont have a problem here. Its just me... It would just take some getting use to it.. I mean, lowering the magnitude level to brighter, so you could see them all in the fov view... Also depends on the FOV I would use of of course....

Issue History

Date Modified Username Field Change
15-05-23 19:53 teslaStinker New Issue
15-05-27 12:54 Patrick Chevalley Note Added: 0003017
15-05-27 12:54 Patrick Chevalley Assigned To => Patrick Chevalley
15-05-27 12:54 Patrick Chevalley Status new => feedback
15-05-27 13:01 Patrick Chevalley Note Added: 0003018
15-06-01 00:21 teslaStinker Status feedback => assigned
15-06-28 21:39 teslaStinker Note Added: 0003030
15-06-28 21:51 teslaStinker Note Edited: 0003030 View Revisions
15-06-28 22:01 teslaStinker Note Edited: 0003030 View Revisions
15-06-28 22:04 teslaStinker Note Edited: 0003030 View Revisions
15-07-01 10:21 teslaStinker Note View State: 0003030: private
15-07-01 20:21 teslaStinker Note Added: 0003032
15-07-01 20:31 teslaStinker Note Edited: 0003032 View Revisions
15-07-01 20:33 teslaStinker Note View State: 0003030: public
15-07-01 20:52 teslaStinker Note Edited: 0003032 View Revisions
15-07-01 21:19 teslaStinker Note Edited: 0003032 View Revisions
15-07-06 01:51 teslaStinker Note Added: 0003033
15-07-06 01:59 teslaStinker Note Edited: 0003033 View Revisions
15-09-17 09:41 Patrick Chevalley Status assigned => resolved
15-09-17 09:41 Patrick Chevalley Resolution open => no change required