View Issue Details

IDProjectCategoryView StatusLast Update
0001502SkyChart(No Category)public17-01-14 15:21
ReporterMenno KnipperAssigned ToPatrick Chevalley 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformDell Inspiron NotebookOSWindows 10OS Version1015 / 10586.63
Product Version3.10 
Target Version4.0Fixed in Version3.11 SVN 
Summary0001502: Access Denied Problem
DescriptionProblem as described in #1451
Steps To ReproduceAlway happens after mouse or bar scroll
TagsNo tags attached.

Relationships

duplicate of 0001451 resolvedPatrick Chevalley "Access Denied " pop-up appears when dragging chart with mouse or scrool bars See item 1334. 
has duplicate 0001408 resolvedPatrick Chevalley Access denied error 

Activities

Patrick Chevalley

16-02-13 14:21

administrator   ~0003278

I do a few more testing on this issue and I find a way to reproduce the problem.

This is probably because you have run the program as administrator and now you try as standard user.
Running as administrator set wrong right to the configuration directory and you have no more write access.

The solution is to totally delete the directory %localappdata%\Skychart.
To do this open a file explorer as administrator, then type %localappdata% in the location bar.
Now locate the Skychart directory and make a backup copy because you will loss all the program configuration.
Then delete the Skychart directory.

Then run the program as a normal user and everything must be initialize right.

To avoid this problem I make a correction to the program to disallow to run as administrator and I add a test that you can write to the configuration directory.
https://sourceforge.net/p/skychart/code/3233/

fhub

16-02-15 13:10

reporter   ~0003298

"disallow to run as administrator" ???

Sorry, but that's complete nonsense!
There are some programs which can only be run as admin, but so far I've never seen a program which refuses to run as admin.

After todays update I've first patched skychart.exe (the Windows 32bit version) to skip this crappy restriction (because it didn't run anymore for me), but then I saw the new commandline option --allowadmin.

Nevertheless - this new restriction is sheer nonsense.

Franz

Patrick Chevalley

16-02-15 14:06

administrator   ~0003299

Can you give me the reason why you need to run as administrator?

Because the complete nonsense is to run any program with administrator right.
This is totally useless and very dangerous for your system. This is only a bad habit inherited from win95 bad design.

If you know what you do this is not a problem for me, this is why I add the --allowadmin option to add to the shortcut along with the admin right.

But if you look at the number of report I receive for this issue this last years most people that use "run as admin" like a magical incantation do not know what they are doing.
And when they try again, using their normal right, some files in the user directory are no more writable for them and the program crash.
There is unfortunately nothing I can do in the program if the user as no more access to %localappdata%\Skychart
This is also a problem of the Windows api, the function SHGetSpecialFolderLocation for CSIDL_LOCAL_APPDATA return your directory even when running as administrator.

Patrick Chevalley

16-02-15 20:23

administrator   ~0003308

OK, this is worst than I expected.
A few googling on this reveal hundred of "recommendation" to run skychart as administrator :(

So revision 3246 remove this restriction and the related option. The punishment will be only the next time the program is run as standard user:
https://sourceforge.net/p/skychart/code/3246/

Patrick Chevalley

16-02-16 08:09

administrator   ~0003312

Version 3246 is now available:
https://sourceforge.net/projects/skychart/files/0-beta/2016-02-16/

Issue History

Date Modified Username Field Change
16-02-13 01:43 Menno Knipper New Issue
16-02-13 14:08 Patrick Chevalley Relationship added duplicate of 0001451
16-02-13 14:21 Patrick Chevalley Note Added: 0003278
16-02-13 14:21 Patrick Chevalley Assigned To => Patrick Chevalley
16-02-13 14:21 Patrick Chevalley Status new => feedback
16-02-13 14:21 Patrick Chevalley Target Version => 4.0
16-02-15 13:10 fhub Note Added: 0003298
16-02-15 14:06 Patrick Chevalley Note Added: 0003299
16-02-15 20:23 Patrick Chevalley Note Added: 0003308
16-02-15 20:23 Patrick Chevalley Status feedback => resolved
16-02-15 20:23 Patrick Chevalley Resolution open => fixed
16-02-15 20:23 Patrick Chevalley Fixed in Version => 3.11 SVN
16-02-16 08:09 Patrick Chevalley Note Added: 0003312
17-01-14 15:21 Patrick Chevalley Relationship added has duplicate 0001408