View Issue Details

IDProjectCategoryView StatusLast Update
0001505SkyChart1-Softwarepublic16-02-15 19:56
ReporterSasa Assigned ToPatrick Chevalley  
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSKubuntuOS Version14.04
Product Version3.11 SVN 
Target Version4.0Fixed in Version3.11 SVN 
Summary0001505: Printing issues
DescriptionInstalled latest .deb (3229)

No printer is installed on this OS (Postscript, 300 DPI is shown by default from CDC). Several issues are present.

1. On CDC main menu, "File->Print Preview" item exists. However, on click on it, some delay of about 30 sec is present, after which form of about 50x250 pixels is show. After manual resize, preview of the chart is nothing shown (only buttons). Click on Print button, AV is shown. After that "Print Preview" item vanished. I did not installed real printer, however I believe then form is fully opened with chart content.

2. CDC "File->Print" item click. It show form. Click on its "Print" button .ps file is created (checked in "Print Setup") and opened automatically by Ocular. If select "Bitmap" in "Print Setup" it create PNG and open in Ocular. Except name "Bitmap" instead perhaps "Image", it seems that all is fine here.

3. Reopen CDC and click on "File->Printer Setup" and select "Bitmap" then OK. After that "Print Preview" item vanished.

- According to documentation, "Print Preview" is only visible when there is real printer in "Printer Setup" selected. Perhaps to check if real printer is available on
 
- PNG is to large and too slow to create. Perhaps to add possibility to choose between JPG/PNG?

- Components on the Print form is a bit miss-positioned. (Attached). Oxygen theme and default fonts on OS and inside CDC.


TagsNo tags attached.

Activities

Sasa

16-02-14 21:37

reporter  

Print form.jpeg (38,010 bytes)   
Print form.jpeg (38,010 bytes)   

Sasa

16-02-14 21:43

reporter   ~0003287

Last edited: 16-02-14 21:49

View 3 revisions

"...Perhaps to check if real printer is available on application opening in order to disable "Print Preview" item."

Sorry.

Patrick Chevalley

16-02-15 08:50

administrator   ~0003289

The problem is only a wrong initial default when no printer is installed, after the first time you open Printer Setup it show an error message and select PS, then you can no more select "System printer" again if no printer is available.

Revision 3239 fix the initial default value and resize the print dialog for no overlap:
https://sourceforge.net/p/skychart/code/3239/

The print to bitmap function is intended for high quality large size bitmap but JPG is very bad to render a line mode map.
You can reduce the bitmap size in Print Setup (resolution and page size).
For screen size JPG use the File / Save image.. function.

Sasa

16-02-15 18:21

reporter   ~0003302

Last edited: 16-02-15 18:34

View 4 revisions

I have recompiled latest SVN, however "Print Preview" item is still visible on main menu...

This new test code I have placed show there is no printer. There is some other problem, as setting MenuPrintPreview.Visible:=(cfgm.PrintMethod=0) have no effect here, probably is reset somewhere else...

...
if Printer.PrinterIndex>=0 then
 cfgm.PrintMethod:=0
else
 cfgm.PrintMethod:=1;

//New test code

if cfgm.PrintMethod=0 then
   ShowMessage('Have printer')
else
  ShowMessage('Have NO printer');

MenuPrintPreview.Visible:=(cfgm.PrintMethod=0) ;

Patrick Chevalley

16-02-15 19:56

administrator   ~0003306

Yes this part of the code set the default value for the first time you run the program. After that the destination printer is read from the config file.

Revision 3245 fix this problem, and also in the case someone remove all it's printer:
https://sourceforge.net/p/skychart/code/3245/

Issue History

Date Modified Username Field Change
16-02-14 21:36 Sasa New Issue
16-02-14 21:37 Sasa File Added: Print form.jpeg
16-02-14 21:43 Sasa Note Added: 0003287
16-02-14 21:44 Sasa Note Edited: 0003287 View Revisions
16-02-14 21:49 Sasa Note Edited: 0003287 View Revisions
16-02-15 08:50 Patrick Chevalley Note Added: 0003289
16-02-15 08:50 Patrick Chevalley Assigned To => Patrick Chevalley
16-02-15 08:50 Patrick Chevalley Status new => resolved
16-02-15 08:50 Patrick Chevalley Resolution open => fixed
16-02-15 08:50 Patrick Chevalley Fixed in Version => 3.11 SVN
16-02-15 08:50 Patrick Chevalley Target Version => 4.0
16-02-15 18:21 Sasa Note Added: 0003302
16-02-15 18:21 Sasa Status resolved => new
16-02-15 18:21 Sasa Resolution fixed => reopened
16-02-15 18:25 Sasa Note Edited: 0003302 View Revisions
16-02-15 18:25 Sasa Note Edited: 0003302 View Revisions
16-02-15 18:34 Sasa Note Edited: 0003302 View Revisions
16-02-15 19:56 Patrick Chevalley Note Added: 0003306
16-02-15 19:56 Patrick Chevalley Status new => resolved
16-02-15 19:56 Patrick Chevalley Resolution reopened => fixed