View Issue Details

IDProjectCategoryView StatusLast Update
0001508SkyChart1-Softwarepublic16-02-17 11:25
ReporterSasa Assigned ToPatrick Chevalley  
PrioritynoneSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinux 64-bitOSKubuntuOS Version14.04
Product Version3.11 SVN 
Target Version4.0Fixed in Version3.11 SVN 
Summary0001508: Mouse wheel up/down automatic inc/dec ability
DescriptionUnlike on Delphi, Lazarus do not provide automatic increase/decrease number when Mouse wheel is triggered in associated TEdit instance.

This is useful feature sometimes. However, on Lazarus currently this feature implementation is code is not quite trivial...

Perhaps it is much more reasonable to submit request in Lazarus bugtracker?
TagsNo tags attached.

Activities

Patrick Chevalley

16-02-15 09:57

administrator   ~0003293

It is not difficult to derivate a component from TEdit that handle a mousewheel event to increment the value.
But this is to do only if the edit contain an integer value.
I already use a specific component TLongEdit for integer input so I can change this component for this function.

Sasa

16-02-15 10:51

reporter   ~0003294

Last edited: 16-02-15 10:52

View 2 revisions

I have missed important - to mentioned TUpDown component here. Sorry...

That is what I wanted to point out - associated TEdit with TUpDown in Lazarus do not behaves the same as the same pair in Delphi on mouse wheel in TEedit instance.

Patrick Chevalley

16-02-17 11:25

administrator   ~0003319

I make a change that implement this feature, at least partially because the mouse must be over the TUpDown buttons, not the TEdit, because there is no easy way to find if an Edit is associated with an UpDown in it's mousewheel event.

Revision 3249 add the TMouseUpDown component:
https://sourceforge.net/p/skychart/code/3249/

Revision 3250 replace every TUpDown by TMouseUpDown:
https://sourceforge.net/p/skychart/code/3250/

Because of the new component you may have to rebuild Lazarus (Tools/Build Lazarus) to avoid form loading error.

Issue History

Date Modified Username Field Change
16-02-15 07:41 Sasa New Issue
16-02-15 09:57 Patrick Chevalley Note Added: 0003293
16-02-15 09:57 Patrick Chevalley Assigned To => Patrick Chevalley
16-02-15 09:57 Patrick Chevalley Status new => acknowledged
16-02-15 09:57 Patrick Chevalley Target Version => 4.0
16-02-15 10:51 Sasa Note Added: 0003294
16-02-15 10:52 Sasa Note Edited: 0003294 View Revisions
16-02-17 11:25 Patrick Chevalley Note Added: 0003319
16-02-17 11:25 Patrick Chevalley Status acknowledged => resolved
16-02-17 11:25 Patrick Chevalley Resolution open => fixed
16-02-17 11:25 Patrick Chevalley Fixed in Version => 3.11 SVN