View Issue Details

IDProjectCategoryView StatusLast Update
0001509SkyChart1-Softwarepublic16-02-16 08:47
ReporterSasa Assigned ToPatrick Chevalley  
PrioritylowSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinux 64-bitOSKubuntu 
Product Version3.11 SVN 
Target Version4.0Fixed in Version3.11 SVN 
Summary0001509: Too short width on some components or mis-positioned
DescriptionThere is quite a few short width on many components, on many forms. That is a bit more complicated when change default language. Or other components are mis-positioned

For instance:

- Observatory form. Text "North" was cutoff (fixed in latest SVN revision), also should be check with other languages. Minute edit field is too short - visible, however too close to the right border and if selected it is a bit.

- Ephemeris calendar - similar for edit fields to set time
- Planet settings - Jupiter GRS longitude edit field
- Asteroid settings, Data maintenance tab - almost all mis-positioned
- Display colors - almost all mis-positioned
- Variable stars observer - Date, JD, Dec, are cutoff as well as "Output date format" panel

Etc. Perhaps there is more.


TagsNo tags attached.

Activities

Patrick Chevalley

16-02-15 11:43

administrator   ~0003295

Can you give me what is your screen dpi and default Gtk font size?

Sasa

16-02-15 14:19

reporter   ~0003300

I have attached related System default settings and "Variable star" CDC form screenshot.

Sasa

16-02-15 14:19

reporter  

Sasa

16-02-15 14:20

reporter  

Sasa

16-02-15 14:20

reporter  

Sasa

16-02-15 14:23

reporter  

Variables star - screenshot.jpeg (239,785 bytes)   
Variables star - screenshot.jpeg (239,785 bytes)   

Patrick Chevalley

16-02-15 19:04

administrator   ~0003304

All this problem is because I only take account for screen DPI to resize the control, not the font size.
And you use a font size of 12 for Gtk, bigger than for KDE, and this make all this problems.

I have fixed that by also computing a resizing based on the font size.
Now everything work fine, even if you set a default font size of 14 or 16.
Done by revision 3241 to 3243:
https://sourceforge.net/p/skychart/code/3241/

Revision 3244 do the fix for Varobs:
https://sourceforge.net/p/skychart/code/3244/

Sasa

16-02-15 21:52

reporter   ~0003310

Last edited: 16-02-15 22:16

View 4 revisions

These are all default settings, I have change nothing regarding fonts...

Unfortunately, there is still many GUI problems. I will attach screen shots for these still problematic...

Variables star form is exactly the same as it was.

Sasa

16-02-15 21:54

reporter  

Sasa

16-02-15 21:56

reporter  

Asteroids - mispositioned.jpeg (70,047 bytes)   
Asteroids - mispositioned.jpeg (70,047 bytes)   

Sasa

16-02-15 21:58

reporter  

Patrick Chevalley

16-02-16 08:33

administrator  

gtk2-default.jpg (66,331 bytes)   
gtk2-default.jpg (66,331 bytes)   

Patrick Chevalley

16-02-16 08:47

administrator   ~0003314

Yes, but the bug is not with Skychart, but with oxygen-gtk theme.
I never use this theme because it is full of bug and even crashed some application. And it is a Kubuntu bug to make it by default.
Fortunately it is not the default in 15.10 and will probably not be in new 16.04 lts.

See the screen shot I make with the default gtk2, without any theme.

If you want a theme that look like KDE in 14.04 please use QtCurve which is much better.

I will not move or resize the component position just for this theme because it will make too much spacing on the other system.


Issue History

Date Modified Username Field Change
16-02-15 08:24 Sasa New Issue
16-02-15 11:43 Patrick Chevalley Note Added: 0003295
16-02-15 11:43 Patrick Chevalley Assigned To => Patrick Chevalley
16-02-15 11:43 Patrick Chevalley Status new => feedback
16-02-15 14:19 Sasa Note Added: 0003300
16-02-15 14:19 Sasa Status feedback => assigned
16-02-15 14:19 Sasa File Added: Font settings- default on Kubuntu GTK.jpeg
16-02-15 14:20 Sasa File Added: Font settings- default on Kubuntu.jpeg
16-02-15 14:20 Sasa File Added: Font settings- default in CDC.jpeg
16-02-15 14:23 Sasa File Added: Variables star - screenshot.jpeg
16-02-15 19:04 Patrick Chevalley Note Added: 0003304
16-02-15 19:04 Patrick Chevalley Status assigned => resolved
16-02-15 19:04 Patrick Chevalley Resolution open => fixed
16-02-15 19:04 Patrick Chevalley Fixed in Version => 3.11 SVN
16-02-15 19:04 Patrick Chevalley Target Version => 4.0
16-02-15 21:52 Sasa Note Added: 0003310
16-02-15 21:52 Sasa Status resolved => new
16-02-15 21:52 Sasa Resolution fixed => reopened
16-02-15 21:52 Sasa Note Edited: 0003310 View Revisions
16-02-15 21:54 Sasa File Added: Planet settings - Jupiter GRS value cutoff.jpeg
16-02-15 21:56 Sasa File Added: Asteroids - mispositioned.jpeg
16-02-15 21:58 Sasa File Added: Display color - mispositioned.jpeg
16-02-15 22:12 Sasa Note Edited: 0003310 View Revisions
16-02-15 22:16 Sasa Note Edited: 0003310 View Revisions
16-02-16 08:33 Patrick Chevalley File Added: gtk2-default.jpg
16-02-16 08:47 Patrick Chevalley Note Added: 0003314
16-02-16 08:47 Patrick Chevalley Status new => resolved
16-02-16 08:47 Patrick Chevalley Resolution reopened => fixed