View Issue Details

IDProjectCategoryView StatusLast Update
0001558SkyChart1-Softwarepublic16-10-25 11:50
ReporterTerry Haimann Assigned ToPatrick Chevalley  
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
PlatformIntel i7-64OSUbuntuMate 
Target Version4.0Fixed in Version3.11 SVN 
Summary0001558:
DescriptionSkychart won't install on Ubuntu Mate 16.10. It appears to need a newer version of a library. I could not install libpng12-0, Ubuntu 16-10 appears to be on libpng16
Steps To Reproduce(Reading database ... 268528 files and directories currently installed.)
Preparing to unpack skychart_3.11-3287_amd64.deb ...
Unpacking skychart (3.11-3287) over (3.11-3287) ...
dpkg: dependency problems prevent configuration of skychart:
 skychart depends on libjpeg62; however:
  Package libjpeg62 is not installed.
 skychart depends on libpng12-0; however:
  Package libpng12-0 is not installed.
 skychart depends on libpasastro; however:
  Package libpasastro is not installed.
 skychart depends on xplanet; however:
  Package xplanet is not installed.

dpkg: error processing package skychart (--install):
 dependency problems - leaving unconfigured
Processing triggers for hicolor-icon-theme (0.15-1) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.3+16.10.20160929-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.60ubuntu1) ...
Errors were encountered while processing:
 skychart
TagsNo tags attached.

Activities

Sasa

16-10-25 07:58

reporter   ~0003385

If you install SkyChart by dpkg, note that latest Skychart depends on:
https://sourceforge.net/projects/libpasastro/

You have to manually install it before skychart.

To fix other dependences:
sudo apt-get -f install

Patrick Chevalley

16-10-25 11:50

administrator   ~0003387

Sorry to miss that. I tested 16.10 on a virtual machine upgraded from 16.04 and the upgrade do not remove libpng12, so it worked.

I remove the direct dependency to libpng and libjpeg as this is already done by the dependency to libgtk2 and in this case it use the right version for any system.

This is fixed by rev 3298:
https://sourceforge.net/p/skychart/code/3298/

Please get the 3299 version from:
https://sourceforge.net/projects/skychart/files/0-beta/2016-10-25/

Do not forget to install the other dependencies as explained by Sasa, or add my unstable repository as described in the following link to make everything automatic:
https://www.ap-i.net/skychart/en/documentation/installation_on_linux_ubuntu

Issue History

Date Modified Username Field Change
16-10-24 22:53 Terry Haimann New Issue
16-10-25 07:58 Sasa Note Added: 0003385
16-10-25 11:50 Patrick Chevalley Note Added: 0003387
16-10-25 11:50 Patrick Chevalley Assigned To => Patrick Chevalley
16-10-25 11:50 Patrick Chevalley Status new => resolved
16-10-25 11:50 Patrick Chevalley Resolution open => fixed
16-10-25 11:50 Patrick Chevalley Fixed in Version => 3.11 SVN
16-10-25 11:50 Patrick Chevalley Target Version => 4.0