View Issue Details

IDProjectCategoryView StatusLast Update
0001642SkyChart1-Softwarepublic17-03-25 14:07
ReporterPete Gladstein Assigned ToPatrick Chevalley  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOSSierraOS Version10.12.3
Target Version4.0Fixed in Version3.11 SVN 
Summary0001642: Unable to Change Chart Colors - CdC Freezes
DescriptionIf you select Setup/Display/Colour and select Horizon for example and change the color then CdC basically freezes. In other words, you cannot quit the program because Skychart/Quit Skychart is dimmed. The only way to quit Skycart is via "Force Quit"
TagsNo tags attached.

Relationships

related to 0001696 resolvedPatrick Chevalley Crash after site configuration 

Activities

Patrick Chevalley

17-02-14 17:44

administrator   ~0003602

Last edited: 17-02-14 17:51

View 3 revisions

I can reproduce the problem with Sierra and also Yosemite.

CdC is not frozen, it still respond to keyboard command (try arrow keys or +/-), moving the mouse over a button show the hints, so mouse move event is processed normally, but the mouse click are totally ineffective.

I do more search for a solution.

Pete Gladstein

17-02-14 18:33

reporter   ~0003603

Actually the mouse still works. After changing color I click on Setup/Save configuration now which works. The issue is that Skychart/Quit Skychart is dimmed. Hence the only way to quit CdC is "Force Quit" plus CdC does not remember color change. I hope this helps.

Patrick Chevalley

17-02-15 14:18

administrator   ~0003604

Think I found a bypass for this bug.
Please try with next beta, probably next Monday, and re-open if you still have a problem.

Fixed by rev 3516:
https://sourceforge.net/p/skychart/code/3516/

Issue History

Date Modified Username Field Change
17-02-14 02:43 Pete Gladstein New Issue
17-02-14 17:44 Patrick Chevalley Assigned To => Patrick Chevalley
17-02-14 17:44 Patrick Chevalley Status new => confirmed
17-02-14 17:44 Patrick Chevalley Note Added: 0003602
17-02-14 17:45 Patrick Chevalley Project CCdciel => SkyChart
17-02-14 17:50 Patrick Chevalley Note Edited: 0003602 View Revisions
17-02-14 17:51 Patrick Chevalley Note Edited: 0003602 View Revisions
17-02-14 18:33 Pete Gladstein Note Added: 0003603
17-02-15 14:18 Patrick Chevalley Status confirmed => resolved
17-02-15 14:18 Patrick Chevalley Resolution open => fixed
17-02-15 14:18 Patrick Chevalley Category General => 1-Software
17-02-15 14:18 Patrick Chevalley Fixed in Version => 3.11 SVN
17-02-15 14:18 Patrick Chevalley Target Version => 4.0
17-02-15 14:18 Patrick Chevalley Note Added: 0003604
17-03-25 14:07 Patrick Chevalley Relationship added related to 0001696