View Issue Details

IDProjectCategoryView StatusLast Update
0001651SkyChart1-Softwarepublic17-02-21 15:37
ReporterSasaAssigned ToPatrick Chevalley 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSLubuntu 32-bitOS Version16.10
Product Version3.11 SVN 
Target Version4.0Fixed in Version3.11 SVN 
Summary0001651: Lubuntu support
DescriptionAfter installed 32-bit Lubuntu 16.10, libpasastro_1.1-14_i386.deb abd skychart_3.11-3526_i386.deb bu dpkg, dependencies are fixed with sudo apt-get -f install.

After running skychart, it crashed complaining libGLU lib is missing. Is it possible Lubuntu to be fully supported during installation, as it is low memory consuming Ubuntu based OS for a bit older computers?
Additional Informationdpkg: dependency problems prevent configuration of skychart:
 skychart depends on libpango1.0-0; however:
  Package libpango1.0-0 is not installed.
 skychart depends on xplanet; however:
  Package xplanet is not installed.
 skychart depends on espeak; however:
  Package espeak is not installed.

$sudo apt-get -f install
$skychart

skychart
[FORMS.PP] ExceptionOccurred
  Sender=Exception
  Exception=Could not load library: libGLU.so.1
  Stack trace:
  $086580CA
  $086585DA
TApplication.HandleException Could not load library: libGLU.so.1
  Stack trace:
  $086580CA
  $086585DA
Exception at 086580CA: Exception:
Could not load library: libGLU.so.1.
TagsNo tags attached.

Activities

Patrick Chevalley

17-02-21 12:50

administrator   ~0003624

Strange, because skychart must not depend on OpenGL.
But I confirm I get the same error if I rename my libGLU on my system.

I try to find the faulty component and remove this dependency.

In the mean time you can solve the problem with "apt install libglu1-mesa"

Patrick Chevalley

17-02-21 14:20

administrator   ~0003626

The problem is bgrabitmap, it look like some time ago the opengl part was merged to the main component (before that they where separated in another package).
Maybe it is possible to separate this files, but I prefer to not touch the package.

This is fixed by adding libGLU to the packages requirement in rev 3527:
https://sourceforge.net/p/skychart/code/3527/

Patrick Chevalley

17-02-21 15:37

administrator   ~0003628

About the source of the problem on your new install of lubuntu.
This is because since 16.10 lubuntu-core no more depend on the xorg meta-package, and libGLU was a dependency of xorg.

Issue History

Date Modified Username Field Change
17-02-21 10:58 Sasa New Issue
17-02-21 12:50 Patrick Chevalley Assigned To => Patrick Chevalley
17-02-21 12:50 Patrick Chevalley Status new => assigned
17-02-21 12:50 Patrick Chevalley Target Version => 4.0
17-02-21 12:50 Patrick Chevalley Note Added: 0003624
17-02-21 14:20 Patrick Chevalley Status assigned => resolved
17-02-21 14:20 Patrick Chevalley Resolution open => fixed
17-02-21 14:20 Patrick Chevalley Fixed in Version => 3.11 SVN
17-02-21 14:20 Patrick Chevalley Note Added: 0003626
17-02-21 15:37 Patrick Chevalley Note Added: 0003628