View Issue Details

IDProjectCategoryView StatusLast Update
0001652SkyChart1-Softwarepublic17-02-22 19:41
ReporterPete GladsteinAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOSMacOSOS VersionSierra
Product Version3.11 SVN 
Target Version4.0Fixed in Version3.11 SVN 
Summary0001652: Unable to Change Open Cluster Color
DescriptionUnable to move color selector within color wheel.

See attachment.
TagsNo tags attached.

Activities

Pete Gladstein

17-02-21 19:41

reporter  

screenshot-1.jpg (360,547 bytes)
screenshot-1.jpg (360,547 bytes)

Patrick Chevalley

17-02-21 20:52

administrator   ~0003632

I cannot reproduce the problem with my Sierra virtual machine.
Can you give me more details:
- is the problem only with Open cluster, or also with other color box in this page?
- can you select another selection widget, like the crayon in the color dialog? do it work?
- do you see the mouse cursor arrow in front of the color wheel? do the reticle move if you click on the color wheel?
- can you move the two cursor for color density and opacity?


But what I remarked is the initial color in the color dialog is wrong, always orange instead of the object color. This is fixed in https://sourceforge.net/p/skychart/code/3530/

Pete Gladstein

17-02-21 22:09

reporter   ~0003633

I can move the reticle for some Object Types. If I click on the color wheel then I can move the reticle in all Object Types. Is that the way it's supposed to work? Also, crayons work.

Related issue - The color of the Open Cluster in the Object Type pane is different than what is displayed on the chart and legend. See attachment.

I hope this helps. Thanks.

screenshot.jpg (221,204 bytes)
screenshot.jpg (221,204 bytes)

Patrick Chevalley

17-02-22 09:22

administrator   ~0003634

I not make this color wheel, this is a standard Apple dialog, so I don't know exactly how it is supposed to work.
But if I open the system desktop settings, choose a plain color background and click the button to customize the color, this color wheel work the same. I think you must click in to move the cursor to avoid some unwanted change.

The colors in your screenshot is not the same because they are modulated by the object brightness. This way it is easy to see that M39 is brighter than NGC7082.

You can adjust this effect with the two cursor in the second part of this screen. To get the pure color for every object you can put "High surface brightness" about 3/4 to the right, then "Low surface brightness" at the same position.

Do this solve the issue ?

Pete Gladstein

17-02-22 15:51

reporter   ~0003637

OK, I now understand. However, I have one question.

Why are these colors different - attachment screenshot-3.

screenshot-3.jpg (147,204 bytes)
screenshot-3.jpg (147,204 bytes)

Patrick Chevalley

17-02-22 19:41

administrator   ~0003640

This orange color become brown when darkened.
And I have a limitation to the brightness of the cluster that prevent it to show the right color.

I have removed this limitation in rev 3536 and it is much better.
https://sourceforge.net/p/skychart/code/3536/

Issue History

Date Modified Username Field Change
17-02-21 19:41 Pete Gladstein New Issue
17-02-21 19:41 Pete Gladstein File Added: screenshot-1.jpg
17-02-21 20:52 Patrick Chevalley Assigned To => Patrick Chevalley
17-02-21 20:52 Patrick Chevalley Status new => feedback
17-02-21 20:52 Patrick Chevalley Note Added: 0003632
17-02-21 22:09 Pete Gladstein File Added: screenshot.jpg
17-02-21 22:09 Pete Gladstein Note Added: 0003633
17-02-21 22:09 Pete Gladstein Status feedback => assigned
17-02-22 09:22 Patrick Chevalley Note Added: 0003634
17-02-22 15:51 Pete Gladstein File Added: screenshot-3.jpg
17-02-22 15:51 Pete Gladstein Note Added: 0003637
17-02-22 19:41 Patrick Chevalley Status assigned => resolved
17-02-22 19:41 Patrick Chevalley Resolution open => fixed
17-02-22 19:41 Patrick Chevalley Fixed in Version => 3.11 SVN
17-02-22 19:41 Patrick Chevalley Target Version => 4.0
17-02-22 19:41 Patrick Chevalley Note Added: 0003640