View Issue Details

IDProjectCategoryView StatusLast Update
0001655SkyChart1-Softwarepublic17-02-23 09:36
ReporterSasaAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSLubuntu 32-bitOS Version16.10
Product Version3.11 SVN 
Target Version4.0Fixed in Version3.11 SVN 
Summary0001655: List of language - mispositioned
DescriptionThe list of language is mispositioned. That seems to be old bug persistent on Kubuntu as well.

The first item is positioned correctly (under parent button), however top arrow is almost on top of form and between is empty space which is the filled on scroll down...

Probably bug of Lazarus component.
Steps To ReproduceSetup -> General -> Languages

Then click on button.
TagsNo tags attached.

Activities

Sasa

17-02-22 17:59

reporter  

List of languages.png (259,350 bytes)
List of languages.png (259,350 bytes)

Patrick Chevalley

17-02-22 19:47

administrator   ~0003641

I cannot reproduce the problem.
The bug is probably with your Gtk2 theme, can you give me the theme name?

Sasa

17-02-22 21:11

reporter   ~0003643

Last edited: 17-02-22 21:12

View 2 revisions

I'm not certain how to obtain that info - I do not see any GTK2 settings at all. It is actually all minimalistic from Lubuntu main menu.

In general, all is default setting of fresh Lubuntu installation. However, I'm certain the same issue was with previous Kubuntu.

Theme is definitely different. In addition, I'm attaching look of Solar System Info. Obviously, checkboxes are different and as well white borders are shown on radio group.



Patrick Chevalley

17-02-23 09:36

administrator   ~0003644

The origin of the problem is GTk2 do not take account of the dropdowncount parameter and alway try to show the full list.
Then you get this effect is because the list is bigger than your screen height, nothing can be changed here.

But as there is enough space in this page I replace the combo by a listbox.
It is much better this way.

https://sourceforge.net/p/skychart/code/3539/

Issue History

Date Modified Username Field Change
17-02-22 17:59 Sasa New Issue
17-02-22 17:59 Sasa File Added: List of languages.png
17-02-22 19:47 Patrick Chevalley Status new => feedback
17-02-22 19:47 Patrick Chevalley Note Added: 0003641
17-02-22 21:11 Sasa File Added: 2017-02-22-204913_1024x768_scrot.png
17-02-22 21:11 Sasa Note Added: 0003643
17-02-22 21:11 Sasa Status feedback => new
17-02-22 21:12 Sasa Note Edited: 0003643 View Revisions
17-02-23 09:36 Patrick Chevalley Assigned To => Patrick Chevalley
17-02-23 09:36 Patrick Chevalley Status new => resolved
17-02-23 09:36 Patrick Chevalley Resolution open => fixed
17-02-23 09:36 Patrick Chevalley Fixed in Version => 3.11 SVN
17-02-23 09:36 Patrick Chevalley Target Version => 4.0
17-02-23 09:36 Patrick Chevalley Note Added: 0003644