View Issue Details

IDProjectCategoryView StatusLast Update
0001661SkyChart1-Softwarepublic17-02-25 16:38
ReporterSasaAssigned ToPatrick Chevalley 
PrioritynormalSeveritytrivialReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformLinuxOSLubuntu 32-bitOS Version16.10
Product Version3.11 SVN 
Target Version4.0Fixed in Version3.11 SVN 
Summary0001661: Object list: More than 2000 object, result is truncated
DescriptionLast downloaded installable beta (SVN 3526), default settings.

"More than 2000 object, result is truncated"

If select all objects filter (including stars), upper info is shown.
Perhaps to change with: "N objects are shown and 2000 is listed only"?

As well, I would expect full list and info how many objects are displayed for basic catalogs. it seems to me 2000 limit is too small. Bright Star Catalog contain 9096 starts, SAC 10600. Populating grid with maximum 10600 stars will not be too slow (I suppose), even that will not be exceeded whatever FOV is used in CDC.

Thus my suggestion is to enlarge limit from 2000 to some about max SAC value.

TagsNo tags attached.

Activities

Sasa

17-02-24 15:55

reporter  

Chart_1.cdc3 (11,168 bytes)

Patrick Chevalley

17-02-25 16:38

administrator   ~0003656

I set this limit long ago because Delphi on Win95 crashed with a higher value.

I test with 100000 ucac stars and there is no problem, memory consumption is reasonable.

I cannot change the message because the total number of object is not know in advance. And with the new limit it is very unlikely you get it.

Revision 3545 set the limit to 100000.
https://sourceforge.net/p/skychart/code/3545

Issue History

Date Modified Username Field Change
17-02-24 15:55 Sasa New Issue
17-02-24 15:55 Sasa File Added: Chart_1.cdc3
17-02-25 16:38 Patrick Chevalley Assigned To => Patrick Chevalley
17-02-25 16:38 Patrick Chevalley Status new => resolved
17-02-25 16:38 Patrick Chevalley Resolution open => fixed
17-02-25 16:38 Patrick Chevalley Fixed in Version => 3.11 SVN
17-02-25 16:38 Patrick Chevalley Target Version => 4.0
17-02-25 16:38 Patrick Chevalley Note Added: 0003656