View Issue Details

IDProjectCategoryView StatusLast Update
0001665SkyChart1-Softwarepublic17-02-28 11:34
ReporterMichael BauerAssigned ToPatrick Chevalley 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSLubuntuOS VersionYakkety
Product Version3.10 
Target Version4.0Fixed in Version3.11 SVN 
Summary0001665: Cannot install skychart
DescriptionSir,

I cannot install skychart follwing your instructions for Ubuntu.

Please see the error messages below.

Thank you
Steps To ReproduceOK:8 http://de.archive.ubuntu.com/ubuntu yakkety-backports InRelease
Holen:5 http://vega.ap-i.net/apt stable InRelease [2.583 B]
Ign:5 http://vega.ap-i.net/apt stable InRelease
Holen:9 http://vega.ap-i.net/apt stable/main i386 Packages [1.266 B]
Es wurden 106 kB in 4 s geholt (23,6 kB/s).
Paketlisten werden gelesen... Fertig
W: GPG-Fehler: http://vega.ap-i.net/apt stable InRelease: Die folgenden Signaturen konnten nicht überprüft werden, weil ihr öffentlicher Schlüssel nicht verfügbar ist: NO_PUBKEY C56CCB02D79BF92A
W: The repository 'http://www.ap-i.net/apt stable InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
mb@mb-MS-6590:~$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys D79BF92A
Executing: /tmp/tmp.zA9Wb49lKV/gpg.1.sh --keyserver
keyserver.ubuntu.com
--recv-keys
D79BF92A
gpg: Empfangen vom Schlüsselserver fehlgeschlagen: Die Wartezeit für die Verbindung ist abgelaufen
TagsNo tags attached.

Activities

Patrick Chevalley

17-02-27 08:36

administrator   ~0003664

This key D79BF92A is outdated and will be replaced soon.

But it must still work, I just run the apt-key command right now and it work.
Can you try again to install the key?

Michael Bauer

17-02-27 12:57

reporter   ~0003665

mb@mb-MS-6590:~$ sudo apt-add-repository --remove 'deb-src http://www.ap-i.net/apt stable main'
mb@mb-MS-6590:~$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys D79BF92A
Executing: /tmp/tmp.1AP9pyGNDh/gpg.1.sh --keyserver
keyserver.ubuntu.com
--recv-keys
D79BF92A
gpg: Empfangen vom Schlüsselserver fehlgeschlagen: Die Wartezeit für die Verbindung ist abgelaufen

mb@mb-MS-6590:~$ sudo apt-get update
[sudo] Passwort für mb:
OK:1 http://de.archive.ubuntu.com/ubuntu yakkety InRelease
OK:2 http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu yakkety InRelease
OK:3 http://de.archive.ubuntu.com/ubuntu yakkety-updates InRelease
Holen:5 http://security.ubuntu.com/ubuntu yakkety-security InRelease [102 kB]
OK:6 http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu yakkety InRelease
OK:7 http://de.archive.ubuntu.com/ubuntu yakkety-backports InRelease
OK:8 http://ppa.launchpad.net/stellarium/stellarium-releases/ubuntu yakkety InRelease
Holen:4 http://vega.ap-i.net/apt stable InRelease [2.583 B]
Ign:4 http://vega.ap-i.net/apt stable InRelease
Es wurden 105 kB in 4 s geholt (25,9 kB/s).
Paketlisten werden gelesen... Fertig
W: GPG-Fehler: http://vega.ap-i.net/apt stable InRelease: Die folgenden Signaturen konnten nicht überprüft werden, weil ihr öffentlicher Schlüssel nicht verfügbar ist: NO_PUBKEY C56CCB02D79BF92A
W: The repository 'http://www.ap-i.net/apt stable InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Dear Patrick,
I tried again today, but no success.

Question: The key seems not to work for me. Must I open special ports in the router?

Question: sudo apt-get update tries to get info from Holen: 4 http//:vega.ap-i.net... But then it says Ign. Does this mean Ignore?

Thanks for the help,

Michael

Patrick Chevalley

17-02-27 15:48

administrator   ~0003669

Yes, the problem is the key is not downloaded from the ubuntu keyserver.
apt-key use port hkp (11371/tcp) but normally a router accept any port in output.

You can try the following to use http port:

gpg --keyserver hkp://keyserver.ubuntu.com:80 --recv D79BF92A
gpg --export --armor D79BF92A | sudo apt-key add -


Michael Bauer

17-02-27 19:42

reporter   ~0003671

It has worked. Thank you. I opened port 11371. But installation aborted, see below.

mb@mb-MS-6590:~$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys D79BF92A
Executing: /tmp/tmp.Nk77yLnRkA/gpg.1.sh --keyserver
keyserver.ubuntu.com
--recv-keys
D79BF92A
gpg: Schlüssel C56CCB02D79BF92A: Öffentlicher Schlüssel "Patrick Chevalley <pch@ap-i.net>" importiert
gpg: Anzahl insgesamt bearbeiteter Schlüssel: 1
gpg: importiert: 1

I received a new error message:

mb@mb-MS-6590:~$ sudo apt-get install --no-install-recommends skychart
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 skychart : Hängt ab von: libpng12-0 ist aber nicht installierbar
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

I do not know what that means. Can you give advice?
Thank you.

Patrick Chevalley

17-02-27 20:16

administrator   ~0003672

My package is too old (2014) and contain this too precise reference to libpng12-0 but Yaketty as only libpng16-16

You can add an apt-get option to bypass this check because it will work with libpng16 but it is probably better you change to use the "unstable" version.
Just replace stable by unstable and install the key AA716FC2 as describe in the documentation.

I am in a few week to release a new stable version and the "unstable" is much better than the old stable.

Michael Bauer

17-02-27 22:52

reporter   ~0003673

Topic resolved, skychart runs well and stable.

Bonsoir Patrick, je te remercie beaucoup pour ton aide. Tout marche bien pour le moment. Avec le nouveau cle AA716FC2 le probleme etait resolu et j'ai change au logiciel unstable.

Nos bonjours de carneval en Suisse!

Michael Bauer
Landshut
Allemagne

Patrick Chevalley

17-02-28 11:34

administrator   ~0003675

Merci!

I try to update the stable version to 4.0 as soon as possible.

After it is available you can switch back to "stable" if you want to avoid too frequent update.

Issue History

Date Modified Username Field Change
17-02-26 22:24 Michael Bauer New Issue
17-02-27 08:36 Patrick Chevalley Assigned To => Patrick Chevalley
17-02-27 08:36 Patrick Chevalley Status new => feedback
17-02-27 08:36 Patrick Chevalley Note Added: 0003664
17-02-27 12:57 Michael Bauer Note Added: 0003665
17-02-27 12:57 Michael Bauer Status feedback => assigned
17-02-27 15:48 Patrick Chevalley Status assigned => feedback
17-02-27 15:48 Patrick Chevalley Note Added: 0003669
17-02-27 19:42 Michael Bauer Note Added: 0003671
17-02-27 19:42 Michael Bauer Status feedback => assigned
17-02-27 20:16 Patrick Chevalley Note Added: 0003672
17-02-27 22:52 Michael Bauer Note Added: 0003673
17-02-28 11:34 Patrick Chevalley Status assigned => resolved
17-02-28 11:34 Patrick Chevalley Resolution open => fixed
17-02-28 11:34 Patrick Chevalley Fixed in Version => 3.11 SVN
17-02-28 11:34 Patrick Chevalley Target Version => 4.0
17-02-28 11:34 Patrick Chevalley Note Added: 0003675