View Issue Details

IDProjectCategoryView StatusLast Update
0001673SkyChart1-Softwarepublic17-03-11 11:19
ReporterDavid EckbladAssigned ToPatrick Chevalley 
PrioritylowSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
PlatformDell 6420OSWindows 64bitOS Version7
Product Version3.11 SVN 
Target Version4.0Fixed in Version3.11 SVN 
Summary0001673: Access Denied when Zooming or Panning with Mouse
DescriptionAt random intervals, while zooming with mousewheel or panning with mouse cursor, I will get "Access Denied" error.



Steps To ReproduceClick and drag to pan or mousewheel zoom in and out.
Additional InformationI'm still experiencing this issue under the latest 3.11-svn-3557.

It happens both when running with normal permissions or "run as administrator"

This is a fresh install. No files in the /Ciel/ folder before installing.

If you can provide steps to generate a debug log, or provide any direction for me to help you solve this problem, I'm more than happy to oblige.

Thank you.
TagsNo tags attached.

Activities

David Eckblad

17-03-08 03:04

reporter   ~0003695

I may have some additional information. It seemed to be related to draw order or redrawing. I turned off each "show" option on the toolbar until the problem no longer occurred. It appears the "Show Planets" option is what causes this error. I have reliably scrolled and zoomed with no error for over 60 secconds when this is off. After "Show Planets" is turned on, I see the error within a few seconds of zooming or panning again.

Patrick Chevalley

17-03-08 09:16

administrator   ~0003696

This problem is because of some file permission but I never get enough feedback from affected users to be sure how to fix it.

Can you open a command prompt window in C:\Users\[username]\AppData\Local\skychart
Type the two following command and copy the output here:
dir /Q /S
attrib /D /S

David Eckblad

17-03-08 17:07

reporter   ~0003697

Thank you! I will do my best to help you in this matter.

In this output, filePerms.txt is a file I generated with the output of those two msdos commands.

 Volume in drive C has no label.
 Volume Serial Number is BC6E-E536

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart

03/08/2017 10:02 AM <DIR> BUILTIN\Administrators .
03/08/2017 10:02 AM <DIR> Sirius\mrBlaQ ..
02/23/2017 02:59 AM <DIR> Sirius\mrBlaQ Archive
03/08/2017 10:02 AM 228,624 BUILTIN\Administrators cdc_trace.txt
03/08/2017 05:59 AM <DIR> Sirius\mrBlaQ database
03/06/2017 11:20 PM <DIR> Sirius\mrBlaQ ds2000
03/08/2017 10:02 AM 0 Sirius\mrBlaQ filePerms.txt
02/23/2017 02:59 AM <DIR> Sirius\mrBlaQ MPC
03/08/2017 12:35 AM <DIR> Sirius\mrBlaQ pictures
02/23/2017 02:59 AM <DIR> Sirius\mrBlaQ satellites
03/08/2017 10:02 AM 145 Sirius\mrBlaQ scope.ini
02/23/2017 02:59 AM <DIR> Sirius\mrBlaQ script
03/08/2017 10:02 AM 23,784 BUILTIN\Administrators skychart.ini
02/23/2017 03:23 PM 11,879 Sirius\mrBlaQ skychart.ini1
03/07/2017 08:02 PM <DIR> Sirius\mrBlaQ tmp
03/08/2017 12:05 AM <DIR> BUILTIN\Administrators VarObs
02/23/2017 02:59 AM <DIR> Sirius\mrBlaQ vo
               5 File(s) 264,432 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\Archive

02/23/2017 02:59 AM <DIR> Sirius\mrBlaQ .
02/23/2017 02:59 AM <DIR> BUILTIN\Administrators ..
               0 File(s) 0 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\database

03/08/2017 05:59 AM <DIR> Sirius\mrBlaQ .
03/08/2017 05:59 AM <DIR> BUILTIN\Administrators ..
03/08/2017 05:59 AM 2,683,904 Sirius\mrBlaQ cdc.db
02/23/2017 03:00 AM 96 Sirius\mrBlaQ LoadAsteroidFile.log
02/23/2017 03:00 AM 143 Sirius\mrBlaQ LoadCometFile.log
02/23/2017 03:00 AM 0 Sirius\mrBlaQ LoadCountryList.log
02/23/2017 03:00 AM 68 Sirius\mrBlaQ LoadSampleData.log
02/23/2017 03:00 AM 68 Sirius\mrBlaQ LoadUSLocation.log
02/23/2017 03:00 AM 69 Sirius\mrBlaQ LoadWorldLocation.log
               7 File(s) 2,684,348 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\ds2000

03/06/2017 11:20 PM <DIR> Sirius\mrBlaQ .
03/06/2017 11:20 PM <DIR> BUILTIN\Administrators ..
03/06/2017 05:37 AM 1,251 Sirius\mrBlaQ d2k.hdr
03/06/2017 05:37 AM 9,232 Sirius\mrBlaQ d2k.info2
03/06/2017 05:37 AM 4,247 Sirius\mrBlaQ d2k.prj
03/06/2017 05:37 AM 7,702 Sirius\mrBlaQ ds2000.cdc3
               4 File(s) 22,432 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\MPC

02/23/2017 02:59 AM <DIR> Sirius\mrBlaQ .
02/23/2017 02:59 AM <DIR> BUILTIN\Administrators ..
               0 File(s) 0 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\pictures

03/08/2017 12:35 AM <DIR> Sirius\mrBlaQ .
03/08/2017 12:35 AM <DIR> BUILTIN\Administrators ..
03/08/2017 12:41 AM 3,058,560 BUILTIN\Administrators $temp.fit
03/08/2017 12:41 AM 3,058,560 BUILTIN\Administrators $temp.fit.gz
               2 File(s) 6,117,120 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\satellites

02/23/2017 02:59 AM <DIR> Sirius\mrBlaQ .
02/23/2017 02:59 AM <DIR> BUILTIN\Administrators ..
02/23/2017 02:59 AM <DIR> Sirius\mrBlaQ Archive
               0 File(s) 0 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\satellites\Archive

02/23/2017 02:59 AM <DIR> Sirius\mrBlaQ .
02/23/2017 02:59 AM <DIR> Sirius\mrBlaQ ..
               0 File(s) 0 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\script

02/23/2017 02:59 AM <DIR> Sirius\mrBlaQ .
02/23/2017 02:59 AM <DIR> BUILTIN\Administrators ..
               0 File(s) 0 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\tmp

03/07/2017 08:02 PM <DIR> Sirius\mrBlaQ .
03/07/2017 08:02 PM <DIR> BUILTIN\Administrators ..
03/06/2017 10:27 PM <DIR> Sirius\mrBlaQ 32
03/07/2017 08:02 PM 80 BUILTIN\Administrators grs.txt
03/06/2017 11:31 PM 33,803 Sirius\mrBlaQ info.png
03/07/2017 08:02 PM 40 BUILTIN\Administrators origin.txt
03/06/2017 10:28 PM 260 Sirius\mrBlaQ planet.png
03/06/2017 10:28 PM 645 Sirius\mrBlaQ tmp.config
               5 File(s) 34,828 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\tmp\32

03/06/2017 10:27 PM <DIR> Sirius\mrBlaQ .
03/06/2017 10:27 PM <DIR> Sirius\mrBlaQ ..
03/06/2017 10:27 PM 2,199 Sirius\mrBlaQ earth.jpg
03/06/2017 10:28 PM 299,136 Sirius\mrBlaQ FreeMonoBold.ttf
03/06/2017 10:27 PM 1,808 Sirius\mrBlaQ moon.jpg
03/06/2017 10:28 PM 3,597 Sirius\mrBlaQ xplanet.config
03/06/2017 10:28 PM 3,601 Sirius\mrBlaQ xplanet2.config
03/06/2017 10:28 PM 3,473 Sirius\mrBlaQ xplanet3.config
               6 File(s) 313,814 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\VarObs

03/08/2017 12:05 AM <DIR> BUILTIN\Administrators .
03/08/2017 12:05 AM <DIR> BUILTIN\Administrators ..
03/06/2017 05:37 AM 5,665 BUILTIN\Administrators aavsoeasy.dat
03/08/2017 12:05 AM <DIR> BUILTIN\Administrators afoevdata
03/08/2017 12:05 AM <DIR> BUILTIN\Administrators quicklook
03/08/2017 12:05 AM 1,392 BUILTIN\Administrators varobs.ini
               2 File(s) 7,057 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\VarObs\afoevdata

03/08/2017 12:05 AM <DIR> BUILTIN\Administrators .
03/08/2017 12:05 AM <DIR> BUILTIN\Administrators ..
               0 File(s) 0 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\VarObs\quicklook

03/08/2017 12:05 AM <DIR> BUILTIN\Administrators .
03/08/2017 12:05 AM <DIR> BUILTIN\Administrators ..
               0 File(s) 0 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\vo

02/23/2017 02:59 AM <DIR> Sirius\mrBlaQ .
02/23/2017 02:59 AM <DIR> BUILTIN\Administrators ..
               0 File(s) 0 bytes

     Total Files Listed:
              31 File(s) 9,444,031 bytes
              44 Dir(s) 106,603,634,688 bytes free
A I C:\Users\mrBlaQ\AppData\Local\skychart\database\cdc.db
A I C:\Users\mrBlaQ\AppData\Local\skychart\database\LoadAsteroidFile.log
A I C:\Users\mrBlaQ\AppData\Local\skychart\database\LoadCometFile.log
A I C:\Users\mrBlaQ\AppData\Local\skychart\database\LoadCountryList.log
A I C:\Users\mrBlaQ\AppData\Local\skychart\database\LoadSampleData.log
A I C:\Users\mrBlaQ\AppData\Local\skychart\database\LoadUSLocation.log
A I C:\Users\mrBlaQ\AppData\Local\skychart\database\LoadWorldLocation.log
A I C:\Users\mrBlaQ\AppData\Local\skychart\ds2000\d2k.hdr
A I C:\Users\mrBlaQ\AppData\Local\skychart\ds2000\d2k.info2
A I C:\Users\mrBlaQ\AppData\Local\skychart\ds2000\d2k.prj
A I C:\Users\mrBlaQ\AppData\Local\skychart\ds2000\ds2000.cdc3
A I C:\Users\mrBlaQ\AppData\Local\skychart\pictures\$temp.fit
A I C:\Users\mrBlaQ\AppData\Local\skychart\pictures\$temp.fit.gz
        I C:\Users\mrBlaQ\AppData\Local\skychart\satellites\Archive
A I C:\Users\mrBlaQ\AppData\Local\skychart\tmp\32\earth.jpg
A I C:\Users\mrBlaQ\AppData\Local\skychart\tmp\32\FreeMonoBold.ttf
A I C:\Users\mrBlaQ\AppData\Local\skychart\tmp\32\moon.jpg
A I C:\Users\mrBlaQ\AppData\Local\skychart\tmp\32\xplanet.config
A I C:\Users\mrBlaQ\AppData\Local\skychart\tmp\32\xplanet2.config
A I C:\Users\mrBlaQ\AppData\Local\skychart\tmp\32\xplanet3.config
        I C:\Users\mrBlaQ\AppData\Local\skychart\tmp\32
A I C:\Users\mrBlaQ\AppData\Local\skychart\tmp\grs.txt
A I C:\Users\mrBlaQ\AppData\Local\skychart\tmp\info.png
A I C:\Users\mrBlaQ\AppData\Local\skychart\tmp\origin.txt
A I C:\Users\mrBlaQ\AppData\Local\skychart\tmp\planet.png
A I C:\Users\mrBlaQ\AppData\Local\skychart\tmp\tmp.config
A I C:\Users\mrBlaQ\AppData\Local\skychart\VarObs\aavsoeasy.dat
        I C:\Users\mrBlaQ\AppData\Local\skychart\VarObs\afoevdata
        I C:\Users\mrBlaQ\AppData\Local\skychart\VarObs\quicklook
A I C:\Users\mrBlaQ\AppData\Local\skychart\VarObs\varobs.ini
        I C:\Users\mrBlaQ\AppData\Local\skychart\Archive
A I C:\Users\mrBlaQ\AppData\Local\skychart\cdc_trace.txt
        I C:\Users\mrBlaQ\AppData\Local\skychart\database
        I C:\Users\mrBlaQ\AppData\Local\skychart\ds2000
A I C:\Users\mrBlaQ\AppData\Local\skychart\filePerms.txt
        I C:\Users\mrBlaQ\AppData\Local\skychart\MPC
        I C:\Users\mrBlaQ\AppData\Local\skychart\pictures
        I C:\Users\mrBlaQ\AppData\Local\skychart\satellites
A I C:\Users\mrBlaQ\AppData\Local\skychart\scope.ini
        I C:\Users\mrBlaQ\AppData\Local\skychart\script
A I C:\Users\mrBlaQ\AppData\Local\skychart\skychart.ini
A I C:\Users\mrBlaQ\AppData\Local\skychart\skychart.ini1
        I C:\Users\mrBlaQ\AppData\Local\skychart\tmp
        I C:\Users\mrBlaQ\AppData\Local\skychart\VarObs
        I C:\Users\mrBlaQ\AppData\Local\skychart\vo

Patrick Chevalley

17-03-09 10:48

administrator   ~0003698

Thank you for your response!

The attrib command do not show any read-only file, so the problem must be file ownership.

There is a big mix of Administrator and your user owning the different files and folder, probably because one or the other create the file the first time you use a function.
This make difficult to test every file in this folders. At the moment the program only test for write access in the base directory.

I make a change to the program that must solve the issue by using a separate directory for the config and work files when you run as administrator.

The drawback is you have to configure the program again when running as admin. But as I already say in another issue you not have any real reason to run Skychart as admin.

You can test this new version, download the file from
https://sourceforge.net/projects/skychart/files/0-beta/2017-03-09/

Before to run it, you must fix your configuration directory.

You can try to take full ownership of C:\Users\mrBlaQ\AppData\Local\skychart for your user, this is explained here for example: http://winaero.com/blog/how-to-take-ownership-and-get-full-access-to-files-and-folders-in-windows-10/
Then check you not see any BUILTIN\Administrators with dir /Q /S

Or delete the directory but you will lost your configuration.

David Eckblad

17-03-09 20:39

reporter   ~0003699

I'm sorry to say that changing the owner permissions did not fix this problem. This is if I run as mrBlaQ or Administrator. Attached here is dir /q /s before permission changes. I will make a second note with an attachment showing the permissions after I changed owner.

owners.txt (4,808 bytes)
 Volume in drive C has no label.
 Volume Serial Number is BC6E-E536

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart

03/09/2017  01:30 PM    <DIR>          BUILTIN\Administrators .
03/09/2017  01:30 PM    <DIR>          Sirius\mrBlaQ          ..
03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          Archive
03/09/2017  01:28 PM            37,601 Sirius\mrBlaQ          cdc_trace.txt
03/09/2017  01:27 PM    <DIR>          Sirius\mrBlaQ          database
03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          ds2000
03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          MPC
03/09/2017  01:30 PM                 0 Sirius\mrBlaQ          owners.txt
03/09/2017  01:27 PM    <DIR>          Sirius\mrBlaQ          pictures
03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          satellites
03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          script
03/09/2017  01:28 PM            23,621 BUILTIN\Administrators skychart.ini
03/09/2017  01:26 PM    <DIR>          Sirius\mrBlaQ          tmp
03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          vo
               3 File(s)         61,222 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\Archive

03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          .
03/09/2017  01:25 PM    <DIR>          BUILTIN\Administrators ..
               0 File(s)              0 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\database

03/09/2017  01:27 PM    <DIR>          Sirius\mrBlaQ          .
03/09/2017  01:27 PM    <DIR>          BUILTIN\Administrators ..
03/09/2017  01:27 PM         2,266,112 Sirius\mrBlaQ          cdc.db
03/09/2017  01:25 PM                96 Sirius\mrBlaQ          LoadAsteroidFile.log
03/09/2017  01:25 PM               143 Sirius\mrBlaQ          LoadCometFile.log
03/09/2017  01:25 PM                 0 Sirius\mrBlaQ          LoadCountryList.log
03/09/2017  01:25 PM                68 Sirius\mrBlaQ          LoadSampleData.log
03/09/2017  01:25 PM                68 Sirius\mrBlaQ          LoadUSLocation.log
03/09/2017  01:25 PM                69 Sirius\mrBlaQ          LoadWorldLocation.log
               7 File(s)      2,266,556 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\ds2000

03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          .
03/09/2017  01:25 PM    <DIR>          BUILTIN\Administrators ..
03/09/2017  09:37 AM             1,251 Sirius\mrBlaQ          d2k.hdr
03/09/2017  09:37 AM             9,232 Sirius\mrBlaQ          d2k.info2
03/09/2017  09:37 AM             4,247 Sirius\mrBlaQ          d2k.prj
03/09/2017  09:37 AM             7,702 Sirius\mrBlaQ          ds2000.cdc3
               4 File(s)         22,432 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\MPC

03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          .
03/09/2017  01:25 PM    <DIR>          BUILTIN\Administrators ..
               0 File(s)              0 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\pictures

03/09/2017  01:27 PM    <DIR>          Sirius\mrBlaQ          .
03/09/2017  01:27 PM    <DIR>          BUILTIN\Administrators ..
03/09/2017  01:27 PM         3,058,560 Sirius\mrBlaQ          $temp.fit
03/09/2017  01:27 PM         3,058,560 Sirius\mrBlaQ          $temp.fit.gz
               2 File(s)      6,117,120 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\satellites

03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          .
03/09/2017  01:25 PM    <DIR>          BUILTIN\Administrators ..
03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          Archive
               0 File(s)              0 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\satellites\Archive

03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          .
03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          ..
               0 File(s)              0 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\script

03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          .
03/09/2017  01:25 PM    <DIR>          BUILTIN\Administrators ..
               0 File(s)              0 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\tmp

03/09/2017  01:26 PM    <DIR>          Sirius\mrBlaQ          .
03/09/2017  01:26 PM    <DIR>          BUILTIN\Administrators ..
               0 File(s)              0 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\vo

03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          .
03/09/2017  01:25 PM    <DIR>          BUILTIN\Administrators ..
               0 File(s)              0 bytes

     Total Files Listed:
              16 File(s)      8,467,330 bytes
              32 Dir(s)  120,806,998,016 bytes free
owners.txt (4,808 bytes)

David Eckblad

17-03-09 20:39

reporter   ~0003700

Here's file permissions after taking ownership.

ownersAfter.txt (4,887 bytes)
 Volume in drive C has no label.
 Volume Serial Number is BC6E-E536

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart

03/09/2017  01:32 PM    <DIR>          Sirius\mrBlaQ          .
03/09/2017  01:32 PM    <DIR>          Sirius\mrBlaQ          ..
03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          Archive
03/09/2017  01:28 PM            37,601 Sirius\mrBlaQ          cdc_trace.txt
03/09/2017  01:27 PM    <DIR>          Sirius\mrBlaQ          database
03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          ds2000
03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          MPC
03/09/2017  01:30 PM             4,808 Sirius\mrBlaQ          owners.txt
03/09/2017  01:32 PM                 0 Sirius\mrBlaQ          ownersAfter.txt
03/09/2017  01:27 PM    <DIR>          Sirius\mrBlaQ          pictures
03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          satellites
03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          script
03/09/2017  01:28 PM            23,621 Sirius\mrBlaQ          skychart.ini
03/09/2017  01:26 PM    <DIR>          Sirius\mrBlaQ          tmp
03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          vo
               4 File(s)         66,030 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\Archive

03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          .
03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          ..
               0 File(s)              0 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\database

03/09/2017  01:27 PM    <DIR>          Sirius\mrBlaQ          .
03/09/2017  01:27 PM    <DIR>          Sirius\mrBlaQ          ..
03/09/2017  01:27 PM         2,266,112 Sirius\mrBlaQ          cdc.db
03/09/2017  01:25 PM                96 Sirius\mrBlaQ          LoadAsteroidFile.log
03/09/2017  01:25 PM               143 Sirius\mrBlaQ          LoadCometFile.log
03/09/2017  01:25 PM                 0 Sirius\mrBlaQ          LoadCountryList.log
03/09/2017  01:25 PM                68 Sirius\mrBlaQ          LoadSampleData.log
03/09/2017  01:25 PM                68 Sirius\mrBlaQ          LoadUSLocation.log
03/09/2017  01:25 PM                69 Sirius\mrBlaQ          LoadWorldLocation.log
               7 File(s)      2,266,556 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\ds2000

03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          .
03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          ..
03/09/2017  09:37 AM             1,251 Sirius\mrBlaQ          d2k.hdr
03/09/2017  09:37 AM             9,232 Sirius\mrBlaQ          d2k.info2
03/09/2017  09:37 AM             4,247 Sirius\mrBlaQ          d2k.prj
03/09/2017  09:37 AM             7,702 Sirius\mrBlaQ          ds2000.cdc3
               4 File(s)         22,432 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\MPC

03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          .
03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          ..
               0 File(s)              0 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\pictures

03/09/2017  01:27 PM    <DIR>          Sirius\mrBlaQ          .
03/09/2017  01:27 PM    <DIR>          Sirius\mrBlaQ          ..
03/09/2017  01:27 PM         3,058,560 Sirius\mrBlaQ          $temp.fit
03/09/2017  01:27 PM         3,058,560 Sirius\mrBlaQ          $temp.fit.gz
               2 File(s)      6,117,120 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\satellites

03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          .
03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          ..
03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          Archive
               0 File(s)              0 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\satellites\Archive

03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          .
03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          ..
               0 File(s)              0 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\script

03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          .
03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          ..
               0 File(s)              0 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\tmp

03/09/2017  01:26 PM    <DIR>          Sirius\mrBlaQ          .
03/09/2017  01:26 PM    <DIR>          Sirius\mrBlaQ          ..
               0 File(s)              0 bytes

 Directory of C:\Users\mrBlaQ\AppData\Local\skychart\vo

03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          .
03/09/2017  01:25 PM    <DIR>          Sirius\mrBlaQ          ..
               0 File(s)              0 bytes

     Total Files Listed:
              17 File(s)      8,472,138 bytes
              32 Dir(s)  120,807,047,168 bytes free
ownersAfter.txt (4,887 bytes)

Patrick Chevalley

17-03-09 20:51

administrator   ~0003701

Very interesting ...

Can run the program with your user until you get the problem, then zip the files cdc_trace.txt and skychart.ini.
Upload the zip here.

David Eckblad

17-03-09 21:08

reporter   ~0003702

The error had occurred twice when generating this cdc_trace. I don't see anything indicating an error in that log file, though.

skychart-debug.zip (8,284 bytes)

Patrick Chevalley

17-03-09 21:55

administrator   ~0003703

No luck, I just replace your username by mine in skychart.ini and I cannot get the error.

To get more information in cdc_trace you need to start the program with the --verbose option.
You can open a DOS prompt in C:\Program Files\Ciel and type: skychart.exe --verbose

Can you also confirm that you still not get the crash if you not show the planet?

If this is the case can you try to enable the planet but change "Draw planet" option to "Line mode drawing" in Setup/Solar system/Planet

David Eckblad

17-03-09 23:24

reporter   ~0003704

Attached is a new verbose log file where I was able to cause the error and then immediately close the application.

Changing to Line Mode Drawing does appear to side-step the issue. So, it does appear to be related to those raster graphics?

cdc_trace.zip (8,338 bytes)

Patrick Chevalley

17-03-10 09:24

administrator   ~0003705

Can you try with the program in the skychart.zip attached here.
(unzip in your document folder, then replace skychart.exe in C:\Program Files\Ciel)

It add more detail in the cdc_trace file for the planet process.

David Eckblad

17-03-10 18:55

reporter   ~0003706

Here you go. I ran cartes until I got the error, clicked "ok" and then immediately exited and saved this cdc_trace

cdc_trace-2.zip (3,149 bytes)

Patrick Chevalley

17-03-10 21:20

administrator   ~0003707

Nothing more in the trace, so the problem is not with the planet bitmap itself.

This lead to a single place where a file is written after the "draw planet" message and before the bitmap processing.
And there is a potential problem here because a single file is written and deleted very quickly a number of time if the planets are not in the map.

I make a new version where I add a message at this place and reduce this file overhead. It is possible this fix the problem.
Can you try this version and test if the problem is still present.
This is in skychart-test-fix.zip here.

David Eckblad

17-03-10 21:27

reporter   ~0003708

It works now! :)

I haven't had one crash in a few minutes of zooming or panning.

I've attached another cdc_trace for you to confirm.

Thank you!

cdc_trace-working.zip (91,119 bytes)

Patrick Chevalley

17-03-11 11:19

administrator   ~0003710

Nice! thank you very much for your help!

I make a new version 3.11-3561 available from
https://sourceforge.net/projects/skychart/files/0-beta/2017-03-11/

I also revert the change with the separate admin config directory and I am interested if you can test with mixed run as standard user and admin.
Please reopen this issue if you have any problem.

The fix is in revision 3560:
https://sourceforge.net/p/skychart/code/3560/

Issue History

Date Modified Username Field Change
17-03-08 02:55 David Eckblad New Issue
17-03-08 03:04 David Eckblad Note Added: 0003695
17-03-08 09:16 Patrick Chevalley Assigned To => Patrick Chevalley
17-03-08 09:16 Patrick Chevalley Status new => feedback
17-03-08 09:16 Patrick Chevalley Target Version => 4.0
17-03-08 09:16 Patrick Chevalley Note Added: 0003696
17-03-08 17:07 David Eckblad Note Added: 0003697
17-03-08 17:07 David Eckblad Status feedback => assigned
17-03-09 10:48 Patrick Chevalley Status assigned => feedback
17-03-09 10:48 Patrick Chevalley Note Added: 0003698
17-03-09 20:39 David Eckblad File Added: owners.txt
17-03-09 20:39 David Eckblad Note Added: 0003699
17-03-09 20:39 David Eckblad Status feedback => assigned
17-03-09 20:39 David Eckblad File Added: ownersAfter.txt
17-03-09 20:39 David Eckblad Note Added: 0003700
17-03-09 20:51 Patrick Chevalley Note Added: 0003701
17-03-09 21:08 David Eckblad File Added: skychart-debug.zip
17-03-09 21:08 David Eckblad Note Added: 0003702
17-03-09 21:55 Patrick Chevalley Status assigned => feedback
17-03-09 21:55 Patrick Chevalley Note Added: 0003703
17-03-09 23:24 David Eckblad File Added: cdc_trace.zip
17-03-09 23:24 David Eckblad Note Added: 0003704
17-03-09 23:24 David Eckblad Status feedback => assigned
17-03-10 09:15 Patrick Chevalley File Added: skychart.zip
17-03-10 09:24 Patrick Chevalley Status assigned => feedback
17-03-10 09:24 Patrick Chevalley Note Added: 0003705
17-03-10 18:55 David Eckblad File Added: cdc_trace-2.zip
17-03-10 18:55 David Eckblad Note Added: 0003706
17-03-10 18:55 David Eckblad Status feedback => assigned
17-03-10 21:07 Patrick Chevalley File Deleted: skychart.zip
17-03-10 21:08 Patrick Chevalley File Added: skychart-test-fix.zip
17-03-10 21:20 Patrick Chevalley Status assigned => feedback
17-03-10 21:20 Patrick Chevalley Note Added: 0003707
17-03-10 21:27 David Eckblad File Added: cdc_trace-working.zip
17-03-10 21:27 David Eckblad Note Added: 0003708
17-03-10 21:27 David Eckblad Status feedback => assigned
17-03-11 11:12 Patrick Chevalley File Deleted: skychart-test-fix.zip
17-03-11 11:19 Patrick Chevalley Status assigned => resolved
17-03-11 11:19 Patrick Chevalley Resolution open => fixed
17-03-11 11:19 Patrick Chevalley Fixed in Version => 3.11 SVN
17-03-11 11:19 Patrick Chevalley Note Added: 0003710