View Issue Details

IDProjectCategoryView StatusLast Update
0001674SkyChart1-Softwarepublic17-03-11 12:25
ReporterSasaAssigned ToPatrick Chevalley 
PrioritynormalSeveritytrivialReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformLinuxOSLubuntu 32-bitOS Version16.10
Product Version3.11 SVN 
Target Version4.0Fixed in Version3.11 SVN 
Summary0001674: Celaning temp images failing
DescriptionInstalling latest .deb (SVN 3559), I have just noticed cleanint tmp dir from temporary different sized images does not work. The old created images from some few weeks old release remain still.

It seems that some hardcoded number may be missing or there is some other issue.

I would also suggest some separated .inc file with current version const instead, for easier maintenance.
TagsNo tags attached.

Activities

Patrick Chevalley

17-03-11 11:10

administrator   ~0003709

This directories are purged only if the constant cdcver change.
The last time was on February 15 when I set it to 3.11y.

I checked that I have no directory older than February 16, so I thing the cleanup work.
Can you check you tmp directory for this dates.

I can add an include file with only the version info cdcversion and cdcver, but not in revision.inc because this one contain the svn revision number at build time and it is automatically updated by my build script.

Sasa

17-03-11 11:42

reporter   ~0003711

Last edited: 17-03-11 11:42

View 2 revisions

There is no date before Feb 15 and I'm positive cleaning worked fine few revisions ago. I remember actually you wrote that version will be changed on every new release and then I actually noted that is not the case always and note the constant is hardcoded and not changed before release. That why I consider separated .inc may be more convenience instead hardcoding.

In any event, temp dirs may be cleaned (new version changed) only on every planet/satellite image change (coming with new installation/update) as currently is, except Sun which user may update whenever is desired.

Patrick Chevalley

17-03-11 12:25

administrator   ~0003712

I put the version in a separate file so it is more easy to track:
https://sourceforge.net/p/skychart/code/3562/

I set tmp cleanup on every version change when we are working actively to this part of the program and xplanet config or bitmap change very often.
Now it is stable I change that in Tf_main.UpdateConfig to cleanup selectively, the same as for the other options change:
https://sourceforge.net/p/skychart/code/3563/

Issue History

Date Modified Username Field Change
17-03-10 07:29 Sasa New Issue
17-03-11 11:10 Patrick Chevalley Assigned To => Patrick Chevalley
17-03-11 11:10 Patrick Chevalley Status new => assigned
17-03-11 11:10 Patrick Chevalley Target Version => 4.0
17-03-11 11:10 Patrick Chevalley Note Added: 0003709
17-03-11 11:42 Sasa Note Added: 0003711
17-03-11 11:42 Sasa Note Edited: 0003711 View Revisions
17-03-11 12:25 Patrick Chevalley Status assigned => resolved
17-03-11 12:25 Patrick Chevalley Resolution open => fixed
17-03-11 12:25 Patrick Chevalley Fixed in Version => 3.11 SVN
17-03-11 12:25 Patrick Chevalley Note Added: 0003712